CabinJS CabinJS

grunt-pages

3 21 1

Grunt task to create HTML pages using markdown and templates

You have 1 open security alert

Dependencies

Package Locked Requirement Latest Status Changelog
Npms colors ~0.6.0-1 1.1.2

colors

get colors in your node.js console

This dependency is not matching latest version. Please consider upgrading.

Npms ejs ~0.8.4 2.3.2

ejs

Embedded JavaScript templates

This dependency is not matching latest version. Please consider upgrading.

Npms handlebars ~1.3.0 3.0.3

handlebars

Handlebars provides the power necessary to let you build semantic templates effectively with no frustration

This dependency is not matching latest version. Please consider upgrading.

Npms jade ~1.0.0 1.11.0

jade

A clean, whitespace-sensitive template language for writing HTML

This dependency is not matching latest version. Please consider upgrading.

Npms lodash ~2.4.1 3.10.0

lodash

The modern build of lodash modular utilities.

This dependency is not matching latest version. Please consider upgrading.

Npms marked ~0.3.0 0.3.3

marked

A markdown parser built for speed

Security alert:

Npms node-fs ~0.1.7 0.1.7

node-fs

node-fs is an extension to the original nodejs fs library, offering new functionalities.

This dependency is up-to-date. Congrats and keep going!

Npms pygmentize-bundled ~2.1.0 2.3.0

pygmentize-bundled

A simple wrapper around Python's Pygments code formatter, with Pygments bundled

This dependency is not matching latest version. Please consider upgrading.

Npms rss ~0.2.0 1.1.1

rss

RSS feed generator. Add RSS feeds to any project. Supports enclosures and GeoRSS.

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Npms grunt ~0.4.1 0.4.5

grunt

The JavaScript Task Runner

This dependency is up-to-date. Congrats and keep going!

Npms grunt-concurrent ~0.3.1 2.0.0

grunt-concurrent

Run grunt tasks concurrently

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-clean ~0.4.1 0.6.0

grunt-contrib-clean

Clean files and folders.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-connect ~0.3.0 0.10.1

grunt-contrib-connect

Start a connect web server

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-copy ~0.4.1 0.8.0

grunt-contrib-copy

Copy files and folders

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-jshint ^0.10.0 0.11.2

grunt-contrib-jshint

Validate files with JSHint.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-watch ~0.4.4 0.6.1

grunt-contrib-watch

Run predefined tasks whenever watched file patterns are added, changed or deleted.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-mdlint 0.0.0 0.0.1

grunt-mdlint

Runs mdlint to lint JavaScript code blocks in your project's markdown files

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-node-inspector ~0.1.0 0.2.0

grunt-node-inspector

Run node-inspector with the rest of your workflow to debug node.js

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-release ~0.4.0 0.13.0

grunt-release

Release a new version of your Node-based project

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-shell ~0.4.0 1.1.2

grunt-shell

Run shell commands

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-simple-mocha ~0.4.0 0.4.0

grunt-simple-mocha

A simple wrapper for running tests with Mocha.

This dependency is up-to-date. Congrats and keep going!

Npms matchdep ~0.1.2 0.3.0

matchdep

Use globule to filter npm module dependencies by name.

This dependency is not matching latest version. Please consider upgrading.

Npms q ~0.9.7 1.4.1

q

A library for promises (CommonJS/Promises/A,B,D)

This dependency is not matching latest version. Please consider upgrading.

Npms should ~1.2.2 7.0.1

should

test framework agnostic BDD-style assertions

This dependency is not matching latest version. Please consider upgrading.

Npms sinon ~1.7.3 1.15.4

sinon

JavaScript test spies, stubs and mocks.

This dependency is not matching latest version. Please consider upgrading.