cocoapods cocoapods

CocoaPods

18 10 0

The Cocoa Dependency Manager.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems activesupport 4.2.4 >= 3.2.15 4.2.4

activesupport version 4.2.4

A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.

This dependency is up-to-date. Congrats and keep going!

Gems claide 0.9.1 ~> 0.9.1 0.9.1

claide version 0.9.1

A small command-line interface framework.

This dependency is up-to-date. Congrats and keep going!

Gems cocoapods-downloader 0.9.2 ~> 0.9.2 0.9.2

cocoapods-downloader version 0.9.2

A small library for downloading files from remotes in a folder.

This dependency is up-to-date. Congrats and keep going!

Gems cocoapods-plugins 0.4.2 ~> 0.4.2 0.4.2

cocoapods-plugins version 0.4.2

This CocoaPods plugin shows information about all available CocoaPods plugins (yes, this is very meta!). This CP plugin adds the "pod plugins" command to CocoaPods so that you can list all plugins (registered in the reference JSON hosted at CocoaPods/cocoapods-plugins)

This dependency is up-to-date. Congrats and keep going!

Gems cocoapods-stats 0.6.0 ~> 0.6.0

Gems cocoapods-trunk 0.6.2 ~> 0.6.2 0.6.2

cocoapods-trunk version 0.6.2

Interact with trunk.cocoapods.org

This dependency is up-to-date. Congrats and keep going!

Gems cocoapods-try 0.5.0 ~> 0.5.0 0.5.0

cocoapods-try version 0.5.0

CocoaPods plugin which allows to quickly try the demo project of a Pod.

This dependency is up-to-date. Congrats and keep going!

Gems colored 1.2 ~> 1.2 1.2

colored version 1.2

>> puts "this is red".red >> puts "this is red with a blue background (read: ugly)".red_on_blue >> puts "this is red with an underline".red.underline >> puts "this is really bold and really blue".bold.blue >> logger.debug "hey this is broken!".red_on_yellow # in rails >> puts Color.red "This is red" # but this part is mostly untested

This dependency is up-to-date. Congrats and keep going!

Gems escape 0.0.4 ~> 0.0.4 0.0.4

escape version 0.0.4

...

This dependency is up-to-date. Congrats and keep going!

Gems json 1.7.7 = 1.7.7 1.8.3

json version 1.7.7

This is a JSON implementation as a Ruby extension in C.

This dependency is not matching latest version. Please consider upgrading.

Gems molinillo 0.3.1 ~> 0.3.1 0.4.0

molinillo version 0.3.1

Provides support for dependency resolution

This dependency is not matching latest version. Please consider upgrading.

Gems nap 0.8.0 ~> 0.8 1.0.0

nap version 0.8.0

Nap is a really simple REST library. It allows you to perform HTTP requests with minimal amounts of code.

This dependency is not matching latest version. Please consider upgrading.

Gems xcodeproj 0.27.0 ~> 0.27.0 0.27.0

xcodeproj version 0.27.0

Xcodeproj lets you create and modify Xcode projects from Ruby. Script boring management tasks or build Xcode-friendly libraries. Also includes support for Xcode workspaces (.xcworkspace) and configuration files (.xcconfig).

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems awesome_print 1.6.1 >= 0 1.6.1

awesome_print version 1.6.1

Great Ruby dubugging companion: pretty print Ruby objects to visualize their structure. Supports custom object formatting via plugins

This dependency is up-to-date. Congrats and keep going!

Gems bacon 1.2.0 >= 0 1.2.0

bacon version 1.2.0

Bacon is a small RSpec clone weighing less than 350 LoC but nevertheless providing all essential features. http://github.com/chneukirchen/bacon

This dependency is up-to-date. Congrats and keep going!

Gems bundler ~> 1.3 1.10.6

bundler

Bundler manages an application's dependencies through its entire life, across many machines, systematically and repeatably

This dependency is up-to-date. Congrats and keep going!

Gems clintegracon 0.6.1 >= 0 0.7.0

clintegracon version 0.6.1

CLIntegracon allows you to build Integration specs for your CLI,independent if they are based on Ruby or another technology.It is especially useful if your command modifies the file system.It provides an integration for Bacon.

This dependency is not matching latest version. Please consider upgrading.

Gems cocoapods-dependencies 0.4.0 >= 0 0.5.0

cocoapods-dependencies version 0.4.0

Shows a project's CocoaPods dependency graph.

This dependency is not matching latest version. Please consider upgrading.

Gems diffy 3.0.7 >= 0 3.0.7

diffy version 3.0.7

Convenient diffing in ruby

This dependency is up-to-date. Congrats and keep going!

Gems inch 0.5.10 >= 0 0.6.4

inch version 0.5.10

Documentation measurement tool for Ruby, based on YARD.

This dependency is not matching latest version. Please consider upgrading.

Gems kicker 3.0.0 >= 0 3.0.0

kicker version 3.0.0

Allows you to fire specific command on file-system change.

This dependency is up-to-date. Congrats and keep going!

Gems mocha 1.1.0 >= 0 1.1.0

mocha version 1.1.0

Mocking and stubbing library with JMock/SchMock syntax, which allows mocking and stubbing of methods on real (non-mock) classes.

This dependency is up-to-date. Congrats and keep going!

Gems mocha-on-bacon 0.2.2 >= 0 0.2.2

mocha-on-bacon version 0.2.2

A Mocha adapter for Bacon, because it's yummy!

This dependency is up-to-date. Congrats and keep going!

Gems prettybacon 0.0.2 >= 0 0.0.2

prettybacon version 0.0.2

Prettifies Bacon output.

This dependency is up-to-date. Congrats and keep going!

Gems rake 10.4.2 >= 0 10.4.2

rake version 10.4.2

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * A library of prepackaged tasks to make building rakefiles easier. For example, tasks for building tarballs and publishing to FTP or SSH sites. (Formerly tasks for building RDoc and Gems were included in rake but they're now available in RDoc and RubyGems respectively.) * Supports parallel execution of tasks.

This dependency is up-to-date. Congrats and keep going!

Gems rb-fsevent 0.9.4 >= 0 0.9.5

rb-fsevent version 0.9.4

FSEvents API with Signals catching (without RubyCocoa)

This dependency is not matching latest version. Please consider upgrading.

Gems rubocop 0.29.1 >= 0 0.33.0

rubocop version 0.29.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

This dependency is not matching latest version. Please consider upgrading.

Gems ruby-prof 0.15.2 >= 0 0.15.8

ruby-prof version 0.15.2

ruby-prof is a fast code profiler for Ruby. It is a C extension and therefore is many times faster than the standard Ruby profiler. It supports both flat and graph profiles. For each method, graph profiles show how long the method ran, which methods called it and which methods it called. RubyProf generate both text and html and can output it to standard out or to a file.

This dependency is not matching latest version. Please consider upgrading.

Gems webmock 1.20.4 >= 0 1.21.0

webmock version 1.20.4

WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.

This dependency is not matching latest version. Please consider upgrading.