adamhunter adamhunter

dossier

15 2 0

Ruby-based report generation/presentation Rails engine.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems actionmailer >= 3.2 4.2.0

actionmailer

Email on Rails. Compose, deliver, receive, and test emails using the familiar controller/view pattern. First-class support for multipart email and attachments.

This dependency is up-to-date. Congrats and keep going!

Gems actionpack >= 3.2 4.2.0

actionpack

Web apps on Rails. Simple, battle-tested conventions for building and testing MVC web applications. Works with any Rack-compatible server.

This dependency is up-to-date. Congrats and keep going!

Gems activesupport >= 3.2 4.2.0

activesupport

A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.

This dependency is up-to-date. Congrats and keep going!

Gems arel >= 3.0 6.0.0

arel

Arel Really Exasperates Logicians Arel is a SQL AST manager for Ruby. It 1. Simplifies the generation of complex SQL queries 2. Adapts to various RDBMSes It is intended to be a framework framework; that is, you can build your own ORM with it, focusing on innovative object and collection modeling as opposed to database compatibility and query generation.

This dependency is up-to-date. Congrats and keep going!

Gems coveralls >= 0 0.7.11

coveralls

A Ruby implementation of the Coveralls API.

This dependency is up-to-date. Congrats and keep going!

Gems haml >= 3.1 4.0.6

haml

Haml (HTML Abstraction Markup Language) is a layer on top of HTML or XML that's designed to express the structure of documents in a non-repetitive, elegant, and easy way by using indentation rather than closing tags and allowing Ruby to be embedded with ease. It was originally envisioned as a plugin for Ruby on Rails, but it can function as a stand-alone templating engine.

This dependency is up-to-date. Congrats and keep going!

Gems jquery-rails >= 0 4.0.3

jquery-rails

This gem provides jQuery and the jQuery-ujs driver for your Rails 4+ application.

This dependency is up-to-date. Congrats and keep going!

Gems mysql2 >= 0 0.3.18

mysql2

A simple, fast Mysql library for Ruby, binding to libmysql

This dependency is up-to-date. Congrats and keep going!

Gems railties >= 3.2 4.2.0

railties

Rails internals: application bootup, plugins, generators, and rake tasks.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems activerecord >= 3.2 4.2.0

activerecord

Databases on Rails. Build a persistent domain model by mapping database tables to Ruby classes. Strong conventions for associations, validations, aggregations, migrations, and testing come baked-in.

This dependency is up-to-date. Congrats and keep going!

Gems capybara ~> 2.1.0 2.4.4

capybara

Capybara is an integration testing tool for rack based web applications. It simulates how a user would interact with a website

This dependency is not matching latest version. Please consider upgrading.

Gems dummy-application >= 0 1.1.2

dummy-application

Provide a base Rails application for usage in testing rubygems

This dependency is up-to-date. Congrats and keep going!

Gems genspec ~> 0.2.7 0.2.8

genspec

Simple, expressive Thor and/or Rails 3 generator testing for RSpec. For the Rails 2.3 version, use genspec 0.1.x.

This dependency is up-to-date. Congrats and keep going!

Gems pry >= 0.9.10 0.10.1

pry

An IRB alternative and runtime developer console

This dependency is up-to-date. Congrats and keep going!

Gems rspec-rails >= 2.14.1 3.2.1

rspec-rails

RSpec for Rails

This dependency is up-to-date. Congrats and keep going!

Gems simplecov ~> 0.7.1 0.9.2

simplecov

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is not matching latest version. Please consider upgrading.

Gems sqlite3 >= 1.3.6 1.3.10

sqlite3

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is up-to-date. Congrats and keep going!