adhearsion adhearsion

adhearsion

31 7 0

A Ruby framework for building telephony applications

Dependencies

Package Locked Requirement Latest Status Changelog
Gems activesupport < 5.0.0, >= 3.0.0 5.1.2

activesupport

A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.

This dependency is not matching latest version. Please consider upgrading.

Gems adhearsion-loquacious ~> 1.9 1.9.3

adhearsion-loquacious

Descriptive configuration files for Ruby written in Ruby. Loquacious provides a very open configuration system written in ruby and descriptions for each configuration attribute. The attributes and descriptions can be iterated over allowing for helpful information about those attributes to be displayed to the user. In the simple case we have a file something like: Loquacious.configuration_for('app') { name 'value', :desc => "Defines the name" foo 'bar', :desc => "FooBar" id 42, :desc => "Ara T. Howard" } Which can be loaded via the standard Ruby loading mechanisms load 'config/app.rb' The attributes and their descriptions can be printed by using a Help object help = Loquacious.help_for('app') help.show :values => true # show the values for the attributes, too Descriptions are optional, and configurations can be nested arbitrarily deep. Loquacious.configuration_for('nested') { desc "The outermost level" a { desc "One more level in" b { desc "Finally, a real value" c 'value' } } } config = Loquacious.configuration_for 'nested' p config.a.b.c #=> "value" And as you can see, descriptions can either be given inline after the value or they can appear above the attribute and value on their own line.

This dependency is up-to-date. Congrats and keep going!

Gems blather ~> 1.0 1.2.0

blather

An XMPP DSL for Ruby written on top of EventMachine and Nokogiri

This dependency is up-to-date. Congrats and keep going!

Gems bundler ~> 1.0 1.15.3

bundler

Bundler manages an application's dependencies through its entire life, across many machines, systematically and repeatably

This dependency is up-to-date. Congrats and keep going!

Gems celluloid ~> 0.16.0 0.17.3

celluloid

Celluloid enables people to build concurrent programs out of concurrent objects just as easily as they build sequential programs out of sequential objects

This dependency is not matching latest version. Please consider upgrading.

Gems countdownlatch >= 0 1.0.0

countdownlatch

A synchronization aid that allows one or more threads to wait until a set of operations being performed in other threads completes

This dependency is up-to-date. Congrats and keep going!

Gems deep_merge >= 0 1.1.1

deep_merge

Recursively merge hashes.

This dependency is up-to-date. Congrats and keep going!

Gems ffi ~> 1.0 1.9.18

ffi

Ruby FFI library

This dependency is up-to-date. Congrats and keep going!

Gems future-resource ~> 1.0 1.1.0

future-resource

Sometimes a value is set asynchronously and you need to wait until it appears. Easy!

This dependency is up-to-date. Congrats and keep going!

Gems has-guarded-handlers >= 1.6.3, ~> 1.6 1.6.3

has-guarded-handlers

Allow an object's API to provide flexible handler registration, storage and matching to arbitrary events.

This dependency is up-to-date. Congrats and keep going!

Gems http ~> 0.9.8 2.2.2

http

An easy-to-use client library for making requests from Ruby. It uses a simple method chaining system for building requests, similar to Python's Requests.

This dependency is not matching latest version. Please consider upgrading.

Gems i18n ~> 0.6 0.8.6

i18n

New wave Internationalization support for Ruby.

This dependency is up-to-date. Congrats and keep going!

Gems logging ~> 2.0 2.2.2

logging

**Logging** is a flexible logging library for use in Ruby programs based on the design of Java's log4j library. It features a hierarchical logging system, custom level names, multiple output destinations per log event, custom formatting, and more.

This dependency is up-to-date. Congrats and keep going!

Gems nokogiri >= 1.5.6, ~> 1.5 1.8.0

nokogiri

Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. Among Nokogiri's many features is the ability to search documents via XPath or CSS3 selectors.

This dependency is up-to-date. Congrats and keep going!

Gems pry >= 0 0.10.4

pry

An IRB alternative and runtime developer console

This dependency is up-to-date. Congrats and keep going!

Gems rake >= 0 12.0.0

rake

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * Supports parallel execution of tasks.

This dependency is up-to-date. Congrats and keep going!

Gems reel ~> 0.5.0 0.6.1

reel

A Celluloid::IO-powered HTTP server

This dependency is not matching latest version. Please consider upgrading.

Gems reel-rack ~> 0.2.0 0.2.3

reel-rack

Rack adapter for Reel

This dependency is up-to-date. Congrats and keep going!

Gems ruby_ami ~> 2.2 3.0.0

ruby_ami

A Ruby client library for the Asterisk Management Interface built on Celluloid IO.

This dependency is not matching latest version. Please consider upgrading.

Gems ruby_jid ~> 1.0 1.0.0

ruby_jid

Provides parsing, validation & accessors

This dependency is up-to-date. Congrats and keep going!

Gems ruby_speech ~> 2.3 2.3.2

ruby_speech

Prepare SSML and GRXML documents with ease

This dependency is up-to-date. Congrats and keep going!

Gems sinatra >= 0 2.0.0

sinatra

Sinatra is a DSL for quickly creating web applications in Ruby with minimal effort.

This dependency is up-to-date. Congrats and keep going!

Gems state_machine ~> 1.0 1.2.0

state_machine

Adds support for creating state machines for attributes on any Ruby class

This dependency is up-to-date. Congrats and keep going!

Gems thor ~> 0.18.0 0.19.4

thor

Thor is a toolkit for building powerful command-line interfaces.

This dependency is not matching latest version. Please consider upgrading.

Gems virtus ~> 1.0 1.0.5

virtus

Attributes on Steroids for Plain Old Ruby Objects

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems aruba ~> 0.6.0 0.14.2

aruba

Extension for popular TDD and BDD frameworks like "Cucumber", "RSpec" and "Minitest" to make testing commandline applications meaningful, easy and fun.

This dependency is not matching latest version. Please consider upgrading.

Gems ci_reporter_cucumber >= 0 1.0.1

ci_reporter_cucumber

Connects CI::Reporter to Cucumber

This dependency is up-to-date. Congrats and keep going!

Gems ci_reporter_rspec >= 0 1.0.0

ci_reporter_rspec

Connects CI::Reporter to RSpec

This dependency is up-to-date. Congrats and keep going!

Gems coveralls >= 0 0.8.21

coveralls

A Ruby implementation of the Coveralls API.

This dependency is up-to-date. Congrats and keep going!

Gems cucumber >= 0 2.4.0

cucumber

Behaviour Driven Development with elegance and joy

This dependency is up-to-date. Congrats and keep going!

Gems guard-cucumber >= 0 2.1.2

guard-cucumber

Guard::Cucumber automatically run your features (much like autotest)

This dependency is up-to-date. Congrats and keep going!

Gems guard-rspec >= 0 4.7.3

guard-rspec

Guard::RSpec automatically run your specs (much like autotest).

This dependency is up-to-date. Congrats and keep going!

Gems guard-yard >= 0 2.2.0

guard-yard

Guard::Yard automatically monitors Yard Documentation.

This dependency is up-to-date. Congrats and keep going!

Gems rspec ~> 3.0 3.6.0

rspec

BDD for Ruby

This dependency is up-to-date. Congrats and keep going!

Gems simplecov >= 0 0.14.1

simplecov

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is up-to-date. Congrats and keep going!

Gems simplecov-rcov >= 0 0.2.3

simplecov-rcov

Rcov style formatter for SimpleCov

This dependency is up-to-date. Congrats and keep going!

Gems timecop >= 0 0.9.1

timecop

A gem providing "time travel" and "time freezing" capabilities, making it dead simple to test time-dependent code. It provides a unified method to mock Time.now, Date.today, and DateTime.now in a single call.

This dependency is up-to-date. Congrats and keep going!

Gems yard >= 0 0.9.9

yard

YARD is a documentation generation tool for the Ruby programming language. It enables the user to generate consistent, usable documentation that can be exported to a number of formats very easily, and also supports extending for custom Ruby constructs such as custom class level definitions.

This dependency is up-to-date. Congrats and keep going!