8ddbf811da78bb0daeeb3cacd7cf743f?s=64 andrew

24pullrequests

40 11 0

Giving back little gifts of code for Christmas

Dependencies

Package Locked Requirement Latest Status Changelog
Gems anjlab-bootstrap-rails 3.0.3.0 ~> 3.0.3.0 3.0.3.0

anjlab-bootstrap-rails version 3.0.3.0

Bootstrap CSS (with Sass flavour) and JS toolkits for Rails 3 projects

This dependency is up-to-date. Congrats and keep going!

Gems bugsnag 1.6.3 = 1.6.3 1.8.8

bugsnag version 1.6.3

Ruby notifier for bugsnag.com

This dependency is not matching latest version. Please consider upgrading.

Gems coffee-rails 4.0.1 >= 0 4.0.1

coffee-rails version 4.0.1

CoffeeScript adapter for the Rails asset pipeline.

This dependency is up-to-date. Congrats and keep going!

Gems csv_shaper 1.0.0 >= 0 1.0.0

csv_shaper version 1.0.0

Creating CSV files in Ruby is painful! CSV Shaper makes life easier! It's ideal for converting database backed models with attrbiutes into CSV output. It can be used without Rails, but works great with ActiveRecord models and even comes with support for it's own template handling.

This dependency is up-to-date. Congrats and keep going!

Gems dalli 2.7.0 >= 0 2.7.0

dalli version 2.7.0

High performance memcached client for Ruby

This dependency is up-to-date. Congrats and keep going!

Gems ffi 1.9.0 = 1.9.0 1.9.3

ffi version 1.9.0

Ruby FFI library

This dependency is not matching latest version. Please consider upgrading.

Gems foreman 0.63.0 >= 0 0.63.0

foreman version 0.63.0

Process manager for applications with multiple components

This dependency is up-to-date. Congrats and keep going!

Gems haml-rails 0.5.3 >= 0 0.5.3

haml-rails version 0.5.3

Haml-rails provides Haml generators for Rails 3. It also enables Haml as the templating engine for you, so you don't have to screw around in your own application.rb when your Gemfile already clearly indicated what templating engine you have installed. Hurrah.

This dependency is up-to-date. Congrats and keep going!

Gems jquery-rails 3.1.0 >= 0 3.1.0

jquery-rails version 3.1.0

This gem provides jQuery and the jQuery-ujs driver for your Rails 3 application.

This dependency is up-to-date. Congrats and keep going!

Gems kaminari 0.15.1 >= 0 0.15.1

kaminari version 0.15.1

Kaminari is a Scope & Engine based, clean, powerful, agnostic, customizable and sophisticated paginator for Rails 3+

This dependency is up-to-date. Congrats and keep going!

Gems memcachier 0.0.2 >= 0 0.0.2

memcachier version 0.0.2

Simple gem that sets the memcached environment variables to the values of corresponding memcachier environment variables. This makes it seemless to use MemCachier in environments like Heroku using the Dalli or other compatible memcached gem.

This dependency is up-to-date. Congrats and keep going!

Gems newrelic_rpm 3.7.3.204 >= 0 3.7.3.204

newrelic_rpm version 3.7.3.204

New Relic is a performance management system, developed by New Relic, Inc (http://www.newrelic.com). New Relic provides you with deep information about the performance of your web application as it runs in production. The New Relic Ruby Agent is dual-purposed as a either a Gem or plugin, hosted on http://github.com/newrelic/rpm/

This dependency is up-to-date. Congrats and keep going!

Gems octokit 3.0.0 >= 0 3.1.0

octokit version 3.0.0

Simple wrapper for the GitHub API

This dependency is not matching latest version. Please consider upgrading.

Gems omniauth 1.2.1 >= 0 1.2.1

omniauth version 1.2.1

A generalized Rack framework for multiple-provider authentication.

This dependency is up-to-date. Congrats and keep going!

Gems omniauth-github 1.1.1 >= 0 1.1.2

omniauth-github version 1.1.1

Official OmniAuth strategy for GitHub.

This dependency is not matching latest version. Please consider upgrading.

Gems omniauth-twitter 1.0.1 >= 0 1.0.1

omniauth-twitter version 1.0.1

OmniAuth strategy for Twitter

This dependency is up-to-date. Congrats and keep going!

Gems pg 0.17.1 >= 0 0.17.1

pg version 0.17.1

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 8.4 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

This dependency is up-to-date. Congrats and keep going!

Gems rabl 0.9.3 >= 0 0.9.3

rabl version 0.9.3

General ruby templating with json, bson, xml and msgpack support

This dependency is up-to-date. Congrats and keep going!

Gems rack-google-analytics 1.0.0 >= 0 1.1.0

rack-google-analytics version 1.0.0

Simple Rack middleware for implementing google analytics tracking in your Ruby-Rack based project. Supports synchronous and asynchronous insertion and configurable load options.

This dependency is not matching latest version. Please consider upgrading.

Gems rails 4.0.4 = 4.0.4 4.1.0

rails version 4.0.4

Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.

This dependency is not matching latest version. Please consider upgrading.

Gems rails_12factor 0.0.2 >= 0 0.0.2

rails_12factor version 0.0.2

Run Rails the 12factor way

This dependency is up-to-date. Congrats and keep going!

Gems sass-rails 4.0.3 ~> 4.0.0 4.0.3

sass-rails version 4.0.3

Sass adapter for the Rails asset pipeline.

This dependency is up-to-date. Congrats and keep going!

Gems simple_form 3.0.0 = 3.0.0 3.0.2

simple_form version 3.0.0

Forms made easy!

This dependency is not matching latest version. Please consider upgrading.

Gems simplecov 0.8.2 >= 0 0.8.2

simplecov version 0.8.2

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is up-to-date. Congrats and keep going!

Gems twitter 5.0.0 = 5.0.0 5.8.0

twitter version 5.0.0

A Ruby interface to the Twitter API.

This dependency is not matching latest version. Please consider upgrading.

Gems uglifier 2.5.0 >= 0 2.5.0

uglifier version 2.5.0

Uglifier minifies JavaScript files by wrapping UglifyJS to be accessible in Ruby

This dependency is up-to-date. Congrats and keep going!

Gems unicorn 4.8.2 >= 0 4.8.2

unicorn version 4.8.2

\Unicorn is an HTTP server for Rack applications designed to only serve fast clients on low-latency, high-bandwidth connections and take advantage of features in Unix/Unix-like kernels. Slow clients should only be served by placing a reverse proxy capable of fully buffering both the the request and response in between \Unicorn and slow clients.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems better_errors 1.1.0 >= 0 1.1.0

better_errors version 1.1.0

Provides a better error page for Rails and other Rack apps. Includes source code inspection, a live REPL and local/instance variable inspection for all stack frames.

This dependency is up-to-date. Congrats and keep going!

Gems binding_of_caller 0.7.2 >= 0 0.7.2

binding_of_caller version 0.7.2

Retrieve the binding of a method's caller. Can also retrieve bindings even further up the stack.

This dependency is up-to-date. Congrats and keep going!

Gems brakeman 2.4.3 >= 0 2.4.3

brakeman version 2.4.3

Brakeman detects security vulnerabilities in Ruby on Rails applications via static analysis.

This dependency is up-to-date. Congrats and keep going!

Gems chai-jquery-rails 1.2.1 >= 0 1.2.1

chai-jquery-rails version 1.2.1

Adds chai-jquery plugin to rails asset pipeline

This dependency is up-to-date. Congrats and keep going!

Gems coveralls 0.7.0 >= 0 0.7.0

coveralls version 0.7.0

A Ruby implementation of the Coveralls API.

This dependency is up-to-date. Congrats and keep going!

Gems database_cleaner 1.2.0 >= 0 1.2.0

database_cleaner version 1.2.0

Strategies for cleaning databases. Can be used to ensure a clean state for testing.

This dependency is up-to-date. Congrats and keep going!

Gems ejs 1.1.1 >= 0 1.1.1

ejs version 1.1.1

Compile and evaluate EJS (Embedded JavaScript) templates from Ruby.

This dependency is up-to-date. Congrats and keep going!

Gems factory_girl_rails 4.4.1 >= 0 4.4.1

factory_girl_rails version 4.4.1

factory_girl_rails provides integration between factory_girl and rails 3 (currently just automatic factory definition loading)

This dependency is up-to-date. Congrats and keep going!

Gems faker 1.3.0 >= 0 1.3.0

faker version 1.3.0

Faker, a port of Data::Faker from Perl, is used to easily generate fake data: names, addresses, phone numbers, etc.

This dependency is up-to-date. Congrats and keep going!

Gems guard-rspec 4.2.8 >= 0 4.2.8

guard-rspec version 4.2.8

Guard::RSpec automatically run your specs (much like autotest).

This dependency is up-to-date. Congrats and keep going!

Gems guard-spork 1.5.1 >= 0 1.5.1

guard-spork version 1.5.1

Guard::Spork automatically manage Spork DRb servers.

This dependency is up-to-date. Congrats and keep going!

Gems konacha 3.2.1 >= 0 3.2.1

konacha version 3.2.1

Konacha is a Rails engine that allows you to test your JavaScript with the mocha test framework and chai assertion library. It is similar to Jasmine and Evergreen, but does not attempt to be framework agnostic. By sticking with Rails, Konacha can take full advantage of features such as the asset pipeline and engines.

This dependency is up-to-date. Congrats and keep going!

Gems launchy 2.4.2 = 2.4.2 2.4.2

launchy version 2.4.2

Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.

This dependency is up-to-date. Congrats and keep going!

Gems poltergeist 1.4.1 ~> 1.4.0 1.5.0

poltergeist version 1.4.1

Poltergeist is a driver for Capybara that allows you to run your tests on a headless WebKit browser, provided by PhantomJS.

This dependency is not matching latest version. Please consider upgrading.

Gems quiet_assets 1.0.2 >= 0 1.0.2

quiet_assets version 1.0.2

Quiet assets turn off rails assets log.

This dependency is up-to-date. Congrats and keep going!

Gems rb-fsevent 0.9.4 >= 0 0.9.4

rb-fsevent version 0.9.4

FSEvents API with Signals catching (without RubyCocoa)

This dependency is up-to-date. Congrats and keep going!

Gems rspec-rails 2.14.2 >= 0 2.14.2

rspec-rails version 2.14.2

RSpec for Rails

This dependency is up-to-date. Congrats and keep going!

Gems ruby_gntp 0.3.4 >= 0 0.3.4

ruby_gntp version 0.3.4

Ruby library for GNTP(Growl Notification Transport Protocol) client

This dependency is up-to-date. Congrats and keep going!

Gems shoulda-matchers 2.5.0 >= 0 2.6.0

shoulda-matchers version 2.5.0

Making tests easy on the fingers and eyes

This dependency is not matching latest version. Please consider upgrading.

Gems sinon-chai-rails 1.1.0 >= 0 1.1.0

sinon-chai-rails version 1.1.0

sinon-chai.js via asset pipeline

This dependency is up-to-date. Congrats and keep going!

Gems sinon-rails 1.9.0 >= 0 1.9.0

sinon-rails version 1.9.0

sinon.js via asset pipeline

This dependency is up-to-date. Congrats and keep going!

Gems thin 1.6.2 >= 0 1.6.2

thin version 1.6.2

A thin and fast web server

This dependency is up-to-date. Congrats and keep going!

Gems timecop 0.7.0 = 0.7.0 0.7.1

timecop version 0.7.0

A gem providing "time travel" and "time freezing" capabilities, making it dead simple to test time-dependent code. It provides a unified method to mock Time.now, Date.today, and DateTime.now in a single call.

This dependency is not matching latest version. Please consider upgrading.

Gems webmock 1.17.4 >= 0 1.17.4

webmock version 1.17.4

WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.

This dependency is up-to-date. Congrats and keep going!