Ec81184c572bc827b72ebb489d49f821?s=64 codeforamerica

geek_corps

0 13 16

Our tool for micro-network building across our social networks

You have 29 open security alerts

Dependencies

Package Locked Requirement Latest Status Changelog
Gems acts-as-taggable-on 2.0.6 >= 0 3.1.1

acts-as-taggable-on version 2.0.6

With ActsAsTaggableOn, you can tag a single model on several contexts, such as skills, interests, and awards. It also provides other advanced functionality.

This dependency is not matching latest version. Please consider upgrading.

Gems aws-s3 0.6.2 >= 0 0.6.3

aws-s3 version 0.6.2

Client library for Amazon's Simple Storage Service's REST API

This dependency is not matching latest version. Please consider upgrading.

Gems delayed_job 2.1.4 >= 0 4.0.1

delayed_job version 2.1.4

Delayed_job (or DJ) encapsulates the common pattern of asynchronously executing longer tasks in the background. It is a direct extraction from Shopify where the job table is responsible for a multitude of core tasks.

Gems devise 1.4.2 >= 0 3.2.4

devise version 1.4.2

Flexible authentication solution for Rails with Warden

Security alert:

Security alert through its dependencies:

Gems formtastic 1.1.0 >= 0 2.2.1

Gems haml 3.0.25 ~> 3.0.18 4.0.5

haml version 3.0.25

Haml (HTML Abstraction Markup Language) is a layer on top of HTML or XML that's designed to express the structure of documents in a non-repetitive, elegant, and easy way by using indentation rather than closing tags and allowing Ruby to be embedded with ease. It was originally envisioned as a plugin for Ruby on Rails, but it can function as a stand-alone templating engine.

This dependency is not matching latest version. Please consider upgrading.

Gems hominid 3.0.2 >= 0 3.0.5

hominid version 3.0.2

Hominid is a Ruby gem that provides a wrapper for interacting with the Mailchimp email marketing service MC, STS and Export API's.

This dependency is not matching latest version. Please consider upgrading.

Gems inherited_resources 1.2.2 >= 0 1.4.1

inherited_resources version 1.2.2

Inherited Resources speeds up development by making your controllers inherit all restful actions so you just have to focus on what is important.

This dependency is not matching latest version. Please consider upgrading.

Gems jquery-rails 1.0.12 >= 0 3.1.0

Gems json 1.5.3 >= 0 1.8.1

json version 1.5.3

This is a JSON implementation as a Ruby extension in C.

Gems linkedin 0.2.2 >= 0 0.4.7

linkedin version 0.2.2

Ruby wrapper for the LinkedIn API

This dependency is not matching latest version. Please consider upgrading.

Gems mogli 0.0.28 >= 0 0.0.46

mogli version 0.0.28

Simple library for accessing the Facebook Open Graph API

Security alerts through its dependencies:

Gems multi_xml 0.2.2 >= 0 0.5.5

multi_xml version 0.2.2

Provides swappable XML backends utilizing LibXML, Nokogiri, Ox, or REXML.

Gems omniauth 0.2.6 >= 0.2.6 1.2.1

omniauth version 0.2.6

A generalized Rack framework for multiple-provider authentication.

Gems paperclip 2.3.12 >= 0 4.1.1

Gems rails 3.0.7 = 3.0.7 4.1.0

rails version 3.0.7

Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.

Security alerts:

Security alerts through its dependencies:

Gems sqlite3 1.3.3 >= 0 1.3.9

sqlite3 version 1.3.3

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is not matching latest version. Please consider upgrading.

Gems twitter 1.6.0 >= 0 5.8.0

twitter version 1.6.0

A Ruby interface to the Twitter API.

Security alerts through its dependencies:

Gems uuid 2.3.2 >= 0 2.3.7

uuid version 2.3.2

UUID generator for producing universally unique identifiers based on RFC 4122 (http://www.ietf.org/rfc/rfc4122.txt).

This dependency is not matching latest version. Please consider upgrading.

Gems will_paginate 2.3.15 >= 0 3.0.5

will_paginate version 2.3.15

will_paginate provides a simple API for performing paginated queries with Active Record, DataMapper and Sequel, and includes helpers for rendering pagination links in Rails, Sinatra and Merb web apps.

Security alert:

Package Locked Requirement Latest Status Changelog
Gems ZenTest 4.5.0 >= 0 4.9.5

ZenTest version 4.5.0

ZenTest provides 4 different tools: zentest, unit_diff, autotest, and multiruby. zentest scans your target and unit-test code and writes your missing code based on simple naming rules, enabling XP at a much quicker pace. zentest only works with Ruby and Minitest or Test::Unit. There is enough evidence to show that this is still proving useful to users, so it stays. unit_diff is a command-line filter to diff expected results from actual results and allow you to quickly see exactly what is wrong. Do note that minitest 2.2+ provides an enhanced assert_equal obviating the need for unit_diff autotest is a continous testing facility meant to be used during development. As soon as you save a file, autotest will run the corresponding dependent tests. multiruby runs anything you want on multiple versions of ruby. Great for compatibility checking! Use multiruby_setup to manage your installed versions.

This dependency is not matching latest version. Please consider upgrading.

Gems factory_girl_rails 1.0.1 >= 0 4.4.1

Gems faker 0.9.5 >= 0 1.3.0

faker version 0.9.5

Faker, a port of Data::Faker from Perl, is used to easily generate fake data: names, addresses, phone numbers, etc.

Security alert through its dependencies:

Gems mocha 0.9.12 >= 0 1.0.0

mocha version 0.9.12

Mocking and stubbing library with JMock/SchMock syntax, which allows mocking and stubbing of methods on real (non-mock) classes.

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-rails 2.6.1 >= 0 2.14.2

Gems simplecov 0.4.2 >= 0 0.8.2

simplecov version 0.4.2

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is not matching latest version. Please consider upgrading.

Gems spork 0.9.0.rc9 >= 0 0.9.2

spork version 0.9.0.rc9

A forking Drb spec server

This dependency is not matching latest version. Please consider upgrading.

Gems webmock 1.6.2 >= 0 1.17.4

webmock version 1.6.2

WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.

Security alert through its dependencies:

Gems yard 0.7.2 >= 0 0.8.7.4

yard version 0.7.2

YARD is a documentation generation tool for the Ruby programming language. It enables the user to generate consistent, usable documentation that can be exported to a number of formats very easily, and also supports extending for custom Ruby constructs such as custom class level definitions.

This dependency is not matching latest version. Please consider upgrading.