collectiveidea collectiveidea

delayed_job_active_record

16 0 0

ActiveRecord backend integration for DelayedJob 3.0+

Dependencies

Package Locked Requirement Latest Status Changelog
Gems activerecord < 5.1, >= 3.0 5.0.2

activerecord

Databases on Rails. Build a persistent domain model by mapping database tables to Ruby classes. Strong conventions for associations, validations, aggregations, migrations, and testing come baked-in.

This dependency is up-to-date. Congrats and keep going!

Gems delayed_job < 5, >= 3.0 4.1.2

delayed_job

Delayed_job (or DJ) encapsulates the common pattern of asynchronously executing longer tasks in the background. It is a direct extraction from Shopify where the job table is responsible for a multitude of core tasks.

This dependency is up-to-date. Congrats and keep going!

Gems rake >= 0 12.0.0

rake

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * Supports parallel execution of tasks.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems activerecord-jdbcmysql-adapter >= 0 1.3.22

activerecord-jdbcmysql-adapter

MySQL JDBC adapter for JRuby on Rails.

This dependency is up-to-date. Congrats and keep going!

Gems activerecord-jdbcpostgresql-adapter >= 0 1.3.22

activerecord-jdbcpostgresql-adapter

Postgres JDBC adapter for JRuby on Rails.

This dependency is up-to-date. Congrats and keep going!

Gems activerecord-jdbcsqlite3-adapter >= 0 1.3.22

activerecord-jdbcsqlite3-adapter

Sqlite3 JDBC adapter for JRuby on Rails.

This dependency is up-to-date. Congrats and keep going!

Gems coveralls >= 0 0.8.19

coveralls

A Ruby implementation of the Coveralls API.

This dependency is up-to-date. Congrats and keep going!

Gems jdbc-mysql >= 0 5.1.40

jdbc-mysql

Install this gem `require 'jdbc/mysql'` and invoke `Jdbc::MySQL.load_driver` within JRuby to load the driver.

This dependency is up-to-date. Congrats and keep going!

Gems jdbc-postgres >= 0 9.4.1206

jdbc-postgres

Install this gem `require 'jdbc/postgres'` and invoke `Jdbc::Postgres.load_driver` within JRuby to load the driver.

This dependency is up-to-date. Congrats and keep going!

Gems jdbc-sqlite3 >= 0 3.15.1

jdbc-sqlite3

Install this gem `require 'jdbc/sqlite3'` and invoke `Jdbc::SQLite3.load_driver` within JRuby to load the driver.

This dependency is up-to-date. Congrats and keep going!

Gems mysql ~> 2.9 2.9.1

mysql

This is the MySQL API module for Ruby. It provides the same functions for Ruby programs that the MySQL C API provides for C programs. This package is offered as gem for easy installation using RubyGems. It wraps unmodified tmtm's mysql-ruby extension into a proper gem. Please note that tmtm (Tomita Mashahiro) has deprecated development of this extension and only update it for bug fixes.

This dependency is up-to-date. Congrats and keep going!

Gems pg >= 0 0.20.0

pg

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 9.1 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

This dependency is up-to-date. Congrats and keep going!

Gems rspec >= 3 3.5.0

rspec

BDD for Ruby

This dependency is up-to-date. Congrats and keep going!

Gems rubocop >= 0.23 0.48.0

rubocop

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

This dependency is up-to-date. Congrats and keep going!

Gems simplecov >= 0 0.14.1

simplecov

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is up-to-date. Congrats and keep going!

Gems sqlite3 >= 0 1.3.13

sqlite3

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is up-to-date. Congrats and keep going!