diaspora diaspora

diaspora-client

3 14 0

ABANDONED - An oauth client for authenticating to Diaspora

Dependencies

Package Locked Requirement Latest Status Changelog
Gems activerecord >= 0 4.2.3

activerecord

Databases on Rails. Build a persistent domain model by mapping database tables to Ruby classes. Strong conventions for associations, validations, aggregations, migrations, and testing come baked-in.

This dependency is up-to-date. Congrats and keep going!

Gems em-http-request >= 0 1.1.2

em-http-request

EventMachine based, async HTTP Request client

This dependency is not matching latest version. Please consider upgrading.

Gems em-synchrony >= 0 1.0.4

em-synchrony

Fiber aware EventMachine libraries

This dependency is not matching latest version. Please consider upgrading.

Gems faraday >= 0 0.9.1

faraday

HTTP/REST API client library.

This dependency is not matching latest version. Please consider upgrading.

Gems jwt >= 0.1.3 1.5.1

jwt

JSON Web Token implementation in Ruby

This dependency is up-to-date. Congrats and keep going!

Gems oauth2 = 0.5.0 1.0.0

oauth2

A Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.

This dependency is not matching latest version. Please consider upgrading.

Gems rack-fiber_pool >= 0 0.9.3

rack-fiber_pool

Rack middleware to run each request within a Fiber

This dependency is not matching latest version. Please consider upgrading.

Gems sinatra >= 0 1.4.6

sinatra

Sinatra is a DSL for quickly creating web applications in Ruby with minimal effort.

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Gems bundler >= 1.0 1.10.5

bundler

Bundler manages an application's dependencies through its entire life, across many machines, systematically and repeatably

This dependency is up-to-date. Congrats and keep going!

Gems jeweler ~> 1.6.2 2.0.1

jeweler

Simple and opinionated helper for creating Rubygem projects on GitHub

This dependency is not matching latest version. Please consider upgrading.

Gems rack-test >= 0 0.6.3

rack-test

Rack::Test is a small, simple testing API for Rack apps. It can be used on its own or as a reusable starting point for Web frameworks and testing libraries to build on. Most of its initial functionality is an extraction of Merb 1.0's request helpers feature.

This dependency is not matching latest version. Please consider upgrading.

Gems rcov >= 0 1.0.0

rcov

rcov is a code coverage tool for Ruby.

This dependency is not matching latest version. Please consider upgrading.

Gems rspec >= 2.0.0 3.3.0

rspec

BDD for Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems ruby-debug >= 0 0.10.4

ruby-debug

A generic command line interface for ruby-debug.

This dependency is not matching latest version. Please consider upgrading.

Gems ruby-debug19 >= 0 0.11.6

ruby-debug19

A generic command line interface for ruby-debug.

This dependency is not matching latest version. Please consider upgrading.

Gems sqlite3 >= 0 1.3.10

sqlite3

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is not matching latest version. Please consider upgrading.

Gems yard >= 0 0.8.7.6

yard

YARD is a documentation generation tool for the Ruby programming language. It enables the user to generate consistent, usable documentation that can be exported to a number of formats very easily, and also supports extending for custom Ruby constructs such as custom class level definitions.

This dependency is not matching latest version. Please consider upgrading.