diaspora diaspora

diaspora_federation

23 7 0

A library that provides functionalities needed for the diaspora* federation protocol.

Reports Beta

Some reports are compatible with your project but none of them has been enabled.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems actionpack 5.1.4 < 6, >= 4.2 5.1.4

actionpack version 5.1.4

Web apps on Rails. Simple, battle-tested conventions for building and testing MVC web applications. Works with any Rack-compatible server.

This dependency is up-to-date. Congrats and keep going!

Gems fabrication 2.16.3 ~> 2.16 2.18.0

fabrication version 2.16.3

Fabrication is an object generation framework for ActiveRecord, Mongoid, DataMapper, Sequel, or any other Ruby object.

This dependency is not matching latest version. Please consider upgrading.

Gems faraday 0.13.1 < 0.14.0, >= 0.9.0 0.13.1

faraday version 0.13.1

HTTP/REST API client library.

This dependency is up-to-date. Congrats and keep going!

Gems faraday_middleware 0.12.2 < 0.13.0, >= 0.10.0 0.12.2

faraday_middleware version 0.12.2

Various middleware for Faraday

This dependency is up-to-date. Congrats and keep going!

Gems nokogiri 1.8.1 >= 1.6.8, ~> 1.6 1.8.1

nokogiri version 1.8.1

Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. Among Nokogiri's many features is the ability to search documents via XPath or CSS3 selectors.

This dependency is up-to-date. Congrats and keep going!

Gems typhoeus 1.3.0 ~> 1.0 1.3.0

typhoeus version 1.3.0

Like a modern code version of the mythical beast with 100 serpent heads, Typhoeus runs HTTP requests in parallel while cleanly encapsulating handling logic.

This dependency is up-to-date. Congrats and keep going!

Gems uuid 2.3.8 >= 2.3.8, ~> 2.3 2.3.8

uuid version 2.3.8

UUID generator for producing universally unique identifiers based on RFC 4122 (http://www.ietf.org/rfc/rfc4122.txt).

This dependency is up-to-date. Congrats and keep going!

Gems valid 1.2.0 ~> 1.0 1.2.0

valid version 1.2.0

A standalone, generic object validator for ruby

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems fuubar 2.2.0 = 2.2.0 2.2.0

fuubar version 2.2.0

the instafailing RSpec progress bar formatter

This dependency is up-to-date. Congrats and keep going!

Gems guard-rspec 4.7.3 >= 0 4.7.3

guard-rspec version 4.7.3

Guard::RSpec automatically run your specs (much like autotest).

This dependency is up-to-date. Congrats and keep going!

Gems guard-rubocop 1.3.0 >= 0 1.3.0

guard-rubocop version 1.3.0

Guard::RuboCop automatically checks Ruby code style with RuboCop when files are modified.

This dependency is up-to-date. Congrats and keep going!

Gems json-schema-rspec 0.0.4 = 0.0.4 0.0.4

json-schema-rspec version 0.0.4

Adds RSpec matchers for validating JSON schemas

This dependency is up-to-date. Congrats and keep going!

Gems nyan-cat-formatter 0.12.0 >= 0 0.12.0

nyan-cat-formatter version 0.12.0

Nyan Cat inspired RSpec formatter!

This dependency is up-to-date. Congrats and keep going!

Gems pronto 0.9.5 = 0.9.5 0.9.5

pronto version 0.9.5

Pronto runs analysis quickly by checking only the relevant changes. Created to be used on pull requests, but suited for other scenarios as well. Perfect if you want to find out quickly if branch introduces changes that conform to your styleguide, are DRY, don't introduce security holes and more.

This dependency is up-to-date. Congrats and keep going!

Gems pronto-rubocop 0.9.0 = 0.9.0 0.9.0

pronto-rubocop version 0.9.0

Pronto runner for Rubocop, ruby code analyzer

This dependency is up-to-date. Congrats and keep going!

Gems pry 0.11.0 >= 0 0.11.3

pry version 0.11.0

An IRB alternative and runtime developer console

This dependency is not matching latest version. Please consider upgrading.

Gems pry-byebug 3.5.0 >= 0 3.5.0

pry-byebug version 3.5.0

Combine 'pry' with 'byebug'. Adds 'step', 'next', 'finish', 'continue' and 'break' commands to control execution.

This dependency is up-to-date. Congrats and keep going!

Gems rake 12.1.0 >= 0 12.3.0

rake version 12.1.0

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * Supports parallel execution of tasks.

This dependency is not matching latest version. Please consider upgrading.

Gems rspec 3.6.0 ~> 3.6.0 3.7.0

rspec version 3.6.0

BDD for Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-collection_matchers 1.1.3 ~> 1.1.2 1.1.3

rspec-collection_matchers version 1.1.3

Collection cardinality matchers, extracted from rspec-expectations

This dependency is up-to-date. Congrats and keep going!

Gems rspec-json_expectations 2.1.0 ~> 2.1 2.1.0

rspec-json_expectations version 2.1.0

Set of matchers and helpers to allow you test your APIs responses like a pro.

This dependency is up-to-date. Congrats and keep going!

Gems rspec-rails 3.6.1 ~> 3.6.0 3.7.1

rspec-rails version 3.6.1

rspec-rails is a testing framework for Rails 3+.

This dependency is not matching latest version. Please consider upgrading.

Gems rubocop 0.50.0 = 0.50.0 0.51.0

rubocop version 0.50.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

This dependency is not matching latest version. Please consider upgrading.

Gems simplecov 0.15.1 = 0.15.1 0.15.1

simplecov version 0.15.1

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is up-to-date. Congrats and keep going!

Gems simplecov-rcov 0.2.3 = 0.2.3 0.2.3

simplecov-rcov version 0.2.3

Rcov style formatter for SimpleCov

This dependency is up-to-date. Congrats and keep going!

Gems spring 2.0.2 >= 0 2.0.2

spring version 2.0.2

Preloads your application so things like console, rake and tests run faster

This dependency is up-to-date. Congrats and keep going!

Gems spring-commands-rspec 1.0.4 >= 0 1.0.4

spring-commands-rspec version 1.0.4

rspec command for spring

This dependency is up-to-date. Congrats and keep going!

Gems spring-watcher-listen 2.0.1 >= 0 2.0.1

spring-watcher-listen version 2.0.1

Makes spring watch files using the listen gem.

This dependency is up-to-date. Congrats and keep going!

Gems webmock 3.0.1 ~> 3.0 3.1.0

webmock version 3.0.1

WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.

This dependency is not matching latest version. Please consider upgrading.

Gems yard 0.9.9 >= 0 0.9.9

yard version 0.9.9

YARD is a documentation generation tool for the Ruby programming language. It enables the user to generate consistent, usable documentation that can be exported to a number of formats very easily, and also supports extending for custom Ruby constructs such as custom class level definitions.

This dependency is up-to-date. Congrats and keep going!