earmbrust earmbrust

mammock

2 16 0

Mammock is a node.js service mocking framework designed to be quick and easy, allowing developers to fill the "missing gaps" in services during development.

Dependencies

Package Locked Requirement Latest Status Changelog
Npms dateformat ~1.0.6-1.2.3 1.0.12

dateformat

A node.js package for Steven Levithan's excellent dateFormat() function.

This dependency is up-to-date. Congrats and keep going!

Npms path ~0.4.9 0.12.7

path

Node.JS path module

This dependency is not matching latest version. Please consider upgrading.

Npms winston ~0.7.2 2.2.0

winston

A multi-transport async logging library for Node.js

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Npms blanket ~1.1.5 1.2.3

blanket

seamless js code coverage

This dependency is not matching latest version. Please consider upgrading.

Npms coveralls ~2.2.0 2.11.12

coveralls

takes json-cov output into stdin and POSTs to coveralls.io

This dependency is not matching latest version. Please consider upgrading.

Npms grunt ~0.4.1 1.0.1

grunt

The JavaScript Task Runner

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-clean ~0.5.0 1.0.0

grunt-contrib-clean

Clean files and folders

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-copy ~0.4.1 1.0.0

grunt-contrib-copy

Copy files and folders

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-jshint ~0.6.0 1.0.0

grunt-contrib-jshint

Validate files with JSHint

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-nodeunit ~0.2.0 1.0.0

grunt-contrib-nodeunit

Run Nodeunit unit tests

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-uglify ~0.2.2 2.0.0

grunt-contrib-uglify

Minify JavaScript files with UglifyJS

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-watch ~0.5.3 1.0.0

grunt-contrib-watch

Run predefined tasks whenever watched file patterns are added, changed or deleted

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-jscover 0.0.1 0.0.1

grunt-jscover

Grunt task for jscover

This dependency is up-to-date. Congrats and keep going!

Npms grunt-mocha-cov ~0.0.7 0.4.0

grunt-mocha-cov

Run Mocha server-side tests in Grunt with code coverage support and optional integration to coveralls.io.

This dependency is not matching latest version. Please consider upgrading.

Npms node.extend ~1.0.8 1.1.5

node.extend

A port of jQuery.extend that actually works on node.js

This dependency is not matching latest version. Please consider upgrading.

Npms proxyquire ~0.5.1 1.7.10

proxyquire

Proxies nodejs require in order to allow overriding dependencies during testing.

This dependency is not matching latest version. Please consider upgrading.

Npms should ~1.2.2 11.1.0

should

test framework agnostic BDD-style assertions

This dependency is not matching latest version. Please consider upgrading.

Npms stdio ~0.1.0 0.2.7

stdio

Standard input/output management with NodeJS

This dependency is not matching latest version. Please consider upgrading.