ets-berkeley-edu ets-berkeley-edu

calcentral

43 60 1

You have 26 open security alerts

Reports Beta

Some reports are compatible with your project but none of them has been enabled.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems actionpack-action_caching 1.1.1 ~> 1.1.1 1.2.0

actionpack-action_caching version 1.1.1

Action caching for Action Pack (removed from core in Rails 4.0)

This dependency is not matching latest version. Please consider upgrading.

Gems actionpack-page_caching 1.0.2 ~> 1.0.2 1.1.0

actionpack-page_caching version 1.0.2

Static page caching for Action Pack (removed from core in Rails 4.0)

This dependency is not matching latest version. Please consider upgrading.

Gems actionpack-xml_parser 1.0.1 ~> 1.0.1 2.0.1

actionpack-xml_parser version 1.0.1

XML parameters parser for Action Pack (removed from core in Rails 4.0)

This dependency is not matching latest version. Please consider upgrading.

Gems actionview-encoded_mail_to 1.0.5 ~> 1.0.5 1.0.9

actionview-encoded_mail_to version 1.0.5

Rails mail_to helper with encoding (removed from core in Rails 4.0)

This dependency is not matching latest version. Please consider upgrading.

Gems active_attr 0.8.5 ~> 0.8.5 0.10.2

active_attr version 0.8.5

Create plain old ruby models without reinventing the wheel.

This dependency is not matching latest version. Please consider upgrading.

Gems activerecord-jdbc-adapter 1.3.16 ~> 1.3.16 1.3.23

activerecord-jdbc-adapter version 1.3.16

AR-JDBC is a database adapter for Rails' ActiveRecord component designed to be used with JRuby built upon Java's JDBC API for database access. Provides (ActiveRecord) built-in adapters: MySQL, PostgreSQL and SQLite3 as well as adapters for popular databases such as Oracle, SQLServer, DB2, FireBird and even Java (embed) databases: Derby, HSQLDB and H2. It allows to connect to virtually any JDBC-compliant database with your JRuby on Rails application.

This dependency is not matching latest version. Please consider upgrading.

Gems activerecord-jdbch2-adapter 1.3.16 ~> 1.3.16 1.3.23

activerecord-jdbch2-adapter version 1.3.16

H2 JDBC adapter for JRuby on Rails.

This dependency is not matching latest version. Please consider upgrading.

Gems activerecord-jdbcpostgresql-adapter 1.3.16 ~> 1.3.16 1.3.23

activerecord-jdbcpostgresql-adapter version 1.3.16

Postgres JDBC adapter for JRuby on Rails.

This dependency is not matching latest version. Please consider upgrading.

Gems activerecord-session_store 0.1.1 ~> 0.1.1 1.1.0

activerecord-session_store version 0.1.1

An Action Dispatch session store backed by an Active Record class.

This dependency is not matching latest version. Please consider upgrading.

Gems activeresource 4.0.0 ~> 4.0.0 5.0.0

activeresource version 4.0.0

REST on Rails. Wrap your RESTful web app with Ruby classes and work with them like Active Record models.

This dependency is not matching latest version. Please consider upgrading.

Npms add-stream 1.0.0 ~1.0.0 1.0.0

add-stream version 1.0.0

Append the contents of one stream onto another.

This dependency is up-to-date. Congrats and keep going!

Gems addressable 2.3.8 ~> 2.3.4 2.5.1

addressable version 2.3.8

Addressable is a replacement for the URI implementation that is part of Ruby's standard library. It more closely conforms to the relevant RFCs and adds support for IRIs and URI templates.

This dependency is not matching latest version. Please consider upgrading.

Npms angular 1.6.5 ~1.6.5 1.6.5

angular version 1.6.5

HTML enhanced for web apps

This dependency is up-to-date. Congrats and keep going!

Npms angular-route 1.6.5 ~1.6.5 1.6.4

angular-route version 1.6.5

AngularJS router module

Npms angular-sanitize 1.6.5 ~1.6.5 1.6.4

angular-sanitize version 1.6.5

AngularJS module for sanitizing HTML

Gems bootstrap-sass 3.3.1.0 ~> 3.3.1.0 3.3.7

bootstrap-sass version 3.3.1.0

bootstrap-sass is a Sass-powered version of Bootstrap 3, ready to drop right into your Sass powered applications.

This dependency is not matching latest version. Please consider upgrading.

Npms browser-sync 2.18.13 ~2.18.12 2.18.13

browser-sync version 2.18.13

Live CSS Reload & Browser Syncing

This dependency is up-to-date. Congrats and keep going!

Npms browserify 14.4.0 ~14.4.0 14.4.0

browserify version 14.4.0

browser-side require() the node way

This dependency is up-to-date. Congrats and keep going!

Npms bulkify 1.4.2 ~1.4.2 1.4.2

bulkify version 1.4.2

transform inline bulk-require calls into statically resolvable require maps

This dependency is up-to-date. Congrats and keep going!

Gems cancan 1.6.10 ~> 1.6.10 1.6.10

cancan version 1.6.10

Simple authorization solution for Rails which is decoupled from user roles. All permissions are stored in a single location.

This dependency is up-to-date. Congrats and keep going!

Gems capistrano 2.15.5 ~> 2.15.4 3.8.2

capistrano version 2.15.5

Capistrano is a utility and framework for executing commands in parallel on multiple remote machines, via SSH.

This dependency is not matching latest version. Please consider upgrading.

Gems closure-compiler 1.1.11 ~> 1.1.11 1.1.13

closure-compiler version 1.1.11

A Ruby Wrapper for the Google Closure Compiler.

This dependency is not matching latest version. Please consider upgrading.

Gems dalli 2.7.2 ~> 2.7.2 2.7.6

dalli version 2.7.2

High performance memcached client for Ruby

This dependency is not matching latest version. Please consider upgrading.

Npms del 3.0.0 ~3.0.0 3.0.0

del version 3.0.0

Delete files and folders

This dependency is up-to-date. Congrats and keep going!

Gems faraday 0.9.2 ~> 0.9.0 0.12.2

faraday version 0.9.2

HTTP/REST API client library.

This dependency is not matching latest version. Please consider upgrading.

Gems faraday_middleware 0.9.1 ~> 0.9.1 0.11.0.1

faraday_middleware version 0.9.1

Various middleware for Faraday

This dependency is not matching latest version. Please consider upgrading.

Npms font-awesome 4.7.0 ~4.6.0 4.7.0

font-awesome version 4.7.0

The iconic font and CSS framework

This dependency is up-to-date. Congrats and keep going!

Gems google-api-client 0.8.6 ~> 0.8.6 0.13.1

google-api-client version 0.8.6

Client for accessing Google APIs

This dependency is not matching latest version. Please consider upgrading.

Gems google_drive 1.0.1 ~> 1.0.1 2.1.5

google_drive version 1.0.1

A library to read/write files/spreadsheets in Google Drive/Docs.

This dependency is not matching latest version. Please consider upgrading.

Npms gulp 3.9.1 ~3.9.1 3.9.1

gulp version 3.9.1

The streaming build system

This dependency is up-to-date. Congrats and keep going!

Npms gulp-angular-templatecache 2.0.0 ~2.0.0 2.0.0

gulp-angular-templatecache version 2.0.0

Concatenates and registers AngularJS templates in the $templateCache.

This dependency is up-to-date. Congrats and keep going!

Npms gulp-autoprefixer 3.0.2 ~3.0.0 4.0.0

gulp-autoprefixer version 3.0.2

Prefix CSS

This dependency is not matching latest version. Please consider upgrading.

Npms gulp-base64 0.1.3 ~0.1.3 0.1.3

gulp-base64 version 0.1.3

gulp task to encode images to data URI

This dependency is up-to-date. Congrats and keep going!

Npms gulp-clean-css 3.7.0 ~3.7.0 3.7.0

gulp-clean-css version 3.7.0

Minify css with clean-css.

This dependency is up-to-date. Congrats and keep going!

Npms gulp-concat 2.6.0 ~2.6.0 2.6.1

gulp-concat version 2.6.0

Concatenates files

This dependency is not matching latest version. Please consider upgrading.

Npms gulp-header 1.8.2 ~1.8.8 1.8.9

gulp-header version 1.8.2

Gulp extension to add header to file(s) in the pipeline.

This dependency is not matching latest version. Please consider upgrading.

Npms gulp-htmlmin 3.0.0 ~3.0.0 3.0.0

gulp-htmlmin version 3.0.0

gulp plugin to minify HTML.

This dependency is up-to-date. Congrats and keep going!

Npms gulp-if 2.0.2 ~2.0.0 2.0.2

gulp-if version 2.0.2

Conditionally run a task

This dependency is up-to-date. Congrats and keep going!

Npms gulp-inject 4.2.0 ~4.2.0 4.2.0

gulp-inject version 4.2.0

A javascript, stylesheet and webcomponent injection plugin for Gulp, i.e. inject file references into your index.html

This dependency is up-to-date. Congrats and keep going!

Npms gulp-ng-annotate 2.0.0 ~2.0.0 2.0.0

gulp-ng-annotate version 2.0.0

Add angularjs dependency injection annotations with ng-annotate

This dependency is up-to-date. Congrats and keep going!

Npms gulp-rename 1.2.2 ~1.2.2 1.2.2

gulp-rename version 1.2.2

Rename files

This dependency is up-to-date. Congrats and keep going!

Npms gulp-rev-all 0.9.7 ~0.9.7 0.9.7

gulp-rev-all version 0.9.7

Static asset revisioning by appending content hash to filenames: unicorn.css => unicorn.098f6bcd.css, also re-writes references in each file to new reved name.

This dependency is up-to-date. Congrats and keep going!

Npms gulp-sass 3.1.0 ~3.1.0 3.1.0

gulp-sass version 3.1.0

Gulp plugin for sass

This dependency is up-to-date. Congrats and keep going!

Npms gulp-streamify 1.0.2 ~1.0.2 1.0.2

gulp-streamify version 1.0.2

Wrap old plugins to support streams.

This dependency is up-to-date. Congrats and keep going!

Npms gulp-uglify 3.0.0 ~3.0.0 3.0.0

gulp-uglify version 3.0.0

Minify files with UglifyJS.

This dependency is up-to-date. Congrats and keep going!

Npms gulp-util 3.0.7 ~3.0.7 3.0.8

gulp-util version 3.0.7

Utility functions for gulp plugins

This dependency is not matching latest version. Please consider upgrading.

Npms highcharts 5.0.12 ~5.0.12 5.0.12

highcharts version 5.0.12

JavaScript charting framework

This dependency is up-to-date. Congrats and keep going!

Gems httparty 0.13.3 ~> 0.13.3 0.15.6

httparty version 0.13.3

Makes http fun! Also, makes consuming restful web services dead easy.

This dependency is not matching latest version. Please consider upgrading.

Gems icalendar 2.2.2 ~> 2.2.2 2.4.1

icalendar version 2.2.2

Implements the iCalendar specification (RFC-5545) in Ruby. This allows for the generation and parsing of .ics files, which are used by a variety of calendaring applications.

This dependency is not matching latest version. Please consider upgrading.

Gems jmx 1.0 ~> 1.0 1.0

jmx version 1.0

Access and create MBeans in a friendly Ruby syntax

This dependency is up-to-date. Congrats and keep going!

Gems jruby-openssl 0.9.19 = 0.9.19 0.9.20

jruby-openssl version 0.9.19

JRuby-OpenSSL is an add-on gem for JRuby that emulates the Ruby OpenSSL native library.

This dependency is not matching latest version. Please consider upgrading.

Npms js-natural-sort 0.8.1 ~0.8.1 0.8.1

js-natural-sort version 0.8.1

Natural Sort algorithm for Javascript (supports AMD / Browserify & CommonJS)

This dependency is up-to-date. Congrats and keep going!

Npms jscs 3.0.7 ~3.0.7 3.0.7

jscs version 3.0.7

JavaScript Code Style

This dependency is up-to-date. Congrats and keep going!

Npms jshint 2.9.5 ~2.9.5 2.9.5

jshint version 2.9.5

Static analysis tool for JavaScript

This dependency is up-to-date. Congrats and keep going!

Gems json 1.8.6 ~> 1.8.0 2.1.0

json version 1.8.6

This is a JSON implementation as a Ruby extension in C.

This dependency is not matching latest version. Please consider upgrading.

Gems link_header 0.0.8 ~> 0.0.7 0.0.8

link_header version 0.0.8

Converts conforming link headers to and from text, LinkHeader objects and corresponding (JSON-friendly) Array representations, also HTML link elements.

This dependency is up-to-date. Congrats and keep going!

Npms lodash 3.10.1 ~4.17.4 4.17.4

lodash version 3.10.1

Lodash modular utilities.

This dependency is not matching latest version. Please consider upgrading.

Gems log4r 1.1.10 ~> 1.1 1.1.10

log4r version 1.1.10

See also: http://logging.apache.org/log4j

This dependency is up-to-date. Congrats and keep going!

Npms minimist 0.0.8 ~1.2.0 1.2.0

minimist version 0.0.8

parse argument options

This dependency is not matching latest version. Please consider upgrading.

Npms moment 2.18.1 ~2.18.1 2.18.1

moment version 2.18.1

Parse, validate, manipulate, and display dates

This dependency is up-to-date. Congrats and keep going!

Gems net-ldap 0.11 ~> 0.11.0 0.16.0

net-ldap version 0.11

Net::LDAP for Ruby (also called net-ldap) implements client access for the Lightweight Directory Access Protocol (LDAP), an IETF standard protocol for accessing distributed directory services. Net::LDAP is written completely in Ruby with no external dependencies. It supports most LDAP client features and a subset of server features as well. Net::LDAP has been tested against modern popular LDAP servers including OpenLDAP and Active Directory. The current release is mostly compliant with earlier versions of the IETF LDAP RFCs (2251-2256, 2829-2830, 3377, and 3771). Our roadmap for Net::LDAP 1.0 is to gain full <em>client</em> compliance with the most recent LDAP RFCs (4510-4519, plutions of 4520-4532).

This dependency is not matching latest version. Please consider upgrading.

Gems net-ssh 2.9.2 ~> 2.9.2 4.1.0

net-ssh version 2.9.2

Net::SSH: a pure-Ruby implementation of the SSH2 client protocol. It allows you to write programs that invoke and interact with processes on remote servers, via SSH2.

This dependency is not matching latest version. Please consider upgrading.

Gems nokogiri 1.5.11 ~> 1.5.9 1.8.0

nokogiri version 1.5.11

Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. Among Nokogiri's many features is the ability to search documents via XPath or CSS3 selectors.

Npms opn 4.0.2 ~5.1.0 5.1.0

opn version 4.0.2

A better node-open. Opens stuff like websites, files, executables. Cross-platform.

This dependency is not matching latest version. Please consider upgrading.

Npms pikaday 1.6.1 ~1.6.1 1.6.1

pikaday version 1.6.1

A refreshing JavaScript Datepicker — lightweight, no dependencies, modular CSS

This dependency is up-to-date. Congrats and keep going!

Gems protected_attributes 1.0.8 ~> 1.0.8 1.1.4

protected_attributes version 1.0.8

Protect attributes from mass assignment

This dependency is not matching latest version. Please consider upgrading.

Gems pundit 0.3.0 ~> 0.3.0 1.1.0

pundit version 0.3.0

Object oriented authorization for Rails applications

This dependency is not matching latest version. Please consider upgrading.

Gems rails 4.1.11 = 4.1.11 5.1.2

rails version 4.1.11

Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.

This dependency is not matching latest version. Please consider upgrading.

Gems rails-observers 0.1.2 ~> 0.1.2 0.1.5

rails-observers version 0.1.2

Rails observer (removed from core in Rails 4.0)

This dependency is not matching latest version. Please consider upgrading.

Gems rails-perftest 0.0.5 ~> 0.0.5 0.0.7

rails-perftest version 0.0.5

Rails performance tests (removed from core in Rails 4.0)

This dependency is not matching latest version. Please consider upgrading.

Gems rails_admin 0.6.5 = 0.6.5 1.2.0

rails_admin version 0.6.5

RailsAdmin is a Rails engine that provides an easy-to-use interface for managing your data.

This dependency is not matching latest version. Please consider upgrading.

Npms raven-js 3.17.0 ~3.17.0 3.17.0

raven-js version 3.17.0

Raven.js is the official browser JavaScript client for [Sentry](https://sentry.io/).

This dependency is up-to-date. Congrats and keep going!

Gems retriable 1.4.1 ~> 1.4 3.0.2

retriable version 1.4.1

Retriable is an simple DSL to retry failed code blocks with randomized exponential backoff. This is especially useful when interacting external api/services or file system calls.

This dependency is not matching latest version. Please consider upgrading.

Npms run-sequence 2.0.0 ~2.0.0 2.1.0

run-sequence version 2.0.0

Run a series of dependent gulp tasks in order

This dependency is not matching latest version. Please consider upgrading.

Gems rvm-capistrano 1.3.4 ~> 1.3.1 1.5.6

rvm-capistrano version 1.3.4

RVM / Capistrano Integration Gem

This dependency is not matching latest version. Please consider upgrading.

Gems safe_yaml 1.0.4 ~> 1.0.4 1.0.4

safe_yaml version 1.0.4

Parse YAML safely

This dependency is up-to-date. Congrats and keep going!

Npms sc5-styleguide 2.0.1 ~2.0.1 2.0.1

sc5-styleguide version 2.0.1

Styleguide generator is a handy little tool that helps you generate good looking styleguides from stylesheets using KSS notation.

This dependency is up-to-date. Congrats and keep going!

Gems secure_headers 1.4.1 ~> 1.4.0 3.6.7

secure_headers version 1.4.1

Manages application of security headers with many safe defaults.

This dependency is not matching latest version. Please consider upgrading.

Gems signet 0.7.2 ~> 0.7.2 0.7.3

signet version 0.7.2

Signet is an OAuth 1.0 / OAuth 2.0 implementation.

This dependency is not matching latest version. Please consider upgrading.

Npms streamqueue 1.1.1 ~1.1.1 1.1.1

streamqueue version 1.1.1

Pipe queued streams progressively, keeping datas order.

This dependency is up-to-date. Congrats and keep going!

Gems torquebox 3.2.0 ~> 3.2.0 3.2.0

torquebox version 3.2.0

TorqueBox Gem

This dependency is up-to-date. Congrats and keep going!

Gems torquebox-messaging 3.2.0 ~> 3.2.0 3.2.0

torquebox-messaging version 3.2.0

TorqueBox Messaging Client

This dependency is up-to-date. Congrats and keep going!

Gems torquebox-server 3.2.0 ~> 3.2.0 3.2.0

torquebox-server version 3.2.0

TorqueBox Server Gem

This dependency is up-to-date. Congrats and keep going!

Npms vinyl-source-stream 1.1.0 ~1.1.0 1.1.0

vinyl-source-stream version 1.1.0

Use conventional text streams at the start of your gulp or vinyl pipelines

This dependency is up-to-date. Congrats and keep going!

Npms watchify 3.9.0 ~3.9.0 3.9.0

watchify version 3.9.0

watch mode for browserify builds

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems activerecord-jdbcsqlite3-adapter 1.3.16 ~> 1.3.16 1.3.23

activerecord-jdbcsqlite3-adapter version 1.3.16

Sqlite3 JDBC adapter for JRuby on Rails.

This dependency is not matching latest version. Please consider upgrading.

Gems capybara 2.4.4 ~> 2.4.4 2.14.4

capybara version 2.4.4

Capybara is an integration testing tool for rack based web applications. It simulates how a user would interact with a website

This dependency is not matching latest version. Please consider upgrading.

Gems guard-livereload 2.4.0 ~> 2.4.0 2.5.2

guard-livereload version 2.4.0

Guard::LiveReload automatically reloads your browser when 'view' files are modified.

This dependency is not matching latest version. Please consider upgrading.

Gems guard-spork 2.1.0 >= 0 2.1.0

guard-spork version 2.1.0

Guard::Spork automatically manage Spork DRb servers.

This dependency is up-to-date. Congrats and keep going!

Gems headless 1.0.2 ~> 1.0.2 2.3.1

headless version 1.0.2

Headless is a Ruby interface for Xvfb. It allows you to create a headless display straight from Ruby code, hiding some low-level action.

This dependency is not matching latest version. Please consider upgrading.

Gems minitest-reporters 1.0.8 ~> 1.0.8 1.1.14

minitest-reporters version 1.0.8

Death to haphazard monkey-patching! Extend Minitest through simple hooks.

This dependency is not matching latest version. Please consider upgrading.

Gems page-object 1.2.0 ~> 1.2.0 2.1.1

page-object version 1.2.0

Page Object DSL that works with both Watir and Selenium

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-collection_matchers 1.1.2 ~> 1.1.2 1.1.3

rspec-collection_matchers version 1.1.2

Collection cardinality matchers, extracted from rspec-expectations

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-core 3.1.7 ~> 3.1.7 3.6.0

rspec-core version 3.1.7

BDD for Ruby. RSpec runner and example groups.

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-its 1.1.0 ~> 1.1.0 1.2.0

rspec-its version 1.1.0

RSpec extension gem for attribute matching

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-mocks 3.1.3 ~> 3.1.3 3.6.0

rspec-mocks version 3.1.3

RSpec's 'test double' framework, with support for stubbing and mocking

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-rails 3.1.0 ~> 3.1.0 3.6.0

rspec-rails version 3.1.0

rspec-rails is a testing framework for Rails 3+.

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-support 3.1.2 ~> 3.1.0 3.6.0

rspec-support version 3.1.2

Support utilities for RSpec gems

This dependency is not matching latest version. Please consider upgrading.

Gems ruby-debug 0.10.5.rc9 >= 0.10.5.rc9 0.10.6

ruby-debug version 0.10.5.rc9

A generic command line interface for ruby-debug.

This dependency is up-to-date. Congrats and keep going!

Gems ruby-debug-ide 0.6.0 ~> 0.6.0 0.6.0

ruby-debug-ide version 0.6.0

An interface which glues ruby-debug to IDEs like Eclipse (RDT), NetBeans and RubyMine.

This dependency is up-to-date. Congrats and keep going!

Gems selenium-webdriver 2.53.4 ~> 2.53.4 3.4.4

selenium-webdriver version 2.53.4

WebDriver is a tool for writing automated tests of websites. It aims to mimic the behaviour of a real user, and as such interacts with the HTML of the application.

This dependency is not matching latest version. Please consider upgrading.

Gems simplecov 0.9.2 ~> 0.9.2 0.14.1

simplecov version 0.9.2

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is not matching latest version. Please consider upgrading.

Gems simplecov-html 0.9.0 ~> 0.9.0 0.10.1

simplecov-html version 0.9.0

Default HTML formatter for SimpleCov code coverage tool for ruby 1.9+

This dependency is not matching latest version. Please consider upgrading.

Gems spork 1.0.0rc0 = 1.0.0rc0 0.9.2

spork version 1.0.0rc0

A forking Drb spec server

This dependency is not matching latest version. Please consider upgrading.

Gems spork-rails 4.0.0 >= 0 4.0.0

spork-rails version 4.0.0

Plugin for Spork to support Rails.

This dependency is up-to-date. Congrats and keep going!

Gems webmock 1.20.4 ~> 1.20.4 3.0.1

webmock version 1.20.4

WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.

This dependency is not matching latest version. Please consider upgrading.