B2dae46e93c0529ad3642fa3e4eff907?s=64 flosse

scaleApp

8 13 0

scaleApp is a JavaScript framework for scalable and maintainable One-Page-Applications

Dependencies

Package Locked Requirement Latest Status Changelog
There is no runtime dependency.
Package Locked Requirement Latest Status Changelog
Npms beautiful-docs ~1.0.3 1.0.3

beautiful-docs

A documentation viewer based on markdown files

This dependency is up-to-date. Congrats and keep going!

Npms chai ~1.8.1 1.9.1

chai

BDD/TDD assertion library for node.js and the browser. Test framework agnostic.

This dependency is not matching latest version. Please consider upgrading.

Npms coffee-script ~1.6.3 1.7.1

coffee-script

Unfancy JavaScript

This dependency is not matching latest version. Please consider upgrading.

Npms coveralls ~2.5.0 2.10.0

coveralls

takes json-cov output into stdin and POSTs to coveralls.io

This dependency is not matching latest version. Please consider upgrading.

Npms grunt ~0.4.2 0.4.4

grunt

The JavaScript Task Runner

This dependency is up-to-date. Congrats and keep going!

Npms grunt-cli ~0.1.11 0.1.13

grunt-cli

The grunt command line interface.

This dependency is up-to-date. Congrats and keep going!

Npms grunt-coffeelint ~0.0.7 0.0.10

grunt-coffeelint

Lint your Coffee

This dependency is up-to-date. Congrats and keep going!

Npms grunt-contrib-coffee ~0.7.0 0.10.1

grunt-contrib-coffee

Compile CoffeeScript files to JavaScript.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-concat ~0.3.0 0.4.0

grunt-contrib-concat

Concatenate files.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-uglify ~0.2.7 0.4.0

grunt-contrib-uglify

Minify files with UglifyJS.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-watch ~0.5.3 0.6.1

grunt-contrib-watch

Run predefined tasks whenever watched file patterns are added, changed or deleted.

This dependency is not matching latest version. Please consider upgrading.

Npms istanbul ~0.1.46 0.2.7

istanbul

Yet another JS code coverage tool that computes statement, line, function and branch coverage with module loader hooks to transparently add coverage when running tests. Supports all JS coverage use cases including unit tests, server side functional tests

This dependency is not matching latest version. Please consider upgrading.

Npms karma ~0.10.5 0.12.9

karma

Spectacular Test Runner for JavaScript.

This dependency is not matching latest version. Please consider upgrading.

Npms karma-coverage ~0.1.2 0.2.1

karma-coverage

A Karma plugin. Generate code coverage.

This dependency is not matching latest version. Please consider upgrading.

Npms karma-mocha ~0.1.0 0.1.3

karma-mocha

A Karma plugin. Adapter for Mocha testing framework.

This dependency is up-to-date. Congrats and keep going!

Npms mocha ~1.14.0 1.18.2

mocha

simple, flexible, fun test framework

This dependency is not matching latest version. Please consider upgrading.

Npms phantomjs ~1.9.2 1.9.7-3

phantomjs

Headless WebKit with JS API

This dependency is up-to-date. Congrats and keep going!

Npms sinon ~1.7.3 1.9.1

sinon

JavaScript test spies, stubs and mocks.

This dependency is not matching latest version. Please consider upgrading.

Npms sinon-chai ~2.4.0 2.5.0

sinon-chai

Extends Chai with assertions for the Sinon.JS mocking framework.

This dependency is not matching latest version. Please consider upgrading.

Npms sloc ~0.0.4 0.0.7

sloc

sloc is a simple tool to count SLOC (source lines of code)

This dependency is up-to-date. Congrats and keep going!

Npms uglify-js ~2.4.6 2.4.13

uglify-js

JavaScript parser, mangler/compressor and beautifier toolkit

This dependency is up-to-date. Congrats and keep going!