Gems_big

guard

2.14.2

Guard is a command line tool to easily handle events on file system modifications.

Critical or Security advisories for 2.14.2

This version doesn't have any advisory. Want to report one?

Changelog for 2.14.2

Bugfix

  • #892 Fix a bug that was preventing logger options from the Guardfile from being correctly set

Improvements

  • #871 Add aliasing section inside tired-of-typing bundle exec
  • #879 Run core with same Ruby version as it was started with
  • #880 Build badge now shows master branch status
  • #881 Update CI matrix to include latest release of JRuby
  • #882 Fix lumberjack version runtime dependency to ">= 1.0.12", "< 2.0"
  • #883 Run CI against Ruby 2.2.8, 2.3.5, and 2.4.2
  • #886 Improve headings in the README
  • #890 Add links to the wiki in CONTRIBUTING.md

Dependencies for 2.14.2

Name Requirement Status
>= 0.2.4

< 4.0, >= 2.7

< 2.0, >= 1.0.12

~> 0.1

~> 0.0

Gems pry
>= 0.9.12

~> 0.0

>= 0.18.1

My projects using guard

Name Locked version Requirement
You should be logged in to see which of your projects use guard.