Gems_big

nokogiri (x86-mingw32)

1.8.2 (x86-mingw32)

Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. Among Nokogiri's many features is the ability to search documents via XPath or CSS3 selectors.

Critical or Security advisories for 1.8.2 (x86-mingw32)

This version doesn't have any advisory. Want to report one?

Critical or Security fixes for 1.8.2 (x86-mingw32)

You need to be logged in to view advisory details.

Login or Signup

Changelog for 1.8.2 (x86-mingw32)

Security Notes

[MRI] The update of vendored libxml2 from 2.9.5 to 2.9.7 addresses at least one published vulnerability, CVE-2017-15412. [#1714 has complete details]

Dependencies

  • [MRI] libxml2 is updated from 2.9.5 to 2.9.7
  • [MRI] libxml2 is updated from 1.1.30 to 1.1.32

Features

  • [MRI] OpenBSD installation should be a bit easier now. [#1685] (Thanks, @jeremyevans!)
  • [MRI] Cross-built Windows gems now support Ruby 2.5

Bug fixes

  • Node#serialize once again returns UTF-8-encoded strings. [#1659]
  • [JRuby] made SAX parsing of characters consistent with C implementation [#1676] (Thanks, @andrew-aladev!)
  • [MRI] Predefined entities, when inspected, no longer cause a segfault. [#1238]

Dependencies for 1.8.2 (x86-mingw32)

Name Requirement Status
~> 2.3.0

My projects using nokogiri

Name Locked version Requirement
You should be logged in to see which of your projects use nokogiri.