Gems_big

structured_warnings

0.3.0

This is an implementation of Daniel Berger's proposal of structured warnings for Ruby.

Critical or Security advisories for 0.3.0

This version doesn't have any advisory. Want to report one?

Changelog for 0.3.0

2017-03-23

  • Major changes
    • Add Ruby 2.4 compatibility
    • Support built-in warnings in Ruby 2.4 with StructuredWarnings::BuiltInWarning
  • Incompatible changes
    • Drop Ruby 1.x compatibility
    • Changed most of the public class names

Dependencies for 0.3.0

Name Requirement Status
This version doesn't have runtime dependencies.

My projects using structured_warnings

Name Locked version Requirement
You should be logged in to see which of your projects use structured_warnings.