This version is outdated! Click here to see latest



WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.

Critical or Security advisories for 1.22.6

This version doesn't have any advisory. Want to report one?

Changelog for 1.22.6

  • Fixes issue around WebMock restricting Addressable version, based on Ruby 1.8.7 for all versions of Ruby.

    This change inverts that, and forces Ruby 1.8.7 users to specify in thier Gemfile an Addressable version < 2.4.0.

    Thanks to PikachuEXE and Matthew Rudy Jacobs.

Dependencies for 1.22.6

Name Requirement Status
>= 2.3.6

>= 0.3.2

>= 0

My projects using webmock

Name Locked version Requirement
You should be logged in to see which of your projects use webmock.