VIP000 VIP000

-

19 16 0

系统集成框架,建成带来的配置管理的好处到你的整个基础设施

Dependencies

Package Locked Requirement Latest Status Changelog
Gems chef-zero ~> 4.0 13.0.0

chef-zero

Self-contained, easy-setup, fast-start in-memory Chef server for testing and solo setup purposes

This dependency is not matching latest version. Please consider upgrading.

Gems diff-lcs >= 1.2.4, ~> 1.2 1.3

diff-lcs

Diff::LCS computes the difference between two Enumerable sequences using the McIlroy-Hunt longest common subsequence (LCS) algorithm. It includes utilities to create a simple HTML diff output format and a standard diff-like tool. This is release 1.3, providing a tentative fix to a long-standing issue related to incorrect detection of a patch direction. Also modernizes the gem infrastructure, testing infrastructure, and provides a warning-free experience to Ruby 2.4 users.

This dependency is up-to-date. Congrats and keep going!

Gems erubis ~> 2.7 2.7.0

erubis

Erubis is an implementation of eRuby and has the following features: * Very fast, almost three times faster than ERB and about 10% faster than eruby. * Multi-language support (Ruby/PHP/C/Java/Scheme/Perl/Javascript) * Auto escaping support * Auto trimming spaces around '<% %>' * Embedded pattern changeable (default '<% %>') * Enable to handle Processing Instructions (PI) as embedded pattern (ex. '<?rb ... ?>') * Context object available and easy to combine eRuby template with YAML datafile * Print statement available * Easy to extend and customize in subclass * Ruby on Rails support

This dependency is up-to-date. Congrats and keep going!

Gems ffi ~> 1.9 1.9.18

ffi

Ruby FFI library

This dependency is up-to-date. Congrats and keep going!

Gems ffi-yajl ~> 1.2 2.3.0

ffi-yajl

Ruby FFI wrapper around YAJL 2.x

This dependency is not matching latest version. Please consider upgrading.

Gems highline >= 1.6.9, ~> 1.6 1.7.8

highline

A high-level IO library that provides validation, type conversion, and more for command-line interfaces. HighLine also includes a complete menu system that can crank out anything from simple list selection to complete shells with just minutes of work.

This dependency is up-to-date. Congrats and keep going!

Gems mixlib-authentication ~> 1.3 1.4.1

mixlib-authentication

Mixes in simple per-request authentication

This dependency is up-to-date. Congrats and keep going!

Gems mixlib-cli ~> 1.4 1.7.0

mixlib-cli

A simple mixin for CLI interfaces, including option parsing

This dependency is up-to-date. Congrats and keep going!

Gems mixlib-config ~> 2.0 2.2.4

mixlib-config

A class based configuration library

This dependency is up-to-date. Congrats and keep going!

Gems mixlib-log ~> 1.3 1.7.1

mixlib-log

A gem that provides a simple mixin for log functionality

This dependency is up-to-date. Congrats and keep going!

Gems mixlib-shellout < 3.0, >= 2.0.0.rc.0 2.2.7

mixlib-shellout

Run external commands on Unix or Windows

This dependency is up-to-date. Congrats and keep going!

Gems net-ssh ~> 2.6 4.1.0

net-ssh

Net::SSH: a pure-Ruby implementation of the SSH2 client protocol. It allows you to write programs that invoke and interact with processes on remote servers, via SSH2.

This dependency is not matching latest version. Please consider upgrading.

Gems net-ssh-multi ~> 1.1 1.2.1

net-ssh-multi

Control multiple Net::SSH connections via a single interface.

This dependency is up-to-date. Congrats and keep going!

Gems ohai ~> 8.0 13.1.0

ohai

Ohai profiles your system and emits JSON

This dependency is not matching latest version. Please consider upgrading.

Gems plist ~> 3.1.0 3.3.0

plist

Plist is a library to manipulate Property List files, also known as plists. It can parse plist files into native Ruby data structures as well as generating new plist files from your Ruby objects.

This dependency is not matching latest version. Please consider upgrading.

Gems pry ~> 0.9 0.10.4

pry

An IRB alternative and runtime developer console

This dependency is up-to-date. Congrats and keep going!

Gems rspec_junit_formatter ~> 0.2.0 0.2.3

rspec_junit_formatter

RSpec results that Hudson can read.

This dependency is up-to-date. Congrats and keep going!

Gems serverspec ~> 2.7 2.39.1

serverspec

RSpec tests for your servers configured by Puppet, Chef, Itamae or anything else

This dependency is up-to-date. Congrats and keep going!

Gems specinfra ~> 2.10 2.68.0

specinfra

Common layer for serverspec and itamae

This dependency is up-to-date. Congrats and keep going!

Gems win32-api ~> 1.5.1 1.6.1.2

win32-api

The Win32::API library is meant as a replacement for the Win32API library that ships as part of the standard library. It contains several advantages over Win32API, including callback support, raw function pointers, an additional string type, and more.

This dependency is not matching latest version. Please consider upgrading.

Gems win32-dir = 0.4.5 0.5.1

win32-dir

The win32-dir library provides extra methods and constants for the builtin Dir class. The constants provide a convenient way to identify certain directories across all versions of Windows. Some methods have been added, such as the ability to create junctions. Others have been modified to provide a more consistent result for MS Windows.

This dependency is not matching latest version. Please consider upgrading.

Gems win32-event = 0.6.1 0.6.3

win32-event

The win32-event library provides an interface to Windows event objects. An event object is a synchronization object whose state can be explicitly set to a signaled state. Event objects are useful in sending a signal to a thread indicating that a particular event has occurred.

This dependency is not matching latest version. Please consider upgrading.

Gems win32-eventlog = 0.6.1 0.6.7

win32-eventlog

The win32-eventlog library provides an interface to the MS Windows event log. Event logging provides a standard, centralized way for applications (and the operating system) to record important software and hardware events. The event-logging service stores events from various sources in a single collection called an event log. This library allows you to inspect existing logs as well as create new ones.

This dependency is not matching latest version. Please consider upgrading.

Gems win32-mmap = 0.4.0 0.4.2

win32-mmap

The win32-mmap library provides an interface for memory mapped IO on MS Windows.

This dependency is not matching latest version. Please consider upgrading.

Gems win32-mutex = 0.4.1 0.4.3

win32-mutex

The win32-mutex library provides an interface for creating mutex objects on MS Windows. A mutex object is a synchronization object whose state is set to signaled when it is not owned by any thread, and non-signaled when it is owned.

This dependency is not matching latest version. Please consider upgrading.

Gems win32-process ~> 0.7.3 0.8.3

win32-process

The win32-process library implements several Process methods that are either unimplemented or dysfunctional in some way in the default Ruby implementation. Examples include Process.kill, Process.uid and Process.create.

This dependency is not matching latest version. Please consider upgrading.

Gems win32-service = 0.8.2 0.8.10

win32-service

The win32-service library provides a Ruby interface to services on MS Windows. You can create new services, or control, configure and inspect existing services. In addition, you can create a pure Ruby service by using the Daemon class that is included as part of the library.

This dependency is not matching latest version. Please consider upgrading.

Gems windows-api ~> 0.4.2 0.4.4

windows-api

The windows-api library provides features over and above the basic interface provided by the win32-api library. Features included automatic constant generation, automatic defintion of ANSI and Unicode methods, special handling of functions that return a boolean value, and the ability to use native Windows type declarations.

This dependency is up-to-date. Congrats and keep going!

Gems windows-pr ~> 1.2.2 1.2.6

windows-pr

The windows-pr library is a collection of Windows functions and constants pre-defined for you using the windows-api library. It also autogenerates explicit ANSI and Wide character versions of those functions, as well as constants that can be used as methods, e.g. CloseHandle() instead of CloseHandle.call().

This dependency is up-to-date. Congrats and keep going!

Gems wmi-lite ~> 1.0 1.0.0

wmi-lite

A lightweight utility over win32ole for accessing basic WMI (Windows Management Instrumentation) functionality in the Microsoft Windows operating system. It has no runtime dependencies other than Ruby, so it can be used without concerns around dependency issues.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems activesupport < 4.0.0 5.1.1

activesupport

A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.

This dependency is not matching latest version. Please consider upgrading.

Gems rack ~> 1.5.1 2.0.3

rack

Rack provides a minimal, modular and adaptable interface for developing web applications in Ruby. By wrapping HTTP requests and responses in the simplest way possible, it unifies and distills the API for web servers, web frameworks, and software in between (the so-called middleware) into a single method call. Also see http://rack.github.io/.

This dependency is not matching latest version. Please consider upgrading.

Gems rake ~> 10.1.0 12.0.0

rake

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * Supports parallel execution of tasks.

This dependency is not matching latest version. Please consider upgrading.

Gems simplecov >= 0 0.14.1

simplecov

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is up-to-date. Congrats and keep going!

Gems yard >= 0 0.9.9

yard

YARD is a documentation generation tool for the Ruby programming language. It enables the user to generate consistent, usable documentation that can be exported to a number of formats very easily, and also supports extending for custom Ruby constructs such as custom class level definitions.

This dependency is up-to-date. Congrats and keep going!