dawson-org dawson-org

dawson-cli

17 33 1

A serverless web framework for Node.js on AWS (CloudFormation, CloudFront, API Gateway, Lambda)

You have 6 open security alerts

Dependencies

Package Locked Requirement Latest Status Changelog
Npms aws-sdk 2.34.0 ^2.34.0 2.171.0

aws-sdk version 2.34.0

AWS SDK for JavaScript

This dependency is not matching latest version. Please consider upgrading.

Npms babel-cli 6.22.2 ^6.14.0 6.26.0

babel-cli version 6.22.2

Babel command line.

This dependency is not matching latest version. Please consider upgrading.

Npms babel-polyfill 6.22.0 ^6.16.0 6.26.0

babel-polyfill version 6.22.0

Provides polyfills necessary for a full ES2015+ environment

This dependency is not matching latest version. Please consider upgrading.

Npms babel-preset-dawson 1.0.0 1.0.0 1.0.0

babel-preset-dawson version 1.0.0

[![npm version](https://badge.fury.io/js/babel-preset-dawson.svg)](https://badge.fury.io/js/babel-preset-dawson) [![npm dependencies](https://david-dm.org/dawson-org/babel-preset-dawson.svg?maxAge=3600)](https://david-dm.org/dawson-org/babel-preset-dawso

This dependency is up-to-date. Congrats and keep going!

Npms babel-register 6.22.0 ^6.16.3 6.26.0

babel-register version 6.22.0

babel require hook

This dependency is not matching latest version. Please consider upgrading.

Npms chalk 1.1.3 ^1.1.3 2.3.0

chalk version 1.1.3

Terminal string styling done right

This dependency is not matching latest version. Please consider upgrading.

Npms chokidar 1.6.1 ^1.6.1 1.7.0

chokidar version 1.6.1

A neat wrapper around node.js fs.watch / fs.watchFile / fsevents.

This dependency is not matching latest version. Please consider upgrading.

Npms cli-table 0.3.1 ^0.3.1 0.3.1

cli-table version 0.3.1

Pretty unicode tables for the CLI

This dependency is up-to-date. Congrats and keep going!

Npms colors 1.1.2 ^1.1.2 1.1.2

colors version 1.1.2

get colors in your node.js console

This dependency is up-to-date. Congrats and keep going!

Npms common-tags 1.4.0 ^1.3.1 1.5.1

common-tags version 1.4.0

a few common utility template tags for ES2015

This dependency is not matching latest version. Please consider upgrading.

Npms console.table 0.8.0 ^0.8.0 0.9.1

console.table version 0.8.0

Adds console.table method that prints an array of objects as a table in console

This dependency is not matching latest version. Please consider upgrading.

Npms del 3.0.0 ^3.0.0 3.0.0

del version 3.0.0

Delete files and folders

This dependency is up-to-date. Congrats and keep going!

Npms docker-lambda 0.13.1 ^0.13.1 0.13.4

docker-lambda version 0.13.1

A Docker image and test runner that (very closely) mimics the live AWS Lambda environment

This dependency is not matching latest version. Please consider upgrading.

Npms es6-promisify 5.0.0 ^5.0.0 5.0.0

es6-promisify version 5.0.0

Converts callback-based functions to ES6 Promises

This dependency is up-to-date. Congrats and keep going!

Npms execa 0.7.0 ^0.7.0 0.8.0

execa version 0.7.0

A better `child_process`

This dependency is not matching latest version. Please consider upgrading.

Npms hard-rejection 1.0.0 ^1.0.0 1.0.0

hard-rejection version 1.0.0

Make unhandled promise rejections fail hard right away instead of the default silent fail

This dependency is up-to-date. Congrats and keep going!

Npms http-proxy 1.16.2 ^1.14.0 1.16.2

http-proxy version 1.16.2

HTTP proxying for the masses

This dependency is up-to-date. Congrats and keep going!

Npms indent-string 3.1.0 ^3.0.0 3.2.0

indent-string version 3.1.0

Indent each line in a string

This dependency is not matching latest version. Please consider upgrading.

Npms listr 0.12.0 ^0.12.0 0.13.0

listr version 0.12.0

Terminal task list

This dependency is not matching latest version. Please consider upgrading.

Npms listr-verbose-renderer 0.4.0 ^0.4.0 0.4.1

listr-verbose-renderer version 0.4.0

Listr verbose renderer

This dependency is not matching latest version. Please consider upgrading.

Npms lodash 4.17.4 ^4.17.2 4.17.4

lodash version 4.17.4

Lodash modular utilities.

This dependency is up-to-date. Congrats and keep going!

Npms minimatch 3.0.3 ^3.0.3 3.0.4

minimatch version 3.0.3

a glob matcher in javascript

This dependency is not matching latest version. Please consider upgrading.

Npms moment 2.18.1 ^2.18.1 2.20.0

moment version 2.18.1

Parse, validate, manipulate, and display dates

Security alert:

Npms prettier 0.22.0 ^0.22.0 1.9.2

prettier version 0.22.0

Prettier is an opinionated code formatter

This dependency is not matching latest version. Please consider upgrading.

Npms prettyjson 1.2.1 ^1.1.3 1.2.1

prettyjson version 1.2.1

Package for formatting JSON data in a coloured YAML-style, perfect for CLI output

This dependency is up-to-date. Congrats and keep going!

Npms prop-types 0.2.0 0.2.0 15.6.0

prop-types version 0.2.0

Runtime type checking for React props and similar objects.

This dependency is not matching latest version. Please consider upgrading.

Npms s3-recursive-uploader 0.3.0 ^0.3.0 0.3.0

s3-recursive-uploader version 0.3.0

recursively uploads files and directories to S3

This dependency is up-to-date. Congrats and keep going!

Npms send 0.15.1 ^0.15.0 0.16.1

send version 0.15.1

Better streaming static file server with Range and conditional-GET support

This dependency is not matching latest version. Please consider upgrading.

Npms source-map-support 0.4.14 ^0.4.14 0.5.0

source-map-support version 0.4.14

Fixes stack traces for files with source maps

This dependency is not matching latest version. Please consider upgrading.

Npms temp 0.8.3 ^0.8.3 0.8.3

temp version 0.8.3

Temporary files and directories

This dependency is up-to-date. Congrats and keep going!

Npms update-notifier 2.1.0 ^2.0.0 2.3.0

update-notifier version 2.1.0

Update notifications for your CLI app

This dependency is not matching latest version. Please consider upgrading.

Npms yargs 8.0.2 ^8.0.2 10.0.3

yargs version 8.0.2

yargs the modern, pirate-themed, successor to optimist.

This dependency is not matching latest version. Please consider upgrading.

Npms zen-observable 0.5.1 ^0.5.1 0.6.0

zen-observable version 0.5.1

An Implementation of ES Observables

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Npms ava 0.19.1 ^0.19.1 0.24.0

ava version 0.19.1

Futuristic test runner 🚀

This dependency is not matching latest version. Please consider upgrading.

Npms commitizen 2.9.6 ^2.9.6 2.9.6

commitizen version 2.9.6

Git commit, but play nice with conventions.

This dependency is up-to-date. Congrats and keep going!

Npms coveralls 2.13.1 ^2.13.1 3.0.0

coveralls version 2.13.1

takes json-cov output into stdin and POSTs to coveralls.io

This dependency is not matching latest version. Please consider upgrading.

Npms cz-conventional-changelog 2.0.0 ^2.0.0 2.1.0

cz-conventional-changelog version 2.0.0

Commitizen adapter following the conventional-changelog format.

This dependency is not matching latest version. Please consider upgrading.

Npms deep-sort-object 1.0.2 ^1.0.2 1.0.2

deep-sort-object version 1.0.2

Sorts object by its keys

This dependency is up-to-date. Congrats and keep going!

Npms eslint 4.1.0 ^4.1.0 4.13.1

eslint version 4.1.0

An AST-based pattern checker for JavaScript.

This dependency is not matching latest version. Please consider upgrading.

Npms eslint-config-semistandard 11.0.0 ^11.0.0 11.0.0

eslint-config-semistandard version 11.0.0

eslint sharable config for semistandard

This dependency is up-to-date. Congrats and keep going!

Npms eslint-config-standard 10.2.1 ^10.2.1 11.0.0-beta.0

eslint-config-standard version 10.2.1

JavaScript Standard Style - ESLint Shareable Config

This dependency is up-to-date. Congrats and keep going!

Npms eslint-plugin-import 2.6.0 ^2.6.0 2.8.0

eslint-plugin-import version 2.6.0

Import with sanity.

This dependency is not matching latest version. Please consider upgrading.

Npms eslint-plugin-node 5.0.0 ^5.0.0 5.2.1

eslint-plugin-node version 5.0.0

Additional ESLint's rules for Node.js

This dependency is not matching latest version. Please consider upgrading.

Npms eslint-plugin-promise 3.5.0 ^3.5.0 3.6.0

eslint-plugin-promise version 3.5.0

Enforce best practices for JavaScript promises

This dependency is not matching latest version. Please consider upgrading.

Npms eslint-plugin-standard 3.0.1 ^3.0.1 3.0.1

eslint-plugin-standard version 3.0.1

ESlint Plugin for the Standard Linter

This dependency is up-to-date. Congrats and keep going!

Npms husky 0.14.0 ^0.14.0 0.14.3

husky version 0.14.0

Prevents bad commit or push (git hooks, pre-commit/precommit, pre-push/prepush, post-merge/postmerge and all that stuff...)

This dependency is not matching latest version. Please consider upgrading.

Npms jest-snapshot 20.0.3 ^20.0.3 21.2.1

This dependency is not matching latest version. Please consider upgrading.

Npms nyc 11.0.2 ^11.0.2 11.3.0

nyc version 11.0.2

the Istanbul command line interface

This dependency is not matching latest version. Please consider upgrading.

Npms prettier-eslint-cli 4.1.1 ^4.1.1 4.6.1

prettier-eslint-cli version 4.1.1

CLI for prettier-eslint

This dependency is not matching latest version. Please consider upgrading.

Npms snazzy 7.0.0 ^7.0.0 7.0.0

snazzy version 7.0.0

Format JavaScript Standard Style as Stylish (i.e. snazzy) output

This dependency is up-to-date. Congrats and keep going!

Npms validate-commit-msg 2.12.2 ^2.12.2 2.14.0

validate-commit-msg version 2.12.2

Script to validate a commit message follows the conventional changelog standard

This dependency is not matching latest version. Please consider upgrading.