dfellis dfellis

spahql

3 5 3

A query language for Javascript data. Extracted from Spah.

You have 16 open security alerts

Dependencies

Package Locked Requirement Latest Status Changelog
Gems mustache 0.99.4 ~> 0.99.3 1.0.5

mustache version 0.99.4

Inspired by ctemplate, Mustache is a framework-agnostic way to render logic-free views. As ctemplates says, "It emphasizes separating logic from presentation: it is impossible to embed application logic in this template language. Think of Mustache as a replacement for your views. Instead of views consisting of ERB or HAML with random helpers and arbitrary logic, your views are broken into two parts: a Ruby class and an HTML template.

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Gems albino 1.3.3 ~> 1.3.3 1.3.3

albino version 1.3.3

Ruby wrapper for pygmentize.

This dependency is up-to-date. Congrats and keep going!

Gems bundler ~> 1.1.0 1.16.1

bundler

Bundler manages an application's dependencies through its entire life, across many machines, systematically and repeatably

Gems json 1.5.4 ~> 1.5.0 2.1.0

json version 1.5.4

This is a JSON implementation as a Ruby extension in C.

Gems liquid 2.3.0 >= 0 4.0.0

liquid version 2.3.0

A secure, non-evaling end user template engine with aesthetic markup.

This dependency is not matching latest version. Please consider upgrading.

Gems maruku 0.6.0 >= 0 0.7.3

maruku version 0.6.0

Maruku is a Markdown interpreter in Ruby. It features native export to HTML and PDF (via Latex). The output is really beautiful!

This dependency is not matching latest version. Please consider upgrading.

Npms nodeunit * 0.11.2

nodeunit

Easy unit testing for node.js and the browser.

This dependency is up-to-date. Congrats and keep going!

Gems nokogiri 1.5.2 >= 0 1.8.2

nokogiri version 1.5.2

Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. Among Nokogiri's many features is the ability to search documents via XPath or CSS3 selectors.

Gems pdoc 0.2.0 ~> 0.2.0 0.2.0

pdoc version 0.2.0

PDoc is an inline comment parser and JavaScript documentation generator written in Ruby. It is designed for documenting Prototype and Prototype-based libraries.

This dependency is up-to-date. Congrats and keep going!

Gems rake 0.9.2.2 >= 0 12.3.0

rake version 0.9.2.2

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * Supports parallel execution of tasks.

This dependency is not matching latest version. Please consider upgrading.

Gems sinatra 1.1.4 ~> 1.1.0 2.0.1

sinatra version 1.1.4

Sinatra is a DSL for quickly creating web applications in Ruby with minimal effort.

This dependency is not matching latest version. Please consider upgrading.