hakatashi hakatashi

cli

10 15 0

:cl::round_pushpin: single command setup

Dependencies

Package Locked Requirement Latest Status Changelog
Npms async ^1.2.1 2.4.1

async

Higher-order functions and common patterns for asynchronous code

This dependency is not matching latest version. Please consider upgrading.

Npms base32 0.0.6 0.0.6

base32

Base32 encoding and decoding

This dependency is up-to-date. Congrats and keep going!

Npms github-url-from-git ^1.4.0 1.5.0

github-url-from-git

Parse a github git url and return the github repo url

This dependency is up-to-date. Congrats and keep going!

Npms ini ^1.3.4 1.3.4

ini

An ini encoder/decoder for node

This dependency is up-to-date. Congrats and keep going!

Npms inquirer ^0.9.0 3.0.6

inquirer

A collection of common interactive command line user interfaces.

This dependency is not matching latest version. Please consider upgrading.

Npms js-yaml ^3.3.1 3.8.4

js-yaml

YAML 1.2 parser and serializer

This dependency is up-to-date. Congrats and keep going!

Npms keytar ^3.0.0 4.0.3

keytar

Bindings to native Mac/Linux/Windows password APIs

This dependency is not matching latest version. Please consider upgrading.

Npms lodash ^3.10.1 4.17.4

lodash

Lodash modular utilities.

This dependency is not matching latest version. Please consider upgrading.

Npms nopt ^3.0.2 4.0.1

nopt

Option parsing for Node, supporting types, shorthands, etc. Used by npm.

This dependency is not matching latest version. Please consider upgrading.

Npms npm-registry-client ^6.4.0 8.3.0

npm-registry-client

Client for the npm registry

This dependency is not matching latest version. Please consider upgrading.

Npms npmconf ^2.1.2 2.1.2

npmconf

The config thing npm uses

This dependency is up-to-date. Congrats and keep going!

Npms npmlog ^2.0.0 4.1.0

npmlog

logger for npm

This dependency is not matching latest version. Please consider upgrading.

Npms parse-github-repo-url ^1.0.0 1.4.0

parse-github-repo-url

Parse a GitHub URL for user/project@version

This dependency is up-to-date. Congrats and keep going!

Npms request ^2.58.0 2.81.0

request

Simplified HTTP request client.

This dependency is up-to-date. Congrats and keep going!

Npms update-notifier ^0.5.0 2.1.0

update-notifier

Update notifications for your CLI app

This dependency is not matching latest version. Please consider upgrading.

Npms user-home ^2.0.0 2.0.0

user-home

Get the path to the user home directory

This dependency is up-to-date. Congrats and keep going!

Npms validator ^3.40.1 7.0.0

validator

String validation and sanitization

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Npms babel ^5.5.8 6.23.0

babel

Turn ES6 code into readable vanilla ES5 with source maps

This dependency is not matching latest version. Please consider upgrading.

Npms cz-conventional-changelog ^1.1.0 2.0.0

cz-conventional-changelog

Commitizen adapter following the conventional-changelog format.

This dependency is not matching latest version. Please consider upgrading.

Npms mkdirp ^0.5.1 0.5.1

mkdirp

Recursively mkdir, like `mkdir -p`

This dependency is up-to-date. Congrats and keep going!

Npms nyc ^3.0.0 10.3.2

nyc

the Istanbul command line interface

This dependency is not matching latest version. Please consider upgrading.

Npms rimraf ^2.4.2 2.6.1

rimraf

A deep deletion module for node (like `rm -rf`)

This dependency is up-to-date. Congrats and keep going!

Npms semantic-release ^4.0.0 6.3.2

semantic-release

automated semver compliant package publishing

This dependency is not matching latest version. Please consider upgrading.

Npms standard ^5.4.1 10.0.2

standard

JavaScript Standard Style

This dependency is not matching latest version. Please consider upgrading.

Npms tap ^2.1.1 10.3.2

tap

A Test-Anything-Protocol library

This dependency is not matching latest version. Please consider upgrading.