hakatashi hakatashi

esolang-battle

0 32 0

Win the esolang master!!!

Dependencies

Package Locked Requirement Latest Status Changelog
Npms array-shuffle 1.0.1 ^1.0.1 1.0.1

array-shuffle version 1.0.1

Randomize the order of items in an array

Npms async 2.1.5 ^2.1.2 2.5.0

async version 2.1.5

Higher-order functions and common patterns for asynchronous code

This dependency is not matching latest version. Please consider upgrading.

Npms bcrypt-nodejs 0.0.3 ^0.0.3 0.0.3

bcrypt-nodejs version 0.0.3

A native JS bcrypt library for NodeJS.

Npms bignumber.js 4.0.0 ^4.0.0 4.0.2

bignumber.js version 4.0.0

A library for arbitrary-precision decimal and non-decimal arithmetic

This dependency is not matching latest version. Please consider upgrading.

Npms bluebird 3.5.0 ^3.5.0 3.5.0

bluebird version 3.5.0

Full featured Promises/A+ implementation with exceptionally good performance

Npms body-parser 1.17.1 ^1.15.2 1.17.2

body-parser version 1.17.1

Node.js body parsing middleware

This dependency is not matching latest version. Please consider upgrading.

Npms chalk 1.1.3 ^1.1.3 2.1.0

chalk version 1.1.3

Terminal string styling done right

This dependency is not matching latest version. Please consider upgrading.

Npms cheerio 0.22.0 ^0.22.0 1.0.0-rc.2

cheerio version 0.22.0

Tiny, fast, and elegant implementation of core jQuery designed specifically for the server

This dependency is not matching latest version. Please consider upgrading.

Npms clockwork 0.1.4 ^0.1.4 0.1.4

clockwork version 0.1.4

Mediaburst Clockwork API wrapper

Npms compression 1.6.2 ^1.6.2 1.7.0

compression version 1.6.2

Node.js compression middleware

This dependency is not matching latest version. Please consider upgrading.

Npms concat-stream 1.6.0 ^1.6.0 1.6.0

concat-stream version 1.6.0

writable stream that concatenates strings or binary data and calls a callback with the result

Npms connect-mongo 1.3.2 ^1.3.2 1.3.2

connect-mongo version 1.3.2

MongoDB session store for Express and Connect

Npms dockerode 2.4.2 ^2.4.2 2.5.0

dockerode version 2.4.2

Docker Remote API module.

This dependency is not matching latest version. Please consider upgrading.

Npms dotenv 4.0.0 ^4.0.0 4.0.0

dotenv version 4.0.0

Loads environment variables from .env file

Npms errorhandler 1.5.0 ^1.4.3 1.5.0

errorhandler version 1.5.0

Development-only error handler middleware

Npms express 4.15.2 ^4.14.0 4.15.4

express version 4.15.2

Fast, unopinionated, minimalist web framework

This dependency is not matching latest version. Please consider upgrading.

Npms express-flash 0.0.2 ^0.0.2 0.0.2

express-flash version 0.0.2

Flash Messages for your Express Application

Npms express-session 1.15.1 ^1.14.2 1.15.5

express-session version 1.15.1

Simple session middleware for Express

This dependency is not matching latest version. Please consider upgrading.

Npms express-status-monitor 0.1.9 ^0.1.5 1.0.0

express-status-monitor version 0.1.9

Realtime Monitoring for Express-based Node applications

This dependency is not matching latest version. Please consider upgrading.

Npms express-validator 3.1.2 ^3.1.2 3.2.1

express-validator version 3.1.2

Express middleware for the validator module.

This dependency is not matching latest version. Please consider upgrading.

Npms fbgraph 1.4.1 ^1.3.0 1.4.1

fbgraph version 1.4.1

Facebook Graph API client

Npms github 9.2.0 ^9.2.0 9.3.0

github version 9.2.0

NodeJS wrapper for the GitHub API

This dependency is not matching latest version. Please consider upgrading.

Npms instagram-node 0.5.8 ^0.5.8 0.5.8

instagram-node version 0.5.8

Simple Instagram driver for Node.js

Npms lastfm 0.9.2 ^0.9.2 0.9.2

lastfm version 0.9.2

Read and write to Last.fm

Npms lob 3.9.0 ^3.9.0 4.1.1

lob version 3.9.0

Lob API wrapper

This dependency is not matching latest version. Please consider upgrading.

Npms lodash 4.17.4 ^4.16.6 4.17.4

lodash version 4.17.4

Lodash modular utilities.

Npms lusca 1.4.1 ^1.4.1 1.5.1

lusca version 1.4.1

Application security for express.

This dependency is not matching latest version. Please consider upgrading.

Npms moment 2.18.1 ^2.16.0 2.18.1

moment version 2.18.1

Parse, validate, manipulate, and display dates

Npms mongoose 4.9.1 ^4.6.6 4.11.7

mongoose version 4.9.1

Mongoose MongoDB ODM

This dependency is not matching latest version. Please consider upgrading.

Npms morgan 1.8.1 ^1.7.0 1.8.2

morgan version 1.8.1

HTTP request logger middleware for node.js

This dependency is not matching latest version. Please consider upgrading.

Npms multer 1.3.0 ^1.3.0 1.3.0

multer version 1.3.0

Middleware for handling `multipart/form-data`.

Npms nightmare 2.10.0 ^2.8.1 2.10.0

nightmare version 2.10.0

A high-level browser automation library.

Npms node-foursquare 0.3.0 ^0.3.0 0.3.0

node-foursquare version 0.3.0

Fault-tolerant Foursquare/Swarm API v2 wrapper for Node JS.

Npms node-linkedin 0.5.4 ^0.5.4 0.5.4

node-linkedin version 0.5.4

LinkedIn 2.0 compatible wrapper in node.js

Npms node-sass-middleware 0.11.0 ^0.11.0 0.11.0

node-sass-middleware version 0.11.0

Connect middleware for node-sass

Npms node-slack 0.0.7 0.0.7 0.0.7

node-slack version 0.0.7

Send and receive Slack Webhooks easily!

Npms nodemailer 3.1.8 ^3.1.8 4.0.1

nodemailer version 3.1.8

Easy as cake e-mail sending from your Node.js applications

This dependency is not matching latest version. Please consider upgrading.

Npms passport 0.3.2 0.3.2 0.4.0

passport version 0.3.2

Simple, unobtrusive authentication for Node.js.

This dependency is not matching latest version. Please consider upgrading.

Npms passport-facebook 2.1.1 ^2.1.1 2.1.1

passport-facebook version 2.1.1

Facebook authentication strategy for Passport.

Npms passport-github 1.1.0 ^1.1.0 1.1.0

passport-github version 1.1.0

GitHub authentication strategy for Passport.

Npms passport-google-oauth 1.0.0 ^1.0.0 1.0.0

passport-google-oauth version 1.0.0

Google (OAuth) authentication strategies for Passport.

Npms passport-instagram 1.0.0 ^1.0.0 1.0.0

passport-instagram version 1.0.0

Instagram authentication strategy for Passport.

Npms passport-linkedin-oauth2 1.5.0 ^1.4.1 1.5.0

passport-linkedin-oauth2 version 1.5.0

Passport for LinkedIn Oauth2

Npms passport-local 1.0.0 ^1.0.0 1.0.0

passport-local version 1.0.0

Local username and password authentication strategy for Passport.

Npms passport-oauth 1.0.0 ^1.0.0 1.0.0

passport-oauth version 1.0.0

OAuth 1.0 and 2.0 authentication strategies for Passport.

Npms passport-openid 0.4.0 ^0.4.0 0.4.0

passport-openid version 0.4.0

OpenID authentication strategy for Passport.

Npms passport-twitter 1.0.4 ^1.0.4 1.0.4

passport-twitter version 1.0.4

Twitter authentication strategy for Passport.

Npms paypal-rest-sdk 1.7.1 ^1.7.0 1.7.1

paypal-rest-sdk version 1.7.1

SDK for PayPal REST APIs

Npms pug 2.0.0-beta9 ^2.0.0-beta6 2.0.0-rc.3

pug version 2.0.0-beta9

A clean, whitespace-sensitive template language for writing HTML

This dependency is not matching latest version. Please consider upgrading.

Npms request 2.81.0 ^2.78.0 2.81.0

request version 2.81.0

Simplified HTTP request client.

Npms shell-escape 0.2.0 ^0.2.0 0.2.0

shell-escape version 0.2.0

Escape and stringify an array of arguments to be executed on the shell

Npms socket.io 1.7.3 ^1.5.1 2.0.3

socket.io version 1.7.3

node.js realtime framework server

This dependency is not matching latest version. Please consider upgrading.

Npms stripe 4.16.0 ^4.12.0 4.24.0

stripe version 4.16.0

Stripe API wrapper

This dependency is not matching latest version. Please consider upgrading.

Npms tmp 0.0.31 ^0.0.31 0.0.33

tmp version 0.0.31

Temporary file and directory creator

This dependency is not matching latest version. Please consider upgrading.

Npms tumblr.js 1.1.1 ^1.1.1 1.1.1

tumblr.js version 1.1.1

Official JavaScript client for the Tumblr API

Npms twilio 3.3.1-edge ^3.3.1-edge 3.6.3

twilio version 3.3.1-edge

A Twilio helper library

This dependency is not matching latest version. Please consider upgrading.

Npms twit 2.2.5 ^2.2.5 2.2.9

twit version 2.2.5

Twitter API client for node (REST & Streaming)

This dependency is not matching latest version. Please consider upgrading.

Npms validator 7.0.0 ^7.0.0 8.0.0

validator version 7.0.0

String validation and sanitization

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Npms chai 3.5.0 ^3.5.0 4.1.1

chai version 3.5.0

BDD/TDD assertion library for node.js and the browser. Test framework agnostic.

This dependency is not matching latest version. Please consider upgrading.

Npms eslint 3.18.0 ^3.9.1 4.5.0

eslint version 3.18.0

An AST-based pattern checker for JavaScript.

This dependency is not matching latest version. Please consider upgrading.

Npms eslint-config-airbnb-base 11.1.1 ^11.1.1 11.3.1

eslint-config-airbnb-base version 11.1.1

Airbnb's base JS ESLint config, following our styleguide

This dependency is not matching latest version. Please consider upgrading.

Npms eslint-plugin-import 2.2.0 ^2.1.0 2.7.0

eslint-plugin-import version 2.2.0

Import with sanity.

This dependency is not matching latest version. Please consider upgrading.

Npms mocha 3.2.0 ^3.1.2 3.5.0

mocha version 3.2.0

simple, flexible, fun test framework

This dependency is not matching latest version. Please consider upgrading.

Npms sinon 2.1.0 ^2.1.0 3.2.1

sinon version 2.1.0

JavaScript test spies, stubs and mocks.

This dependency is not matching latest version. Please consider upgrading.

Npms sinon-mongoose 1.3.0 ^1.3.0 2.0.2

sinon-mongoose version 1.3.0

Sinon extensions for Mongoose stubs

This dependency is not matching latest version. Please consider upgrading.

Npms supertest 3.0.0 ^3.0.0 3.0.0

supertest version 3.0.0

SuperAgent driven library for testing HTTP servers