hakatashi hakatashi

jshint

3 18 1

JSHint is a tool that helps to detect errors and potential problems in your JavaScript code

You have 1 open security alert

Dependencies

Package Locked Requirement Latest Status Changelog
Npms cli 0.6.x 1.0.1

cli

A tool for rapidly building command line apps

This dependency is not matching latest version. Please consider upgrading.

Npms console-browserify 1.1.x 1.1.0

console-browserify

Emulate console for all the browsers

This dependency is up-to-date. Congrats and keep going!

Npms exit 0.1.x 0.1.2

exit

A replacement for process.exit that ensures stdio are fully drained before exiting.

This dependency is up-to-date. Congrats and keep going!

Npms htmlparser2 3.8.x 3.9.2

htmlparser2

Fast & forgiving HTML/XML/RSS parser

This dependency is not matching latest version. Please consider upgrading.

Npms lodash 3.7.x 4.17.4

lodash

Lodash modular utilities.

This dependency is not matching latest version. Please consider upgrading.

Npms minimatch 2.0.x 3.0.4

minimatch

a glob matcher in javascript

Security alert:

Npms shelljs 0.3.x 0.7.8

shelljs

Portable Unix shell commands for Node.js

This dependency is not matching latest version. Please consider upgrading.

Npms strip-json-comments 1.0.x 2.0.1

strip-json-comments

Strip comments from JSON. Lets you use comments in your JSON files!

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Npms browserify 9.x 14.4.0

browserify

browser-side require() the node way

This dependency is not matching latest version. Please consider upgrading.

Npms conventional-changelog 0.4.x 1.1.6

conventional-changelog

Generate a changelog from git metadata

This dependency is not matching latest version. Please consider upgrading.

Npms conventional-github-releaser 0.4.x 1.1.12

conventional-github-releaser

Make a new GitHub release from git metadata.

This dependency is not matching latest version. Please consider upgrading.

Npms coveralls 2.11.x 3.0.0

coveralls

takes json-cov output into stdin and POSTs to coveralls.io

This dependency is not matching latest version. Please consider upgrading.

Npms istanbul 0.3.x 0.4.5

istanbul

Yet another JS code coverage tool that computes statement, line, function and branch coverage with module loader hooks to transparently add coverage when running tests. Supports all JS coverage use cases including unit tests, server side functional tests

This dependency is not matching latest version. Please consider upgrading.

Npms jscs 1.11.x 3.0.7

jscs

JavaScript Code Style

This dependency is not matching latest version. Please consider upgrading.

Npms jshint 2.6.x 2.9.5

jshint

Static analysis tool for JavaScript

This dependency is not matching latest version. Please consider upgrading.

Npms mock-stdin 0.3.x 0.3.1

mock-stdin

Mock STDIN file descriptor in Node.js

This dependency is up-to-date. Congrats and keep going!

Npms nodeunit 0.9.x 0.11.1

nodeunit

Easy unit testing for node.js and the browser.

This dependency is not matching latest version. Please consider upgrading.

Npms phantom ~0.7.2 4.0.5

phantom

PhantomJS integration module for NodeJS

This dependency is not matching latest version. Please consider upgrading.

Npms phantomjs 1.9.13 2.1.7

phantomjs

Headless WebKit with JS API

This dependency is not matching latest version. Please consider upgrading.

Npms regenerate 1.2.x 1.3.3

regenerate

Generate JavaScript-compatible regular expressions based on a given set of Unicode symbols or code points.

This dependency is not matching latest version. Please consider upgrading.

Npms sinon 1.12.x 4.0.1

sinon

JavaScript test spies, stubs and mocks.

This dependency is not matching latest version. Please consider upgrading.

Npms unicode-6.3.0 0.1.x 0.7.4

unicode-6.3.0

JavaScript-compatible Unicode data. Arrays of code points, arrays of symbols, and regular expressions for Unicode v6.3.0’s categories, scripts, blocks, bidi, and other properties.

This dependency is not matching latest version. Please consider upgrading.