gitlabhq gitlabhq

gitlabhq

36 98 0

GitLab is version control for your server

You have 1 open security alert

Reports Beta

Some reports are compatible with your project but none of them has been enabled.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems RedCloth 4.2.9 >= 0 4.2.9

RedCloth version 4.2.9

Textile parser for Ruby.

This dependency is up-to-date. Congrats and keep going!

Gems ace-rails-ap 2.0.1 >= 0 3.0.2

ace-rails-ap version 2.0.1

The Ajax.org Cloud9 Editor (Ace) for the Rails 3.1 asset pipeline.

This dependency is not matching latest version. Please consider upgrading.

Gems acts-as-taggable-on 3.5.0 ~> 3.4 3.5.0

acts-as-taggable-on version 3.5.0

With ActsAsTaggableOn, you can tag a single model on several contexts, such as skills, interests, and awards. It also provides other advanced functionality.

This dependency is up-to-date. Congrats and keep going!

Gems addressable 2.3.5 >= 0 2.3.8

addressable version 2.3.5

Addressable is a replacement for the URI implementation that is part of Ruby's standard library. It more closely conforms to the relevant RFCs and adds support for IRIs and URI templates.

This dependency is not matching latest version. Please consider upgrading.

Gems asana 0.0.6 ~> 0.0.6 0.0.6

asana version 0.0.6

Ruby wrapper for the Asana REST API

This dependency is up-to-date. Congrats and keep going!

Gems asciidoctor 0.1.4 = 0.1.4 1.5.2

asciidoctor version 0.1.4

A fast, open source text processor and publishing toolchain, written in Ruby, for converting AsciiDoc content to HTML5, DocBook 5 (or 4.5) and other formats.

This dependency is not matching latest version. Please consider upgrading.

Gems bootstrap-sass 3.3.3 ~> 3.0 3.3.4.1

bootstrap-sass version 3.3.3

Twitter's Bootstrap, converted to Sass and ready to drop into Rails or Compass

This dependency is not matching latest version. Please consider upgrading.

Gems browser 0.7.2 >= 0 0.8.0

browser version 0.7.2

Do some browser detection with Ruby.

This dependency is not matching latest version. Please consider upgrading.

Gems cal-heatmap-rails 0.0.1 ~> 0.0.1 3.5.1

cal-heatmap-rails version 0.0.1

Packages Cal-HeatMap for Rails Asset Pipeline

This dependency is not matching latest version. Please consider upgrading.

Gems carrierwave 0.9.0 >= 0 0.10.0

carrierwave version 0.9.0

Upload files in your Ruby applications, map them to a range of ORMs, store them on different backends.

This dependency is not matching latest version. Please consider upgrading.

Gems charlock_holmes 0.6.9.4 >= 0 0.7.3

charlock_holmes version 0.6.9.4

charlock_holmes provides binary and text detection as well as text transcoding using libicu

This dependency is not matching latest version. Please consider upgrading.

Gems coffee-rails 4.0.1 >= 0 4.1.0

coffee-rails version 4.0.1

CoffeeScript adapter for the Rails asset pipeline.

This dependency is not matching latest version. Please consider upgrading.

Gems colored 1.2 >= 0 1.2

colored version 1.2

>> puts "this is red".red >> puts "this is red with a blue background (read: ugly)".red_on_blue >> puts "this is red with an underline".red.underline >> puts "this is really bold and really blue".bold.blue >> logger.debug "hey this is broken!".red_on_yellow # in rails >> puts Color.red "This is red" # but this part is mostly untested

This dependency is up-to-date. Congrats and keep going!

Gems creole 0.3.8 ~> 0.3.6 0.5.0

creole version 0.3.8

Creole is a lightweight markup language (http://wikicreole.org/).

This dependency is not matching latest version. Please consider upgrading.

Gems d3_rails 3.1.10 ~> 3.1.4 3.5.5

d3_rails version 3.1.10

Gem installation of javascript framework for data visualization, D3

This dependency is not matching latest version. Please consider upgrading.

Gems default_value_for 3.0.0 ~> 3.0.0 3.0.1

default_value_for version 3.0.0

The default_value_for plugin allows one to define default values for ActiveRecord models in a declarative manner

This dependency is not matching latest version. Please consider upgrading.

Gems devise 3.2.4 = 3.2.4 3.4.1

devise version 3.2.4

Flexible authentication solution for Rails with Warden

This dependency is not matching latest version. Please consider upgrading.

Gems devise-async 0.9.0 = 0.9.0 0.9.0

devise-async version 0.9.0

Send Devise's emails in background. Supports Resque, Sidekiq, Delayed::Job and QueueClassic.

This dependency is up-to-date. Congrats and keep going!

Gems diffy 3.0.3 ~> 3.0.3 3.0.7

diffy version 3.0.3

Convenient diffing in ruby

This dependency is not matching latest version. Please consider upgrading.

Gems doorkeeper 2.1.3 = 2.1.3 2.1.4

doorkeeper version 2.1.3

Doorkeeper is an OAuth 2 provider for Rails.

This dependency is not matching latest version. Please consider upgrading.

Gems dropzonejs-rails 0.4.14 >= 0 0.7.1

dropzonejs-rails version 0.4.14

Adds Dropzone, a great JS File upload by Matias Meno, to the Rails Asset pipeline.

This dependency is not matching latest version. Please consider upgrading.

Gems enumerize 0.7.0 >= 0 0.11.0

enumerize version 0.7.0

Enumerated attributes with I18n and ActiveRecord/Mongoid/MongoMapper support

This dependency is not matching latest version. Please consider upgrading.

Gems fog 1.21.0 ~> 1.14 1.29.0

fog version 1.21.0

The Ruby cloud services library. Supports all major cloud providers including AWS, Rackspace, Linode, Blue Box, StormOnDemand, and many others. Full support for most AWS services including EC2, S3, CloudWatch, SimpleDB, ELB, and RDS.

This dependency is not matching latest version. Please consider upgrading.

Gems font-awesome-rails 4.2.0.0 ~> 4.2 4.3.0.0

font-awesome-rails version 4.2.0.0

I like font-awesome. I like the asset pipeline. I like semantic versioning. If you do too, you're welcome.

This dependency is not matching latest version. Please consider upgrading.

Gems foreman 0.63.0 >= 0 0.78.0

foreman version 0.63.0

Process manager for applications with multiple components

This dependency is not matching latest version. Please consider upgrading.

Gems gemnasium-gitlab-service 0.2.6 ~> 0.2 0.2.6

gemnasium-gitlab-service version 0.2.6

Add Gemnasium support to Gitlab as a Project Service. It uploads the dependency files to https://api.gemnasium.com whenever a new commit is pushed to your repository.

This dependency is up-to-date. Congrats and keep going!

Gems github-markup 1.3.1 >= 0 1.3.3

github-markup version 1.3.1

This gem is used by GitHub to render any fancy markup such as Markdown, Textile, Org-Mode, etc. Fork it and add your own!

This dependency is not matching latest version. Please consider upgrading.

Gems gitlab-flowdock-git-hook 0.4.2.2 ~> 0.4.2 0.4.2.2

gitlab-flowdock-git-hook version 0.4.2.2

Git Post-Receive hook for Flowdock. Gem requirements patched for use with Gitlab.

This dependency is up-to-date. Congrats and keep going!

Gems gitlab-grack 2.0.0 ~> 2.0.0.rc2 2.0.0

gitlab-grack version 2.0.0

Ruby/Rack Git Smart-HTTP Server Handler

This dependency is up-to-date. Congrats and keep going!

Gems gitlab-linguist 3.0.1 ~> 3.0.1 3.0.1

gitlab-linguist version 3.0.1

GitLab Language detection

This dependency is up-to-date. Congrats and keep going!

Gems gitlab_emoji 0.1.0 ~> 0.1 0.1.0

gitlab_emoji version 0.1.0

GitLab emoji assets

This dependency is up-to-date. Congrats and keep going!

Gems gitlab_git 7.1.9 ~> 7.1.9 7.1.10

gitlab_git version 7.1.9

GitLab wrapper around git objects

This dependency is not matching latest version. Please consider upgrading.

Gems gitlab_meta 7.0 = 7.0 7.0

gitlab_meta version 7.0

GitLab meta gem

This dependency is up-to-date. Congrats and keep going!

Gems gitlab_omniauth-ldap 1.2.1 = 1.2.1 1.2.1

gitlab_omniauth-ldap version 1.2.1

A LDAP strategy for OmniAuth.

This dependency is up-to-date. Congrats and keep going!

Gems gollum-lib 4.0.2 ~> 4.0.2 4.0.3

gollum-lib version 4.0.2

A simple, Git-powered wiki with a sweet API and local frontend.

This dependency is not matching latest version. Please consider upgrading.

Gems gon 5.0.1 ~> 5.0.0 5.2.3

gon version 5.0.1

If you need to send some data to your js files and you don't want to do this with long way trough views and parsing - use this force!

This dependency is not matching latest version. Please consider upgrading.

Gems grape 0.6.1 ~> 0.6.1 0.11.0

grape version 0.6.1

A Ruby framework for rapid API development with great conventions.

This dependency is not matching latest version. Please consider upgrading.

Gems grape-entity 0.4.2 ~> 0.4.2 0.4.5

grape-entity version 0.4.2

Extracted from Grape, A Ruby framework for rapid API development with great conventions.

This dependency is not matching latest version. Please consider upgrading.

Gems growl 1.0.3 >= 0 1.0.3

growl version 1.0.3

growlnotify bindings

This dependency is up-to-date. Congrats and keep going!

Gems haml-rails 0.5.3 >= 0 0.9.0

haml-rails version 0.5.3

Haml-rails provides Haml generators for Rails 4. It also enables Haml as the templating engine for you, so you don't have to screw around in your own application.rb when your Gemfile already clearly indicated what templating engine you have installed. Hurrah.

This dependency is not matching latest version. Please consider upgrading.

Gems hipchat 1.4.0 ~> 1.4.0 1.5.1

hipchat version 1.4.0

Ruby library to interact with HipChat

This dependency is not matching latest version. Please consider upgrading.

Gems html-pipeline-gitlab 0.2.0 ~> 0.1 0.2.0

html-pipeline-gitlab version 0.2.0

Extension filters for html-pipeline used by GitLab

This dependency is up-to-date. Congrats and keep going!

Gems httparty 0.13.0 >= 0 0.13.3

httparty version 0.13.0

Makes http fun! Also, makes consuming restful web services dead easy.

This dependency is not matching latest version. Please consider upgrading.

Gems jquery-atwho-rails 0.3.3 ~> 0.3.3 1.0.1

jquery-atwho-rails version 0.3.3

This is a jQuery plugin that implement Github-like mentions.

This dependency is not matching latest version. Please consider upgrading.

Gems jquery-rails 3.1.0 >= 0 4.0.3

jquery-rails version 3.1.0

This gem provides jQuery and the jQuery-ujs driver for your Rails 4+ application.

This dependency is not matching latest version. Please consider upgrading.

Gems jquery-scrollto-rails 1.4.3 >= 0 1.4.3

jquery-scrollto-rails version 1.4.3

This provides jQUery scrollTo for your Rails 3 application

This dependency is up-to-date. Congrats and keep going!

Gems jquery-turbolinks 2.0.1 >= 0 2.1.0

jquery-turbolinks version 2.0.1

jQuery plugin for drop-in fix binded events problem caused by Turbolinks

This dependency is not matching latest version. Please consider upgrading.

Gems jquery-ui-rails 4.2.1 >= 0 5.0.3

jquery-ui-rails version 4.2.1

jQuery UI's JavaScript, CSS, and image files packaged for the Rails 3.1+ asset pipeline

This dependency is not matching latest version. Please consider upgrading.

Gems kaminari 0.15.1 ~> 0.15.1 0.16.3

kaminari version 0.15.1

Kaminari is a Scope & Engine based, clean, powerful, agnostic, customizable and sophisticated paginator for Rails 3+

This dependency is not matching latest version. Please consider upgrading.

Gems mousetrap-rails 1.4.6 >= 0 1.4.6

mousetrap-rails version 1.4.6

Mousetrap is a javascript library for handling keyboard shortcuts in your web applications. This gem integrates Mousetrap with Rails asset pipeline for easy of use.

This dependency is up-to-date. Congrats and keep going!

Gems newrelic_rpm 3.9.4.245 >= 0 3.11.2.286

newrelic_rpm version 3.9.4.245

New Relic is a performance management system, developed by New Relic, Inc (http://www.newrelic.com). New Relic provides you with deep information about the performance of your web application as it runs in production. The New Relic Ruby Agent is dual-purposed as a either a Gem or plugin, hosted on http://github.com/newrelic/rpm/

This dependency is not matching latest version. Please consider upgrading.

Gems nprogress-rails 0.1.2.3 >= 0 0.1.6.6

nprogress-rails version 0.1.2.3

This is a gem for the rstacruz' nprogress implementation. It's based on version nprogress 0.1.6.

This dependency is not matching latest version. Please consider upgrading.

Gems octokit 3.7.0 = 3.7.0 3.8.0

octokit version 3.7.0

Simple wrapper for the GitHub API

This dependency is not matching latest version. Please consider upgrading.

Gems omniauth 1.1.4 ~> 1.1.3 1.2.2

omniauth version 1.1.4

A generalized Rack framework for multiple-provider authentication.

This dependency is not matching latest version. Please consider upgrading.

Gems omniauth-bitbucket 0.0.2 >= 0 0.0.2

omniauth-bitbucket version 0.0.2

OmniAuth strategy for Bitbucket.

This dependency is up-to-date. Congrats and keep going!

Gems omniauth-github 1.1.1 >= 0 1.1.2

omniauth-github version 1.1.1

Official OmniAuth strategy for GitHub.

This dependency is not matching latest version. Please consider upgrading.

Gems omniauth-gitlab 1.0.0 >= 0 1.0.0

omniauth-gitlab version 1.0.0

This is the strategy for authenticating to your GitLab service

This dependency is up-to-date. Congrats and keep going!

Gems omniauth-google-oauth2 0.2.5 >= 0 0.2.6

omniauth-google-oauth2 version 0.2.5

A Google OAuth2 strategy for OmniAuth 1.x

This dependency is not matching latest version. Please consider upgrading.

Gems omniauth-kerberos 0.2.0 >= 0 0.2.0

omniauth-kerberos version 0.2.0

An OmniAuth strategy for Kerberos.

This dependency is up-to-date. Congrats and keep going!

Gems omniauth-shibboleth 1.1.1 >= 0 1.2.0

omniauth-shibboleth version 1.1.1

OmniAuth Shibboleth strategies for OmniAuth 1.x

This dependency is not matching latest version. Please consider upgrading.

Gems omniauth-twitter 1.0.1 >= 0 1.1.0

omniauth-twitter version 1.0.1

OmniAuth strategy for Twitter

This dependency is not matching latest version. Please consider upgrading.

Gems org-ruby 0.9.12 = 0.9.12 0.9.12

org-ruby version 0.9.12

An Org mode parser written in Ruby.

This dependency is up-to-date. Congrats and keep going!

Gems rack-attack 4.2.0 >= 0 4.2.0

rack-attack version 4.2.0

A rack middleware for throttling and blocking abusive requests

This dependency is up-to-date. Congrats and keep going!

Gems rack-cors 0.2.9 >= 0 0.4.0

rack-cors version 0.2.9

Middleware that will make Rack-based apps CORS compatible. Read more here: http://blog.sourcebender.com/2010/06/09/introducin-rack-cors.html. Fork the project here: https://github.com/cyu/rack-cors

This dependency is not matching latest version. Please consider upgrading.

Gems rack-oauth2 1.0.8 ~> 1.0.5 1.1.1

rack-oauth2 version 1.0.8

OAuth 2.0 Server & Client Library. Both Bearer and MAC token type are supported.

This dependency is not matching latest version. Please consider upgrading.

Gems rails 4.1.9 ~> 4.1.0 4.2.1

rails version 4.1.9

Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.

This dependency is not matching latest version. Please consider upgrading.

Gems rails_autolink 1.1.6 ~> 1.1 1.1.6

rails_autolink version 1.1.6

This is an extraction of the `auto_link` method from rails. The `auto_link` method was removed from Rails in version Rails 3.1. This gem is meant to bridge the gap for people migrating.

This dependency is up-to-date. Congrats and keep going!

Gems raphael-rails 2.1.2 ~> 2.1.2 2.1.2

raphael-rails version 2.1.2

Raphael JS as a Rubygem for use in the Rails asset pipeline

This dependency is up-to-date. Congrats and keep going!

Gems rdoc 3.12.2 ~> 3.6 4.2.0

rdoc version 3.12.2

RDoc produces HTML and command-line documentation for Ruby projects. RDoc includes the +rdoc+ and +ri+ tools for generating and displaying documentation from the command-line.

This dependency is not matching latest version. Please consider upgrading.

Gems redcarpet 3.2.3 ~> 3.2.3 3.2.3

redcarpet version 3.2.3

A fast, safe and extensible Markdown to (X)HTML parser

This dependency is up-to-date. Congrats and keep going!

Gems redis-rails 4.0.0 >= 0 4.0.0

redis-rails version 4.0.0

Redis for Ruby on Rails

This dependency is up-to-date. Congrats and keep going!

Gems request_store 1.0.5 >= 0 1.1.0

request_store version 1.0.5

RequestStore gives you per-request global storage.

This dependency is not matching latest version. Please consider upgrading.

Gems rugments 1.0.0.beta6 >= 0 1.0.0.beta6

rugments version 1.0.0.beta6

Rugments aims to a be a simple,easy-to-extend drop-in replacement for pygments.

This dependency is up-to-date. Congrats and keep going!

Gems sanitize 2.1.0 ~> 2.0 3.1.2

sanitize version 2.1.0

Sanitize is a whitelist-based HTML and CSS sanitizer. Given a list of acceptable elements, attributes, and CSS properties, Sanitize will remove all unacceptable HTML and/or CSS from a string.

This dependency is not matching latest version. Please consider upgrading.

Gems sass-rails 4.0.3 ~> 4.0.2 5.0.3

sass-rails version 4.0.3

Sass adapter for the Rails asset pipeline.

This dependency is not matching latest version. Please consider upgrading.

Gems seed-fu 2.3.1 >= 0 2.3.5

seed-fu version 2.3.1

Seed Fu is an attempt to once and for all solve the problem of inserting and maintaining seed data in a database. It uses a variety of techniques gathered from various places around the web and combines them to create what is hopefully the most robust seed data system around.

This dependency is not matching latest version. Please consider upgrading.

Gems select2-rails 3.5.2 >= 0 3.5.9.3

select2-rails version 3.5.2

Select2 is a jQuery based replacement for select boxes. It supports searching, remote data sets, and infinite scrolling of results. This gem integrates Select2 with Rails asset pipeline for easy of use.

This dependency is not matching latest version. Please consider upgrading.

Gems settingslogic 2.0.9 >= 0 2.0.9

settingslogic version 2.0.9

A simple and straightforward settings solution that uses an ERB enabled YAML file and a singleton design pattern.

This dependency is up-to-date. Congrats and keep going!

Gems sidekiq 3.3.0 ~> 3.3 3.3.3

sidekiq version 3.3.0

Simple, efficient background processing for Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems sidetiq 0.6.3 = 0.6.3 0.6.3

sidetiq version 0.6.3

Recurring jobs for Sidekiq

This dependency is up-to-date. Congrats and keep going!

Gems sinatra 1.4.4 >= 0 1.4.6

sinatra version 1.4.4

Sinatra is a DSL for quickly creating web applications in Ruby with minimal effort.

This dependency is not matching latest version. Please consider upgrading.

Gems six 0.2.0 >= 0 0.2.0

six version 0.2.0

Very simple authorization gem

This dependency is up-to-date. Congrats and keep going!

Gems slack-notifier 1.0.0 ~> 1.0.0 1.1.0

slack-notifier version 1.0.0

A slim ruby wrapper for posting to slack webhooks

This dependency is not matching latest version. Please consider upgrading.

Gems slim 2.0.2 >= 0 3.0.3

slim version 2.0.2

Slim is a template language whose goal is reduce the syntax to the essential parts without becoming cryptic.

This dependency is not matching latest version. Please consider upgrading.

Gems stamp 0.5.0 >= 0 0.6.0

stamp version 0.5.0

Format dates and times based on human-friendly examples, not arcane strftime directives.

This dependency is not matching latest version. Please consider upgrading.

Gems state_machine 1.2.0 >= 0 1.2.0

state_machine version 1.2.0

Adds support for creating state machines for attributes on any Ruby class

This dependency is up-to-date. Congrats and keep going!

Gems tinder 1.9.3 ~> 1.9.2 1.10.1

tinder version 1.9.3

A Ruby API for interfacing with Campfire, the 37Signals chat application.

This dependency is not matching latest version. Please consider upgrading.

Gems turbolinks 2.0.0 >= 0 2.5.3

turbolinks version 2.0.0

Turbolinks makes following links in your web application faster (use with Rails Asset Pipeline)

This dependency is not matching latest version. Please consider upgrading.

Gems uglifier 2.3.2 >= 0 2.7.1

uglifier version 2.3.2

Uglifier minifies JavaScript files by wrapping UglifyJS to be accessible in Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems underscore-rails 1.4.4 ~> 1.4.4 1.8.2

underscore-rails version 1.4.4

underscore.js asset pipeline provider/wrapper

This dependency is not matching latest version. Please consider upgrading.

Gems unf 0.1.4 >= 0 0.1.4

unf version 0.1.4

This is a wrapper library to bring Unicode Normalization Form support to Ruby/JRuby.

This dependency is up-to-date. Congrats and keep going!

Gems version_sorter 2.0.0 >= 0 2.0.0

version_sorter version 2.0.0

VersionSorter is a C extension that does fast sorting of large sets of version strings.

This dependency is up-to-date. Congrats and keep going!

Gems virtus 1.0.1 >= 0 1.0.5

virtus version 1.0.1

Attributes on Steroids for Plain Old Ruby Objects

This dependency is not matching latest version. Please consider upgrading.

Gems wikicloth 0.8.1 = 0.8.1 0.8.3

wikicloth version 0.8.1

mediawiki parser

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Gems annotate 2.6.0 ~> 2.6.0.beta2 2.6.8

annotate version 2.6.0

Annotates Rails/ActiveRecord Models, routes, fixtures, and others based on the database schema.

This dependency is not matching latest version. Please consider upgrading.

Gems awesome_print 1.2.0 >= 0 1.6.1

awesome_print version 1.2.0

Great Ruby dubugging companion: pretty print Ruby objects to visualize their structure. Supports custom object formatting via plugins

This dependency is not matching latest version. Please consider upgrading.

Gems better_errors 1.0.1 >= 0 2.1.1

better_errors version 1.0.1

Provides a better error page for Rails and other Rack apps. Includes source code inspection, a live REPL and local/instance variable inspection for all stack frames.

This dependency is not matching latest version. Please consider upgrading.

Gems binding_of_caller 0.7.2 >= 0 0.7.2

binding_of_caller version 0.7.2

Retrieve the binding of a method's caller. Can also retrieve bindings even further up the stack.

This dependency is up-to-date. Congrats and keep going!

Gems brakeman 3.0.1 >= 0 3.0.2

brakeman version 3.0.1

Brakeman detects security vulnerabilities in Ruby on Rails applications via static analysis.

This dependency is not matching latest version. Please consider upgrading.

Gems byebug 3.2.0 >= 0 4.0.5

byebug version 3.2.0

Byebug is a Ruby 2 debugger. It's implemented using the Ruby 2 TracePoint C API for execution control and the Debug Inspector C API for call stack navigation. The core component provides support that front-ends can build on. It provides breakpoint handling and bindings for stack frames among other things and it comes with an easy to use command line interface.

This dependency is not matching latest version. Please consider upgrading.

Gems capybara 2.2.1 ~> 2.2.1 2.4.4

capybara version 2.2.1

Capybara is an integration testing tool for rack based web applications. It simulates how a user would interact with a website

This dependency is not matching latest version. Please consider upgrading.

Gems coveralls 0.7.0 >= 0 0.8.0

coveralls version 0.7.0

A Ruby implementation of the Coveralls API.

This dependency is not matching latest version. Please consider upgrading.

Gems database_cleaner 1.3.0 >= 0 1.4.1

database_cleaner version 1.3.0

Strategies for cleaning databases. Can be used to ensure a clean state for testing.

This dependency is not matching latest version. Please consider upgrading.

Gems email_spec 1.5.0 >= 0 1.6.0

email_spec version 1.5.0

Easily test email in RSpec, Cucumber, and MiniTest

This dependency is not matching latest version. Please consider upgrading.

Gems factory_girl_rails 4.3.0 >= 0 4.5.0

factory_girl_rails version 4.3.0

factory_girl_rails provides integration between factory_girl and rails 3 (currently just automatic factory definition loading)

This dependency is not matching latest version. Please consider upgrading.

Gems ffaker 1.22.1 >= 0 2.0.0

ffaker version 1.22.1

Faster Faker, generates dummy data.

This dependency is not matching latest version. Please consider upgrading.

Gems guard-rspec 4.2.0 >= 0 4.5.0

guard-rspec version 4.2.0

Guard::RSpec automatically run your specs (much like autotest).

This dependency is not matching latest version. Please consider upgrading.

Gems guard-spinach 0.0.2 >= 0 0.2.0

guard-spinach version 0.0.2

guard-spinach is a guard plugin for spinach

This dependency is not matching latest version. Please consider upgrading.

Gems jasmine 2.0.2 = 2.0.2 2.2.0

jasmine version 2.0.2

Test your JavaScript without any framework dependencies, in any environment, and with a nice descriptive syntax.

This dependency is not matching latest version. Please consider upgrading.

Gems launchy 2.4.2 >= 0 2.4.3

launchy version 2.4.2

Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.

This dependency is not matching latest version. Please consider upgrading.

Gems letter_opener 1.1.2 >= 0 1.3.0

letter_opener version 1.1.2

When mail is sent from your application, Letter Opener will open a preview in the browser instead of sending.

This dependency is not matching latest version. Please consider upgrading.

Gems minitest 5.3.5 ~> 5.3.0 5.6.0

minitest version 5.3.5

minitest provides a complete suite of testing facilities supporting TDD, BDD, mocking, and benchmarking. "I had a class with Jim Weirich on testing last week and we were allowed to choose our testing frameworks. Kirk Haines and I were paired up and we cracked open the code for a few test frameworks... I MUST say that minitest is *very* readable / understandable compared to the 'other two' options we looked at. Nicely done and thank you for helping us keep our mental sanity." -- Wayne E. Seguin minitest/unit is a small and incredibly fast unit testing framework. It provides a rich set of assertions to make your tests clean and readable. minitest/spec is a functionally complete spec engine. It hooks onto minitest/unit and seamlessly bridges test assertions over to spec expectations. minitest/benchmark is an awesome way to assert the performance of your algorithms in a repeatable manner. Now you can assert that your newb co-worker doesn't replace your linear algorithm with an exponential one! minitest/mock by Steven Baker, is a beautifully tiny mock (and stub) object framework. minitest/pride shows pride in testing and adds coloring to your test output. I guess it is an example of how to write IO pipes too. :P minitest/unit is meant to have a clean implementation for language implementors that need a minimal set of methods to bootstrap a working test suite. For example, there is no magic involved for test-case discovery. "Again, I can't praise enough the idea of a testing/specing framework that I can actually read in full in one sitting!" -- Piotr Szotkowski Comparing to rspec: rspec is a testing DSL. minitest is ruby. -- Adam Hawkins, "Bow Before MiniTest" minitest doesn't reinvent anything that ruby already provides, like: classes, modules, inheritance, methods. This means you only have to learn ruby to use minitest and all of your regular OO practices like extract-method refactorings still apply.

This dependency is not matching latest version. Please consider upgrading.

Gems mysql2 0.3.16 >= 0 0.3.18

mysql2 version 0.3.16

A simple, fast Mysql library for Ruby, binding to libmysql

This dependency is not matching latest version. Please consider upgrading.

Gems pg 0.15.1 >= 0 0.18.1

pg version 0.15.1

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 8.4 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

This dependency is not matching latest version. Please consider upgrading.

Gems poltergeist 1.5.1 ~> 1.5.1 1.6.0

poltergeist version 1.5.1

Poltergeist is a driver for Capybara that allows you to run your tests on a headless WebKit browser, provided by PhantomJS.

This dependency is not matching latest version. Please consider upgrading.

Gems pry-rails 0.3.2 >= 0 0.3.4

pry-rails version 0.3.2

Use Pry as your rails console

This dependency is not matching latest version. Please consider upgrading.

Gems quiet_assets 1.0.2 ~> 1.0.1 1.1.0

quiet_assets version 1.0.2

Quiet Assets turns off Rails asset pipeline log.

This dependency is not matching latest version. Please consider upgrading.

Gems rack-mini-profiler 0.9.0 >= 0 0.9.3

rack-mini-profiler version 0.9.0

Profiling toolkit for Rack applications with Rails integration. Client Side profiling, DB profiling and Server profiling.

This dependency is not matching latest version. Please consider upgrading.

Gems rb-fsevent 0.9.3 >= 0 0.9.4

rb-fsevent version 0.9.3

FSEvents API with Signals catching (without RubyCocoa)

This dependency is not matching latest version. Please consider upgrading.

Gems rb-inotify 0.9.2 >= 0 0.9.5

rb-inotify version 0.9.2

A Ruby wrapper for Linux's inotify, using FFI

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-rails 2.99.0 = 2.99 3.2.1

rspec-rails version 2.99.0

RSpec for Rails

This dependency is not matching latest version. Please consider upgrading.

Gems rubocop 0.28.0 = 0.28.0 0.30.0

rubocop version 0.28.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

This dependency is not matching latest version. Please consider upgrading.

Gems sdoc 0.3.20 >= 0 0.4.1

sdoc version 0.3.20

rdoc generator html with javascript search index.

This dependency is not matching latest version. Please consider upgrading.

Gems shoulda-matchers 2.7.0 ~> 2.7.0 2.8.0

shoulda-matchers version 2.7.0

Making tests easy on the fingers and eyes

This dependency is not matching latest version. Please consider upgrading.

Gems simplecov 0.9.0 >= 0 0.10.0

simplecov version 0.9.0

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is not matching latest version. Please consider upgrading.

Gems spinach-rails 0.2.1 >= 0 0.2.1

spinach-rails version 0.2.1

spinach-rails adds Rails support to spinach

This dependency is up-to-date. Congrats and keep going!

Gems spring 1.3.3 ~> 1.3.1 1.3.4

spring version 1.3.3

Rails application preloader

This dependency is not matching latest version. Please consider upgrading.

Gems spring-commands-rspec 1.0.4 = 1.0.4 1.0.4

spring-commands-rspec version 1.0.4

rspec command for spring

This dependency is up-to-date. Congrats and keep going!

Gems spring-commands-spinach 1.0.0 = 1.0.0 1.0.0

spring-commands-spinach version 1.0.0

spinach command for spring

This dependency is up-to-date. Congrats and keep going!

Gems test_after_commit 0.2.2 >= 0 0.4.1

test_after_commit version 0.2.2

makes after_commit callbacks testable in Rails 3+ with transactional_fixtures

This dependency is not matching latest version. Please consider upgrading.

Gems thin 1.6.1 >= 0 1.6.3

thin version 1.6.1

A thin and fast web server

This dependency is not matching latest version. Please consider upgrading.

Gems unicorn 4.6.3 ~> 4.6.3 4.8.3

unicorn version 4.6.3

\Unicorn is an HTTP server for Rack applications designed to only serve fast clients on low-latency, high-bandwidth connections and take advantage of features in Unix/Unix-like kernels. Slow clients should only be served by placing a reverse proxy capable of fully buffering both the the request and response in between \Unicorn and slow clients.

This dependency is not matching latest version. Please consider upgrading.

Gems unicorn-worker-killer 0.4.2 >= 0 0.4.3

unicorn-worker-killer version 0.4.2

Kill unicorn workers by memory and request counts

This dependency is not matching latest version. Please consider upgrading.

Gems webmock 1.16.0 >= 0 1.21.0

webmock version 1.16.0

WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.

This dependency is not matching latest version. Please consider upgrading.