C747ffcd593aa4da922e8a7c4019d95b?s=64 gollum

gollum

8 3 0

A simple, Git-powered wiki with a sweet API and local frontend.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems github-markdown ~> 0.6.5 0.6.5

github-markdown

Self-contained Markdown parser for GitHub, with all our custom extensions

This dependency is up-to-date. Congrats and keep going!

Gems gollum-lib ~> 3.0 3.0.0

gollum-lib

A simple, Git-powered wiki with a sweet API and local frontend.

This dependency is up-to-date. Congrats and keep going!

Gems mustache < 1.0.0, >= 0.99.5 0.99.5

mustache

Inspired by ctemplate, Mustache is a framework-agnostic way to render logic-free views. As ctemplates says, "It emphasizes separating logic from presentation: it is impossible to embed application logic in this template language. Think of Mustache as a replacement for your views. Instead of views consisting of ERB or HAML with random helpers and arbitrary logic, your views are broken into two parts: a Ruby class and an HTML template.

This dependency is up-to-date. Congrats and keep going!

Gems sinatra >= 1.4.4, ~> 1.4 1.4.5

sinatra

Sinatra is a DSL for quickly creating web applications in Ruby with minimal effort.

This dependency is up-to-date. Congrats and keep going!

Gems useragent ~> 0.10.0 0.10.0

useragent

HTTP User Agent parser

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems minitest-reporters ~> 0.14.16 1.0.3

minitest-reporters

Death to haphazard monkey-patching! Extend Minitest through simple hooks.

This dependency is not matching latest version. Please consider upgrading.

Gems mocha ~> 1.0.0 1.0.0

mocha

Mocking and stubbing library with JMock/SchMock syntax, which allows mocking and stubbing of methods on real (non-mock) classes.

This dependency is up-to-date. Congrats and keep going!

Gems rack-test ~> 0.6.2 0.6.2

rack-test

Rack::Test is a small, simple testing API for Rack apps. It can be used on its own or as a reusable starting point for Web frameworks and testing libraries to build on. Most of its initial functionality is an extraction of Merb 1.0's request helpers feature.

This dependency is up-to-date. Congrats and keep going!

Gems rake ~> 10.2.2 10.3.1

rake

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * A library of prepackaged tasks to make building rakefiles easier. For example, tasks for building tarballs and publishing to FTP or SSH sites. (Formerly tasks for building RDoc and Gems were included in rake but they're now available in RDoc and RubyGems respectively.) * Supports parallel execution of tasks.

This dependency is not matching latest version. Please consider upgrading.

Gems shoulda ~> 3.5.0 3.5.0

shoulda

Making tests easy on the fingers and eyes

This dependency is up-to-date. Congrats and keep going!

Gems twitter_cldr ~> 2.4.2 3.0.1

twitter_cldr

Ruby implementation of the ICU (International Components for Unicode) that uses the Common Locale Data Repository to format dates, plurals, and more.

This dependency is not matching latest version. Please consider upgrading.