Ea7edc32b93708197fa49de746d18a3e?s=64 gotwarlost

istanbul

13 4 0

Yet another JS code coverage tool that computes statement, line, function and branch coverage with module loader hooks to transparently add coverage when running tests. Supports all JS coverage use cases including unit tests, server side functional tests and browser tests. Built for scale.

Dependencies

Package Locked Requirement Latest Status Changelog
Npms abbrev 1.0.x 1.0.4

abbrev

Like ruby's abbrev module, but in js

This dependency is up-to-date. Congrats and keep going!

Npms async 0.2.x 0.7.0

async

Higher-order functions and common patterns for asynchronous code

This dependency is not matching latest version. Please consider upgrading.

Npms escodegen 1.3.x 1.3.1

escodegen

ECMAScript code generator

This dependency is up-to-date. Congrats and keep going!

Npms esprima 1.0.x 1.1.1

esprima

ECMAScript parsing infrastructure for multipurpose analysis

This dependency is not matching latest version. Please consider upgrading.

Npms fileset 0.1.x 0.1.5

fileset

Wrapper around miniglob / minimatch combo to allow multiple patterns matching and include-exclude ability

This dependency is up-to-date. Congrats and keep going!

Npms handlebars 1.3.x 2.0.0-alpha.2

handlebars

Handlebars provides the power necessary to let you build semantic templates effectively with no frustration

This dependency is not matching latest version. Please consider upgrading.

Npms js-yaml 3.x 3.0.2

js-yaml

YAML 1.2 parser and serializer

This dependency is up-to-date. Congrats and keep going!

Npms mkdirp 0.3.x 0.3.5

mkdirp

Recursively mkdir, like `mkdir -p`

This dependency is up-to-date. Congrats and keep going!

Npms nopt 2.2.x 2.2.0

nopt

Option parsing for Node, supporting types, shorthands, etc. Used by npm.

This dependency is up-to-date. Congrats and keep going!

Npms resolve 0.6.x 0.6.2

resolve

resolve like require.resolve() on behalf of files asynchronously and synchronously

This dependency is up-to-date. Congrats and keep going!

Npms which 1.0.x 1.0.5

which

Like which(1) unix command. Find the first instance of an executable in the PATH.

This dependency is up-to-date. Congrats and keep going!

Npms wordwrap 0.0.x 0.0.2

wordwrap

Wrap those words. Show them at what columns to start and stop.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Npms jshint 2.4.x 2.5.0

jshint

Static analysis tool for JavaScript

This dependency is not matching latest version. Please consider upgrading.

Npms nodeunit 0.8.x 0.8.6

nodeunit

Easy unit testing for node.js and the browser.

This dependency is up-to-date. Congrats and keep going!

Npms requirejs 2.x 2.1.11

requirejs

Node adapter for RequireJS, for loading AMD modules. Includes RequireJS optimizer

This dependency is up-to-date. Congrats and keep going!

Npms rimraf 2.2.x 2.2.6

rimraf

A deep deletion module for node (like `rm -rf`)

This dependency is up-to-date. Congrats and keep going!

Npms yui-lint 0.1.x 0.1.4

yui-lint

Default JSHint rules used by YUI in its various packages

This dependency is up-to-date. Congrats and keep going!