auditable

11 0 0

A simple(r) auditing / version tracking library for Rails (ActiveRecord). Developed and tested for Rails 3.2 onwards. Should work with earlier Rails 3 versions but no guarantee. Should be easy to tweak it though.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems activerecord >= 3.0 5.0.0.1

activerecord

Databases on Rails. Build a persistent domain model by mapping database tables to Ruby classes. Strong conventions for associations, validations, aggregations, migrations, and testing come baked-in.

This dependency is up-to-date. Congrats and keep going!

Gems activesupport >= 3.0 5.0.0.1

activesupport

A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems activerecord-jdbcsqlite3-adapter >= 0 1.3.21

activerecord-jdbcsqlite3-adapter

Sqlite3 JDBC adapter for JRuby on Rails.

This dependency is up-to-date. Congrats and keep going!

Gems debugger >= 0 1.6.8

debugger

debugger is a fast implementation of the standard Ruby debugger debug.rb. It is implemented by utilizing a new Ruby C API hook. The core component provides support that front-ends can build on. It provides breakpoint handling, bindings for stack frames among other things.

This dependency is up-to-date. Congrats and keep going!

Gems kramdown >= 0 1.13.1

kramdown

kramdown is yet-another-markdown-parser but fast, pure Ruby, using a strict syntax definition and supporting several common extensions.

This dependency is up-to-date. Congrats and keep going!

Gems rake >= 0 12.0.0

rake

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * Supports parallel execution of tasks.

This dependency is up-to-date. Congrats and keep going!

Gems rspec >= 2 3.5.0

rspec

BDD for Ruby

This dependency is up-to-date. Congrats and keep going!

Gems sqlite3 >= 0 1.3.12

sqlite3

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is up-to-date. Congrats and keep going!

Gems timecop >= 0 0.8.1

timecop

A gem providing "time travel" and "time freezing" capabilities, making it dead simple to test time-dependent code. It provides a unified method to mock Time.now, Date.today, and DateTime.now in a single call.

This dependency is up-to-date. Congrats and keep going!

Gems watchr >= 0 0.7

watchr

Modern continious testing (flexible alternative to autotest).

This dependency is up-to-date. Congrats and keep going!

Gems yard >= 0 0.9.5

yard

YARD is a documentation generation tool for the Ruby programming language. It enables the user to generate consistent, usable documentation that can be exported to a number of formats very easily, and also supports extending for custom Ruby constructs such as custom class level definitions.

This dependency is up-to-date. Congrats and keep going!