heartsentwined heartsentwined

ember-auth-rails-demo

2 21 2

rails + devise + ember-auth demo site

You have 15 open security alerts

Dependencies

Package Locked Requirement Latest Status Changelog
Gems active_model_serializers 0.7.0 >= 0 0.9.3

active_model_serializers version 0.7.0

Making it easy to serialize models for client-side use

This dependency is not matching latest version. Please consider upgrading.

Gems bcrypt-ruby 3.0.1 >= 0 3.1.5

bcrypt-ruby version 3.0.1

bcrypt() is a sophisticated and secure hash algorithm designed by The OpenBSD project for hashing passwords. The bcrypt Ruby gem provides a simple wrapper for safely handling passwords.

This dependency is not matching latest version. Please consider upgrading.

Gems devise 2.2.3 >= 0 3.5.1

devise version 2.2.3

Flexible authentication solution for Rails with Warden

Security alert:

Gems ember-auth-rails 4.0.1 >= 0 5.0.1

ember-auth-rails version 4.0.1

Ember-auth is an authentication framework for ember.js. It is expected to work out of the box with rails + devise.

This dependency is not matching latest version. Please consider upgrading.

Gems ember-rails 0.11.1 >= 0 0.18.2

ember-rails version 0.11.1

Ember for Rails 3.1+

This dependency is not matching latest version. Please consider upgrading.

Gems emblem-rails 0.0.7 >= 0 0.2.2

emblem-rails version 0.0.7

Use emblem.js with ember-rails - see https://github.com/machty/emblem.js

This dependency is not matching latest version. Please consider upgrading.

Gems inherited_resources 1.4.0 >= 0 1.6.0

inherited_resources version 1.4.0

Inherited Resources speeds up development by making your controllers inherit all restful actions so you just have to focus on what is important.

This dependency is not matching latest version. Please consider upgrading.

Gems newrelic_rpm 3.6.0.83 >= 0 3.12.0.288

newrelic_rpm version 3.6.0.83

New Relic is a performance management system, developed by New Relic, Inc (http://www.newrelic.com). New Relic provides you with deep information about the performance of your web application as it runs in production. The New Relic Ruby Agent is dual-purposed as a either a Gem or plugin, hosted on http://github.com/newrelic/rpm/

This dependency is not matching latest version. Please consider upgrading.

Gems pg 0.15.1 ~> 0.14 0.18.2

pg version 0.15.1

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 8.4 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

This dependency is not matching latest version. Please consider upgrading.

Gems rails 3.2.13 ~> 3.2 4.2.1

rails version 3.2.13

Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.

Gems unicorn 4.6.2 >= 0 4.9.0

unicorn version 4.6.2

\Unicorn is an HTTP server for Rack applications designed to only serve fast clients on low-latency, high-bandwidth connections and take advantage of features in Unix/Unix-like kernels. Slow clients should only be served by placing a reverse proxy capable of fully buffering both the the request and response in between \Unicorn and slow clients.

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Gems coffee-rails 3.2.2 ~> 3.2 4.1.0

coffee-rails version 3.2.2

CoffeeScript adapter for the Rails asset pipeline.

This dependency is not matching latest version. Please consider upgrading.

Gems database_cleaner 0.9.1 >= 0 1.4.1

database_cleaner version 0.9.1

Strategies for cleaning databases. Can be used to ensure a clean state for testing.

This dependency is not matching latest version. Please consider upgrading.

Gems fabrication 2.6.5 >= 0 2.13.2

fabrication version 2.6.5

Fabrication is an object generation framework for ActiveRecord, Mongoid, DataMapper, Sequel, or any other Ruby object.

This dependency is not matching latest version. Please consider upgrading.

Gems guard-rspec 2.5.4 >= 0 4.5.1

guard-rspec version 2.5.4

Guard::RSpec automatically run your specs (much like autotest).

This dependency is not matching latest version. Please consider upgrading.

Gems guard-spork 1.5.0 >= 0 2.1.0

guard-spork version 1.5.0

Guard::Spork automatically manage Spork DRb servers.

This dependency is not matching latest version. Please consider upgrading.

Gems jquery-rails 2.2.1 ~> 2.2 4.0.3

jquery-rails version 2.2.1

This gem provides jQuery and the jQuery-ujs driver for your Rails 4+ application.

This dependency is not matching latest version. Please consider upgrading.

Gems rb-fchange 0.0.6 >= 0 0.0.6

rb-fchange version 0.0.6

A Ruby wrapper for Windows Kernel functions for monitoring the specified directory or subtree

This dependency is up-to-date. Congrats and keep going!

Gems rb-fsevent 0.9.3 >= 0 0.9.5

rb-fsevent version 0.9.3

FSEvents API with Signals catching (without RubyCocoa)

This dependency is not matching latest version. Please consider upgrading.

Gems rb-inotify 0.9.0 >= 0 0.9.5

rb-inotify version 0.9.0

A Ruby wrapper for Linux's inotify, using FFI

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-rails 2.13.0 >= 0 3.2.1

rspec-rails version 2.13.0

RSpec for Rails

This dependency is not matching latest version. Please consider upgrading.

Gems sass-rails 3.2.6 ~> 3.2 5.0.3

sass-rails version 3.2.6

Sass adapter for the Rails asset pipeline.

This dependency is not matching latest version. Please consider upgrading.

Gems shoulda 3.4.0 >= 0 3.5.0

shoulda version 3.4.0

Making tests easy on the fingers and eyes

This dependency is not matching latest version. Please consider upgrading.

Gems spork 0.9.2 >= 0 0.9.2

spork version 0.9.2

A forking Drb spec server

This dependency is up-to-date. Congrats and keep going!

Gems uglifier 1.3.0 ~> 1.3 2.7.1

uglifier version 1.3.0

Uglifier minifies JavaScript files by wrapping UglifyJS to be accessible in Ruby

This dependency is not matching latest version. Please consider upgrading.