huerlisi huerlisi

wikisigns

6 28 7

WikiSigns infinite monkey machine

You have 33 open security alerts

Reports Beta

Some reports are compatible with your project but none of them has been enabled.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems airbrake 3.0.9 >= 0 4.3.0

airbrake version 3.0.9

Send your application errors to our hosted service and reclaim your inbox.

This dependency is not matching latest version. Please consider upgrading.

Gems compass-rails 1.0.1 >= 0 2.0.4

compass-rails version 1.0.1

Integrate Compass into Rails 3.0 and up.

This dependency is not matching latest version. Please consider upgrading.

Gems devise 1.5.3 >= 0 3.5.1

devise version 1.5.3

Flexible authentication solution for Rails with Warden

Gems fancy-buttons 1.2.0 >= 0 1.2.0

fancy-buttons version 1.2.0

Fancy Buttons helps you easily style buttons with beautiful CSS3 features like gradients, rounded corners, etc. Don't worry the buttons also degrade nicely for browsers with no support. This requires the Compass stylesheet authoring framework.

This dependency is up-to-date. Congrats and keep going!

Gems formtastic 2.2.0 >= 0 3.1.3

formtastic version 2.2.0

A Rails form builder plugin/gem with semantically rich and accessible markup

This dependency is not matching latest version. Please consider upgrading.

Gems haml 3.1.4 >= 0 4.0.6

haml version 3.1.4

Haml (HTML Abstraction Markup Language) is a layer on top of HTML or XML that's designed to express the structure of documents in a non-repetitive, elegant, and easy way by using indentation rather than closing tags and allowing Ruby to be embedded with ease. It was originally envisioned as a plugin for Ruby on Rails, but it can function as a stand-alone templating engine.

This dependency is not matching latest version. Please consider upgrading.

Gems haml-rails 0.3.4 >= 0 0.9.0

haml-rails version 0.3.4

Haml-rails provides Haml generators for Rails 4. It also enables Haml as the templating engine for you, so you don't have to screw around in your own application.rb when your Gemfile already clearly indicated what templating engine you have installed. Hurrah.

This dependency is not matching latest version. Please consider upgrading.

Gems has_scope 0.5.1 >= 0 0.6.0

has_scope version 0.5.1

Maps controller filters to your resource scopes

This dependency is not matching latest version. Please consider upgrading.

Gems i18n_rails_helpers 1.0.3 >= 0 2.0.0

i18n_rails_helpers version 1.0.3

Rails i18n view helpers for things like crud actions, models and and attributes.

This dependency is not matching latest version. Please consider upgrading.

Gems imgkit 1.3.6 >= 0 1.6.1

imgkit version 1.3.6

Uses wkhtmltoimage to create Images using HTML

This dependency is not matching latest version. Please consider upgrading.

Gems inherited_resources 1.2.2 = 1.2.2 1.6.0

inherited_resources version 1.2.2

Inherited Resources speeds up development by making your controllers inherit all restful actions so you just have to focus on what is important.

This dependency is not matching latest version. Please consider upgrading.

Gems jquery-rails 1.0.19 >= 0 4.0.4

jquery-rails version 1.0.19

This gem provides jQuery and the jQuery-ujs driver for your Rails 4+ application.

Security alert:

Gems koala 1.1.0 >= 0 2.0.0

koala version 1.1.0

Koala is a lightweight, flexible Ruby SDK for Facebook. It allows read/write access to the social graph via the Graph and REST APIs, as well as support for realtime updates and OAuth and Facebook Connect authentication. Koala is fully tested and supports Net::HTTP and Typhoeus connections out of the box and can accept custom modules for other services.

This dependency is not matching latest version. Please consider upgrading.

Gems lyb_sidebar 0.1.0 >= 0 0.1.1

lyb_sidebar version 0.1.0

LybSidebar simplifies common sidebar code.

This dependency is not matching latest version. Please consider upgrading.

Gems mysql2 0.2.24 ~> 0.2.7 0.3.18

mysql2 version 0.2.24

A simple, fast Mysql library for Ruby, binding to libmysql

This dependency is not matching latest version. Please consider upgrading.

Gems newrelic_rpm 3.3.4.1 >= 0 3.12.1.298

newrelic_rpm version 3.3.4.1

New Relic is a performance management system, developed by New Relic, Inc (http://www.newrelic.com). New Relic provides you with deep information about the performance of your web application as it runs in production. The New Relic Ruby Agent is dual-purposed as a either a Gem or plugin, hosted on http://github.com/newrelic/rpm/

Security alert:

Gems omniauth 1.1.0 >= 0 1.2.2

omniauth version 1.1.0

A generalized Rack framework for multiple-provider authentication.

This dependency is not matching latest version. Please consider upgrading.

Gems omniauth-facebook 1.2.0 >= 0 2.0.1

omniauth-facebook version 1.2.0

Facebook OAuth2 Strategy for OmniAuth

Security alert:

Gems omniauth-twitter 0.0.11 >= 0 1.2.0

omniauth-twitter version 0.0.11

OmniAuth strategy for Twitter

This dependency is not matching latest version. Please consider upgrading.

Gems rack 1.2.1 = 1.2.1 1.6.4

rack version 1.2.1

Rack provides a minimal, modular and adaptable interface for developing web applications in Ruby. By wrapping HTTP requests and responses in the simplest way possible, it unifies and distills the API for web servers, web frameworks, and software in between (the so-called middleware) into a single method call. Also see http://rack.github.io/.

Gems rack-google_analytics 1.0.2 >= 0 1.0.2

rack-google_analytics version 1.0.2

Embeds Google Analytics tracking code in the bottom of HTML documents

This dependency is up-to-date. Congrats and keep going!

Gems rails 3.0.11 ~> 3.0.0 4.2.3

rails version 3.0.11

Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.

Gems routing-filter 0.3.0 >= 0 0.5.0

routing-filter version 0.3.0

Routing filters wraps around the complex beast that the Rails routing system is, allowing for unseen flexibility and power in Rails URL recognition and generation.

This dependency is not matching latest version. Please consider upgrading.

Gems rqrcode 0.4.2 >= 0 0.6.0

rqrcode version 0.4.2

rQRCode is a library for encoding QR Codes. The simple interface allows you to create QR Code data structures ready to be displayed in the way you choose.

This dependency is not matching latest version. Please consider upgrading.

Gems settingslogic 2.0.8 >= 0 2.0.9

settingslogic version 2.0.8

A simple and straightforward settings solution that uses an ERB enabled YAML file and a singleton design pattern.

This dependency is not matching latest version. Please consider upgrading.

Gems simple-navigation 3.7.0 >= 0 4.0.3

simple-navigation version 3.7.0

With the simple-navigation gem installed you can easily create multilevel navigations for your Rails, Sinatra or Padrino applications. The navigation is defined in a single configuration file. It supports automatic as well as explicit highlighting of the currently active navigation through regular expressions.

This dependency is not matching latest version. Please consider upgrading.

Gems simple_form 2.0.2 >= 0 3.1.0

simple_form version 2.0.2

Forms made easy!

This dependency is not matching latest version. Please consider upgrading.

Gems unicorn 4.9.0 >= 0 4.9.0

unicorn version 4.9.0

\Unicorn is an HTTP server for Rack applications designed to only serve fast clients on low-latency, high-bandwidth connections and take advantage of features in Unix/Unix-like kernels. Slow clients should only be served by placing a reverse proxy capable of fully buffering both the the request and response in between \Unicorn and slow clients.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems ZenTest 4.5.0 < 4.6.0 4.11.0

ZenTest version 4.5.0

ZenTest provides 4 different tools: zentest, unit_diff, autotest, and multiruby. zentest scans your target and unit-test code and writes your missing code based on simple naming rules, enabling XP at a much quicker pace. zentest only works with Ruby and Minitest or Test::Unit. There is enough evidence to show that this is still proving useful to users, so it stays. unit_diff is a command-line filter to diff expected results from actual results and allow you to quickly see exactly what is wrong. Do note that minitest 2.2+ provides an enhanced assert_equal obviating the need for unit_diff autotest is a continous testing facility meant to be used during development. As soon as you save a file, autotest will run the corresponding dependent tests. multiruby runs anything you want on multiple versions of ruby. Great for compatibility checking! Use multiruby_setup to manage your installed versions.

This dependency is not matching latest version. Please consider upgrading.

Gems autotest 4.4.6 >= 0 4.4.6

autotest version 4.4.6

This is a stub gem to fix the confusion caused by autotest being part of the ZenTest suite.

This dependency is up-to-date. Congrats and keep going!

Gems autotest-rails 4.1.2 >= 0 4.2.1

autotest-rails version 4.1.2

This is an autotest plugin to provide rails support. It provides basic rails support and extra plugins for migrations and fixtures.

This dependency is not matching latest version. Please consider upgrading.

Gems capones_recipes 1.20.1 >= 0 1.20.1

capones_recipes version 1.20.1

A collection of usefull capistrano recipes used by CyT GmbH and others.

This dependency is up-to-date. Congrats and keep going!

Gems capybara 1.1.2 >= 0 2.4.4

capybara version 1.1.2

Capybara is an integration testing tool for rack based web applications. It simulates how a user would interact with a website

This dependency is not matching latest version. Please consider upgrading.

Gems factory_girl 2.0.5 ~> 2.0.0.rc1 4.5.0

factory_girl version 2.0.5

factory_girl provides a framework and DSL for defining and using factories - less error-prone, more explicit, and all-around easier to work with than fixtures.

This dependency is not matching latest version. Please consider upgrading.

Gems factory_girl_rails 1.1.0 ~> 1.1.rc1 4.5.0

factory_girl_rails version 1.1.0

factory_girl_rails provides integration between factory_girl and rails 3 (currently just automatic factory definition loading)

This dependency is not matching latest version. Please consider upgrading.

Gems hpricot 0.8.6 >= 0 0.8.6

hpricot version 0.8.6

a swift, liberal HTML parser with a fantastic library

This dependency is up-to-date. Congrats and keep going!

Gems rails3-generators 0.17.4 >= 0 1.0.0

rails3-generators version 0.17.4

Rails 3 compatible generators for gems that don't have them yet

This dependency is not matching latest version. Please consider upgrading.

Gems rspec 2.10.0 >= 0 3.3.0

rspec version 2.10.0

BDD for Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems rspec-rails 2.10.0 >= 0 3.3.2

rspec-rails version 2.10.0

rspec-rails is a testing framework for Rails 3.x and 4.x.

This dependency is not matching latest version. Please consider upgrading.

Gems ruby_parser 2.3.1 >= 0 3.7.0

ruby_parser version 2.3.1

ruby_parser (RP) is a ruby parser written in pure ruby (utilizing racc--which does by default use a C extension). RP's output is the same as ParseTree's output: s-expressions using ruby's arrays and base types. As an example: def conditional1 arg1 return 1 if arg1 == 0 return 0 end becomes: s(:defn, :conditional1, s(:args, :arg1), s(:if, s(:call, s(:lvar, :arg1), :==, s(:lit, 0)), s(:return, s(:lit, 1)), nil), s(:return, s(:lit, 0))) Tested against 801,039 files from the latest of all rubygems (as of 2013-05): * 1.8 parser is at 99.9739% accuracy, 3.651 sigma * 1.9 parser is at 99.9940% accuracy, 4.013 sigma * 2.0 parser is at 99.9939% accuracy, 4.008 sigma

Security alert:

Gems shoulda 3.0.1 >= 0 3.5.0

shoulda version 3.0.1

Making tests easy on the fingers and eyes

This dependency is not matching latest version. Please consider upgrading.