intridea intridea

omniauth-ldap

13 1 0

LDAP strategy for OmniAuth

Dependencies

Package Locked Requirement Latest Status Changelog
Gems net-ldap ~> 0.3 0.11

net-ldap

Net::LDAP for Ruby (also called net-ldap) implements client access for the Lightweight Directory Access Protocol (LDAP), an IETF standard protocol for accessing distributed directory services. Net::LDAP is written completely in Ruby with no external dependencies. It supports most LDAP client features and a subset of server features as well. Net::LDAP has been tested against modern popular LDAP servers including OpenLDAP and Active Directory. The current release is mostly compliant with earlier versions of the IETF LDAP RFCs (2251-2256, 2829-2830, 3377, and 3771). Our roadmap for Net::LDAP 1.0 is to gain full <em>client</em> compliance with the most recent LDAP RFCs (4510-4519, plutions of 4520-4532).

This dependency is up-to-date. Congrats and keep going!

Gems omniauth ~> 1.0 1.2.2

omniauth

A generalized Rack framework for multiple-provider authentication.

This dependency is up-to-date. Congrats and keep going!

Gems pyu-ruby-sasl ~> 0.0.3.1 0.0.3.3

pyu-ruby-sasl

Simple Authentication and Security Layer (RFC 4422)

This dependency is up-to-date. Congrats and keep going!

Gems rubyntlm ~> 0.3 0.5.2

rubyntlm

Ruby/NTLM provides message creator and parser for the NTLM authentication.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems growl >= 0 1.0.3

growl

growlnotify bindings

This dependency is up-to-date. Congrats and keep going!

Gems guard >= 0 2.13.0

guard

Guard is a command line tool to easily handle events on file system modifications.

This dependency is up-to-date. Congrats and keep going!

Gems guard-bundler >= 0 2.1.0

guard-bundler

Guard::Bundler automatically install/update your gem bundle when needed

This dependency is up-to-date. Congrats and keep going!

Gems guard-rspec >= 0 4.6.4

guard-rspec

Guard::RSpec automatically run your specs (much like autotest).

This dependency is up-to-date. Congrats and keep going!

Gems libnotify >= 0 0.9.1

libnotify

Ruby bindings for libnotify using FFI

This dependency is up-to-date. Congrats and keep going!

Gems rack-test >= 0 0.6.3

rack-test

Rack::Test is a small, simple testing API for Rack apps. It can be used on its own or as a reusable starting point for Web frameworks and testing libraries to build on. Most of its initial functionality is an extraction of Merb 1.0's request helpers feature.

This dependency is up-to-date. Congrats and keep going!

Gems rb-fsevent >= 0 0.9.5

rb-fsevent

FSEvents API with Signals catching (without RubyCocoa)

This dependency is up-to-date. Congrats and keep going!

Gems rspec ~> 2.7 3.3.0

rspec

BDD for Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems ruby-debug19 >= 0 0.11.6

ruby-debug19

A generic command line interface for ruby-debug.

This dependency is up-to-date. Congrats and keep going!

Gems simplecov >= 0 0.10.0

simplecov

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is up-to-date. Congrats and keep going!