8f93a872e399bc1353cc8d4e791d5401?s=64 mislav

will_paginate

6 2 0

Pagination library for Rails 3, Sinatra, Merb, DataMapper, and more

Dependencies

Package Locked Requirement Latest Status Changelog
There is no runtime dependency.
Package Locked Requirement Latest Status Changelog
Gems debugger >= 0 1.6.6

debugger

debugger is a fast implementation of the standard Ruby debugger debug.rb. It is implemented by utilizing a new Ruby C API hook. The core component provides support that front-ends can build on. It provides breakpoint handling, bindings for stack frames among other things.

This dependency is up-to-date. Congrats and keep going!

Gems mocha ~> 0.9.8 1.0.0

mocha

Mocking and stubbing library with JMock/SchMock syntax, which allows mocking and stubbing of methods on real (non-mock) classes.

This dependency is not matching latest version. Please consider upgrading.

Gems mysql ~> 2.9 2.9.1

mysql

This is the MySQL API module for Ruby. It provides the same functions for Ruby programs that the MySQL C API provides for C programs. This package is offered as gem for easy installation using RubyGems. It wraps unmodified tmtm's mysql-ruby extension into a proper gem. Please note that tmtm (Tomita Mashahiro) has deprecated development of this extension and only update it for bug fixes.

This dependency is up-to-date. Congrats and keep going!

Gems mysql2 ~> 0.3.10 0.3.15

mysql2

A simple, fast Mysql library for Ruby, binding to libmysql

This dependency is up-to-date. Congrats and keep going!

Gems pg ~> 0.11 0.17.1

pg

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 8.4 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

This dependency is up-to-date. Congrats and keep going!

Gems rspec ~> 2.6.0 2.14.1

rspec

BDD for Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems ruby-debug >= 0 0.10.4

ruby-debug

A generic command line interface for ruby-debug.

This dependency is up-to-date. Congrats and keep going!

Gems sqlite3 ~> 1.3.6 1.3.9

sqlite3

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is up-to-date. Congrats and keep going!