Cb4e9c9ec6d33ee844baa03bd8f58cd3?s=64 mysociety

popit-api

9 9 0

PopIt API code - can be used as a standalone PopIt/Popolo API server or embedded in an Express website

Dependencies

Package Locked Requirement Latest Status Changelog
Npms JSV ~4.0.2 4.0.2

JSV

A JavaScript implementation of a extendable, fully compliant JSON Schema validator.

This dependency is up-to-date. Congrats and keep going!

Npms assert ~0.4.9 1.1.1

assert

commonjs assert - node.js api compatible

This dependency is not matching latest version. Please consider upgrading.

Npms async ~0.2.6 0.7.0

async

Higher-order functions and common patterns for asynchronous code

This dependency is not matching latest version. Please consider upgrading.

Npms doublemetaphone ~0.1.2 0.1.2

doublemetaphone

Encode a string into a phonetic code with the Double Metaphone algorithm

This dependency is up-to-date. Congrats and keep going!

Npms elasticsearch ~1.5.1 2.1.0

elasticsearch

The official low-level Elasticsearch client for Node.js and the browser.

This dependency is not matching latest version. Please consider upgrading.

Npms express ~3.1.0 4.0.0

express

Sinatra inspired web development framework

This dependency is not matching latest version. Please consider upgrading.

Npms glob ~3.1.21 3.2.9

glob

a little globber

This dependency is not matching latest version. Please consider upgrading.

Npms http-accept ~0.1.6 0.1.6

http-accept

Connect compatible middleware that parses HTTP Accept header fields

This dependency is up-to-date. Congrats and keep going!

Npms language-tags ~1.0.2 1.0.2

language-tags

Work with IANA language tags.

This dependency is up-to-date. Congrats and keep going!

Npms mongoose ~3.8.5 3.8.8

mongoose

Mongoose MongoDB ODM

This dependency is up-to-date. Congrats and keep going!

Npms regexp-quote 0.0.0 0.0.0

regexp-quote

RegExp.quote = require('regexp-quote')

This dependency is up-to-date. Congrats and keep going!

Npms underscore ~1.4.4 1.6.0

underscore

JavaScript's functional programming helper library.

This dependency is not matching latest version. Please consider upgrading.

Npms underscore.string ~2.3.1 2.3.3

underscore.string

String manipulation extensions for Underscore.js javascript library.

This dependency is up-to-date. Congrats and keep going!

Npms unorm ~1.3.1 1.3.3

unorm

JavaScript Unicode 6.3 Normalization - NFC, NFD, NFKC, NFKD. Read <http://unicode.org/reports/tr15/> UAX #15 Unicode Normalization Forms.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Npms jshint ~1.1.0 2.5.0

jshint

Static analysis tool for JavaScript

This dependency is not matching latest version. Please consider upgrading.

Npms mocha ~1.18.2 1.18.2

mocha

simple, flexible, fun test framework

This dependency is up-to-date. Congrats and keep going!

Npms pow-mongodb-fixtures ~0.8.1 0.10.0

pow-mongodb-fixtures

Easy JSON fixture loading for MongoDB. Makes managing document relationships easier.

This dependency is not matching latest version. Please consider upgrading.

Npms supertest ~0.5.1 0.10.0

supertest

Super-agent driven library for testing HTTP servers

This dependency is not matching latest version. Please consider upgrading.