Npms_big

babel-cli

6.24.0

Babel command line.

(6to5, babel, es6, transpile, transpiler, babel-cli, compiler)

Critical or Security advisories for 6.24.0

This version doesn't have any advisory. Want to report one?

Changelog for 6.24.0

(2017-03-13)

A quick release for 2 features:

  • Thanks to @rwjblue, there is now a noInterop option for our es2015-modules transform to remove the interopRequireDefault and interopRequireWildcard helpers.

Input

js import foo from "foo"; foo;

Regular Output

```js var foo = require("foo"); var _foo2 = _interopRequireDefault(foo); function interopRequireDefault(obj) { return obj && obj._esModule ? obj : { default: obj }; }

Dependencies for 6.24.0

Name Requirement Status
^6.24.0

^6.22.0

^6.23.0

^6.24.0

^6.22.0

^1.6.1

^2.8.1

^1.1.0

^1.0.0

^7.0.0

Display all

My projects using babel-cli

Name Locked version Requirement
You should be logged in to see which of your projects use babel-cli.