Npms_big

babel-loader

7.0.0

babel module loader for webpack

(webpack, loader, babel, es6, transpiler, module)

Critical or Security advisories for 7.0.0

This version doesn't have any advisory. Want to report one?

Changelog for 7.0.0

💥 Breaking Change

  • Drop support for node < 4
  • Drop support for webpack 1

🚀 New Feature

  • support babel-core@7 (#403) (Henry Zhu)

🐛 Bug Fix

  • Make sure .babelrc is a file, not a directory (#427) (Hiroki Osame)
  • Bump loader-utils and use getOptions (#391) (Brian Ng)
  • Ensure options are always an object (#413) (Daniel Tschinder)

📝 Documentation

  • Point changelog to releases (Daniel Tschinder)
  • Updated documentation to match webpack v2 changes. (#438) (Jagadish Kasi)
  • Add note about webpack versions (Daniel Tschinder)
  • Update README.md for webpack 2 (#402) (Sid Raval)

🏠 Internal

  • chore(ci): get rid of node 0.10 (#354) (Yuta Hiroto)
  • Use preset-env (#406) (Daniel Tschinder)
  • Correctly run yarn commands (Daniel Tschinder)
  • Update ava to the latest version 🚀 (#434) (greenkeeper[bot])
  • Update cross-env to the latest version 🚀 (#431) (greenkeeper[bot])
  • chore(package): update babel-plugin-istanbul to version 4.0.0 (#374) (greenkeeper[bot])
  • chore(package): update cross-env to version 3.1.4 (#353) (greenkeeper[bot])
  • chore(package): update ava to version 0.18.0 (#369) (greenkeeper[bot])
  • Use yarn (#376) (Daniel Tschinder)
  • target node 4 in preset env (#423) (Daniel Tschinder)
  • Add prettier (#409) (Daniel Tschinder)
  • Use bash codecov (#440) (Daniel Tschinder)

Dependencies for 7.0.0

Name Requirement Status
Npms ava
^0.19.0

^6.18.0

^6.0.0

^7.1.0

^4.0.0

^2.1.3

^1.2.0

^6.18.0

^4.0.0

^3.8.1

Display all

My projects using babel-loader

Name Locked version Requirement
You should be logged in to see which of your projects use babel-loader.