Npms_big

gulp-babel

7.0.0

Use next generation JavaScript, today

(gulpplugin, babel, transpiler, es2015, es2016, es2017, rewriting, transformation, syntax, codegen, desugaring, javascript, compiler)

Critical or Security advisories for 7.0.0

This version doesn't have any advisory. Want to report one?

Changelog for 7.0.0

Not many changes needed

  • just dropped Node 0.10/0.12 support
  • made babel-core a peerDependency instead of dependency and supports v6/v7/(alpha/beta/rc for v7)
  • currently on the --next npm tag until v7 is released

Dependencies for 7.0.0

Name Requirement Status
7.0.0-alpha.18

7.0.0-alpha.18

7.0.0-alpha.18

7.0.0-alpha.18

^1.1.1

^3.0.0

*

0.0.1

^2.0.0

^0.2.0

Display all

My projects using gulp-babel

Name Locked version Requirement
You should be logged in to see which of your projects use gulp-babel.