This version is outdated! Click here to see latest
Npms_big

gulp-mocha

4.0.0

Run Mocha tests

(gulpplugin, mocha, test, testing, unit, framework, runner, tdd, bdd, qunit, spec, tap)

Critical or Security advisories for 4.0.0

This version doesn't have any advisory. Want to report one?

Changelog for 4.0.0

  • Drop support for Node.js 0.12 and 0.10.
  • Now spawns the mocha binary instead using its broken programmatic API. This means you can use any of the mocha CLI flags (in a camelCased form). This should also fix most of the issues people have been having with this task. Thanks to @shellscape for doing most of the work.

If you were using Babel with babel-register in your gulpfile, you now need to use the Mocha compilers option instead: {compilers: 'js:babel-core/register'}. See https://babeljs.io/docs/setup/#installation

Dependencies for 4.0.0

Name Requirement Status
^5.1.0

^0.6.0

^3.0.0

^3.0.0

^2.0.3

Npms xo
*

My projects using gulp-mocha

Name Locked version Requirement
You should be logged in to see which of your projects use gulp-mocha.