Npms_big

gulp-uglify

2.0.0

Minify files with UglifyJS.

(gulpplugin)

Critical or Security advisories for 2.0.0

This version doesn't have any advisory. Want to report one?

Changelog for 2.0.0

Bug Fixes

  • errors: emit errors of type GulpUglifyError (1232c3c)
  • minifer: use gulplog for the warning (5632cee)

Features

  • minifier: use UglifyJS 2.7.0's input map support (8160697)

BREAKING CHANGES

  • errors: Emitted errors are of a new type. Original UglifyJS error message are preserved instead of the attempt to normalize them. The constructor is exported as "GulpUglifyError" to allow for instance checks.
  • minifier: Now requires UglifyJS 2.7.0 or greater to use the input object support.

Dependencies for 2.0.0

Name Requirement Status
^2.11.4

^2.0.0

^1.0.0

^1.0.0

^0.1.0

^1.0.1

^0.4.0

^4.13.1

^1.1.1

^1.2.0

Display all

My projects using gulp-uglify

Name Locked version Requirement
You should be logged in to see which of your projects use gulp-uglify.