Npms_big

inquirer

4.0.0

A collection of common interactive command line user interfaces.

(command, prompt, stdin, cli, tty, menu)

Critical or Security advisories for 4.0.0

This version doesn't have any advisory. Want to report one?

Changelog for 4.0.0

Breaking

The core codebase went through a major es5 to 6 refactor. As such, we're dropping support for Node 4.

This change will likely require changes to the community Plugins as es6 classes are enforcing more restriction (like constructor can only be invoked with new).

New features / Bug fixes

  • list, expand and rawlist prompts now accepts the value as default (previously it would only accept the choice index).
  • The pagination now properly handles multiline choices.
  • Fix bug where invalid default choices would break the UI.

Dependencies for 4.0.0

Name Requirement Status
^3.0.0

^4.0.1

^2.0.0

^2.1.0

^2.0.0

^0.0.4

^3.0.0

^4.1.0

^2.4.0

^0.19.0

Display all

My projects using inquirer

Name Locked version Requirement
You should be logged in to see which of your projects use inquirer.