Npms_big

karma

2.0.0

Spectacular Test Runner for JavaScript.

(karma, spectacular, runner, karma, js, javascript, testing, test, remote, execution)

Critical or Security advisories for 2.0.0

This version doesn't have any advisory. Want to report one?

Changelog for 2.0.0

Bug Fixes

  • config: Call debug log methods after setting the loglevel based upon config/cli-options. (99fd3f0)
  • config: Call debug log methods after setting the loglevel based upon config/cli-options. (a340dae)
  • config: Retry install with appveyor-retry. (17d5791)
  • config: Workaround npm 5.4 windows bug (ec47d81)
  • deps: update socket.io to version 2.0.3. (3b7b019), closes #2821 #2777
  • logging: Upgrade to log4js 2.x API. (#2868) (f6f8707), closes #2858
  • reporter: show file path correctly when urlRoot specified (34dc7d3), closes #2897

Features

  • cli: Warn on commands with underscores. (0801a7f)
  • config: allow to use newer versions of CoffeeScript (c1fcf42)
  • launcher: trim whitespace in browser name (871d46f)
  • launcher: trim whitespace in browser name (334f9fb)
  • middleware: added manual file type option (0330cd1), closes #2824
  • better string representation of errors (c9e1ca9)
  • drop core-js and babel where possible (60dfc5c)
  • update of supported node versions (e79463b)

Dependencies for 2.0.0

Name Requirement Status
^6.26.0

^3.3.0

^1.16.1

^14.5.0

^4.1.2

^7.1.1

^1.2.2

^1.4.1

^1.12.7

^1.1.0

Display all

My projects using karma

Name Locked version Requirement
You should be logged in to see which of your projects use karma.