This version is outdated! Click here to see latest
Npms_big

mongoose

4.11.10

Mongoose MongoDB ODM

(mongodb, document, model, schema, database, odm, data, datastore, query, nosql, orm, db)

Critical or Security advisories for 4.11.10

This version doesn't have any advisory. Want to report one?

Changelog for 4.11.10

  • docs: add KeenIO tracking #5612
  • fix(schema): ensure validators declared with .validate() get copied with clone() #5607
  • fix: remove unnecessary jest warning #5480
  • fix(discriminator): prevent implicit discriminator schema id from clobbering base schema custom id #5591
  • fix(schema): hide schema objectid warning for non-hex strings of length 24 #5587
  • docs(populate): use story schema defined key author instead of creator #5578 dmric
  • docs(document): describe usage of .set() #5576
  • fix(document): ensure correct scope in single nested validators #5569
  • fix(populate): don't mark path as populated until populate() is done #5564
  • fix(document): make push()-ing a doc onto an empty array act as manual population #5504
  • fix(connection): emit timeout event on socket timeout #4513

Dependencies for 4.11.10

Name Requirement Status
0.4.1

0.0.3

2.1.4

2.1.2

3.5.0

~1.0.4

Npms co
4.6.0

Npms dox
0.3.1

2.4.0

7.0.1

Display all

My projects using mongoose

Name Locked version Requirement
You should be logged in to see which of your projects use mongoose.