This version is outdated! Click here to see latest
Npms_big

mongoose

4.11.8

Mongoose MongoDB ODM

(mongodb, document, model, schema, database, odm, data, datastore, query, nosql, orm, db)

Critical or Security advisories for 4.11.8

This version doesn't have any advisory. Want to report one?

Changelog for 4.11.8

  • feat: add warning about using schema ObjectId as type ObjectId #5571 efkan
  • fix(schema): allow setting id property after schema was created #5570 #5548
  • docs(populate): remove confusing _ from populate docs #5560
  • fix(connection): expose parsed uri fields (host, port, dbname) when using openUri() #5556
  • docs: added type boolean to options documentation #5547 ndabAP
  • test: add test coverage for stopping/starting server #5524
  • fix(aggregate): pull read preference from schema by default #5522

Dependencies for 4.11.8

Name Requirement Status
0.4.1

0.0.3

2.1.4

2.1.2

3.5.0

~1.0.4

Npms co
4.6.0

Npms dox
0.3.1

2.4.0

7.0.1

Display all

My projects using mongoose

Name Locked version Requirement
You should be logged in to see which of your projects use mongoose.