Npms_big

q

1.5.1

A library for promises (CommonJS/Promises/A,B,D)

(q, promise, promises, promises-a, promises-aplus, deferred, future, async, flow control, fluent, browser, node)

Critical or Security advisories for 1.5.1

This version doesn't have any advisory. Want to report one?

Changelog for 1.5.1

"finally" is invalid (@grahamrhay)

  • Long stack trace improvements, can now construct long stack traces across rethrows.

Dependencies for 1.5.1

Name Requirement Status
*

~0.4.1

~0.1.9

~0.9.1

1.11.0

~2.1.9

~0.2.0

*

1.x

My projects using q

Name Locked version Requirement
You should be logged in to see which of your projects use q.