nrako nrako

formal-mongoose

3 18 0

formal + mongoose = DRY! Define your form from your mongoose schema.

Dependencies

Package Locked Requirement Latest Status Changelog
Npms formal ~0.3.0 0.3.0

formal

Simple, flexible node.js form module with casting and validation; inspired by mongoose

This dependency is up-to-date. Congrats and keep going!

Npms mpath ~0.2.1 0.2.1

mpath

{G,S}et object values using MongoDB-like path notation

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Npms blanket ~1.1.4 1.1.7

blanket

seamless js code coverage

This dependency is not matching latest version. Please consider upgrading.

Npms chai ~1.6.0 3.0.0

chai

BDD/TDD assertion library for node.js and the browser. Test framework agnostic.

This dependency is not matching latest version. Please consider upgrading.

Npms coffee-script ~1.6.2 1.9.3

coffee-script

Unfancy JavaScript

This dependency is not matching latest version. Please consider upgrading.

Npms glob ~3.2.1 5.0.13

glob

a little globber

This dependency is not matching latest version. Please consider upgrading.

Npms grunt ~0.4.1 0.4.5

grunt

The JavaScript Task Runner

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-clean ~0.4.1 0.6.0

grunt-contrib-clean

Clean files and folders.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-jshint ~0.4.3 0.11.2

grunt-contrib-jshint

Validate files with JSHint.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-contrib-yuidoc ~0.4.0 0.8.0

grunt-contrib-yuidoc

Compile YUIDoc Documentation.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-dox ~0.4.1 0.5.0

grunt-dox

Dox grunt plugin

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-jsonlint ~1.0.0 1.0.4

grunt-jsonlint

Validate JSON files from grunt.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-jsvalidate ~0.2.1 0.2.2

grunt-jsvalidate

Validate JavaScript source.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-mocha-cov 0.0.4 0.4.0

grunt-mocha-cov

Run Mocha server-side tests in Grunt with code coverage support and optional integration to coveralls.io.

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-plato ~0.2.0 1.3.0

grunt-plato

Generate complexity analysis reports with plato

This dependency is not matching latest version. Please consider upgrading.

Npms grunt-simple-mocha ~0.4.0 0.4.0

grunt-simple-mocha

A simple wrapper for running tests with Mocha.

This dependency is up-to-date. Congrats and keep going!

Npms matchdep ~0.1.2 0.3.0

matchdep

Use globule to filter npm module dependencies by name.

This dependency is not matching latest version. Please consider upgrading.

Npms moment ~2.0.0 2.10.3

moment

Parse, validate, manipulate, and display dates

This dependency is not matching latest version. Please consider upgrading.

Npms mongoose ~3.6.10 4.0.6

mongoose

Mongoose MongoDB ODM

This dependency is not matching latest version. Please consider upgrading.

Npms mongoose-validator ~0.2.1 1.2.0

mongoose-validator

Validators for mongoose models utilising validator.js

This dependency is not matching latest version. Please consider upgrading.

Npms travis-cov ~0.2.4 0.2.5

travis-cov

Mocha/blanket coverage reporter for travis-ci.

This dependency is not matching latest version. Please consider upgrading.