postfixadmin-cookbook

10 8 1

Chef cookbook to install and configure PostfixAdmin.

You have 1 open security alert

Dependencies

Package Locked Requirement Latest Status Changelog
There is no runtime dependency.
Package Locked Requirement Latest Status Changelog
Gems berkshelf ~> 3.1 6.3.1

berkshelf

Manages a Cookbook's, or an Application's, Cookbook dependencies

This dependency is not matching latest version. Please consider upgrading.

Gems chef-encrypted-attributes >= 0 0.9.0

chef-encrypted-attributes

Chef plugin to add Node encrypted attributes support using client keys

This dependency is up-to-date. Congrats and keep going!

Gems chefspec ~> 4.0 7.1.0

chefspec

ChefSpec is a unit testing and resource coverage (code coverage) framework for testing Chef cookbooks ChefSpec makes it easy to write examples and get fast feedback on cookbook changes without the need for virtual machines or cloud servers.

This dependency is not matching latest version. Please consider upgrading.

Gems foodcritic = 4.0.0 12.2.1

foodcritic

Lint tool for Chef cookbooks.

This dependency is not matching latest version. Please consider upgrading.

Gems guard ~> 2.6 2.14.1

guard

Guard is a command line tool to easily handle events on file system modifications.

This dependency is up-to-date. Congrats and keep going!

Gems guard-foodcritic ~> 1.0 3.0.0

guard-foodcritic

Guard::Foodcritic automatically runs foodcritic.

This dependency is not matching latest version. Please consider upgrading.

Gems guard-kitchen ~> 0.0 0.0.2

guard-kitchen

Guard plugin for test kitchen

This dependency is up-to-date. Congrats and keep going!

Gems guard-rspec ~> 4.3 4.7.3

guard-rspec

Guard::RSpec automatically run your specs (much like autotest).

This dependency is up-to-date. Congrats and keep going!

Gems guard-rubocop ~> 1.1 1.3.0

guard-rubocop

Guard::RuboCop automatically checks Ruby code style with RuboCop when files are modified.

This dependency is up-to-date. Congrats and keep going!

Gems kitchen-digitalocean ~> 0.8 0.9.8

kitchen-digitalocean

A Test Kitchen Driver for Digital Ocean

This dependency is up-to-date. Congrats and keep going!

Gems kitchen-ec2 ~> 0.8 1.3.2

kitchen-ec2

A Test Kitchen Driver for Amazon EC2

This dependency is not matching latest version. Please consider upgrading.

Gems kitchen-vagrant ~> 0.10 1.2.1

kitchen-vagrant

Kitchen::Driver::Vagrant - A Vagrant Driver for Test Kitchen.

This dependency is not matching latest version. Please consider upgrading.

Gems rake >= 0 12.3.0

rake

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * Supports parallel execution of tasks.

This dependency is up-to-date. Congrats and keep going!

Gems rubocop = 0.32.0 0.51.0

rubocop

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Security alert:

Gems sequel ~> 4.23 5.2.0

sequel

The Database Toolkit for Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems should_not ~> 1.1 1.1.0

should_not

You should_not start your specs with the string "should". If every spec starts with "should", then it's redundant everywhere. Instead, write in an active tone: `it "should ignore nil elements"` - BAD `it "ignores nil elements"` - GOOD

This dependency is up-to-date. Congrats and keep going!

Gems test-kitchen ~> 1.2 1.19.1

test-kitchen

Test Kitchen is an integration tool for developing and testing infrastructure code and software on isolated target platforms.

This dependency is up-to-date. Congrats and keep going!

Gems vagrant-wrapper ~> 2.0 2.0.3

vagrant-wrapper

Since Vagrant 1.1+ is no longer distributed via Gems, vagrant-wrapper allows you to require and interact with the newer package versions via your Gemfile, shell, or Ruby code. It allows the newer packaged version to take precedence even if the older Vagrant gem remains installed. See https://github.com/org-binbab/gem-vagrant-wrapper for more details.

This dependency is up-to-date. Congrats and keep going!

Gems webmock ~> 1.21 3.1.1

webmock

WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.

This dependency is not matching latest version. Please consider upgrading.