9fb6d496226ae9161913564ab97d8afb?s=64 openoakland

adopt-a-drain

2 13 5

AdoptaDrain is an online civic tool that supports the City of Oakland's Adopta-Spot program.

You have 13 open security alerts

Dependencies

Package Locked Requirement Latest Status Changelog
Gems arel 3.0.2 >= 0 5.0.1.20140414130214

arel version 3.0.2

Arel is a SQL AST manager for Ruby. It 1. Simplifies the generation of complex SQL queries 2. Adapts to various RDBMSes It is intended to be a framework framework; that is, you can build your own ORM with it, focusing on innovative object and collection modeling as opposed to database compatibility and query generation.

This dependency is not matching latest version. Please consider upgrading.

Gems devise 2.2.0 >= 0 3.2.4

devise version 2.2.0

Flexible authentication solution for Rails with Warden

Gems fastercsv 1.5.5 >= 0 1.5.5

fastercsv version 1.5.5

FasterCSV is intended as a complete replacement to the CSV standard library. It is significantly faster and smaller while still being pure Ruby code. It also strives for a better interface.

This dependency is up-to-date. Congrats and keep going!

Gems geokit 1.6.7 ~> 1.6.7 1.8.4

geokit version 1.6.7

Geokit provides geocoding and distance calculation in an easy-to-use API

This dependency is not matching latest version. Please consider upgrading.

Gems google-v3-geocoder 1.0.0 = 1.0.0 1.0.0

google-v3-geocoder version 1.0.0

Geokit::Geocoder subclass for interacting with Google's v3 API <http://code.google.com/apis/maps/documentation/geocoding/>

This dependency is up-to-date. Congrats and keep going!

Gems haml 3.2.0.rc.2 ~> 3.2.0.alpha 4.0.5

haml version 3.2.0.rc.2

Haml (HTML Abstraction Markup Language) is a layer on top of HTML or XML that's designed to express the structure of documents in a non-repetitive, elegant, and easy way by using indentation rather than closing tags and allowing Ruby to be embedded with ease. It was originally envisioned as a plugin for Ruby on Rails, but it can function as a stand-alone templating engine.

This dependency is not matching latest version. Please consider upgrading.

Gems http_accept_language 1.0.2 >= 0 2.0.1

http_accept_language version 1.0.2

Find out which locale the user preferes by reading the languages they specified in their browser

This dependency is not matching latest version. Please consider upgrading.

Gems httparty 0.10.2 >= 0 0.13.1

httparty version 0.10.2

Makes http fun! Also, makes consuming restful web services dead easy.

This dependency is not matching latest version. Please consider upgrading.

Gems newrelic_rpm 3.5.5.38 >= 0 3.7.3.204

newrelic_rpm version 3.5.5.38

New Relic is a performance management system, developed by New Relic, Inc (http://www.newrelic.com). New Relic provides you with deep information about the performance of your web application as it runs in production. The New Relic Ruby Agent is dual-purposed as a either a Gem or plugin, hosted on http://github.com/newrelic/rpm/

This dependency is not matching latest version. Please consider upgrading.

Gems pg 0.14.1 >= 0 0.17.1

pg version 0.14.1

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 8.4 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

This dependency is not matching latest version. Please consider upgrading.

Gems rails 3.2.13 ~> 3.2 4.1.0

rails version 3.2.13

Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.

Gems rails_admin 0.4.0 >= 0 0.6.2

Gems sendgrid 1.0.1 ~> 1.0.1 1.2.0

sendgrid version 1.0.1

This gem allows simple integration between ActionMailer and SendGrid. SendGrid is an email deliverability API that is affordable and has lots of bells and whistles.

This dependency is not matching latest version. Please consider upgrading.

Gems thin 1.5.0 >= 0 1.6.2

thin version 1.5.0

A thin and fast web server

This dependency is not matching latest version. Please consider upgrading.

Gems validates_formatting_of 0.7.1 >= 0 0.8.1

validates_formatting_of version 0.7.1

Common Rails validations wrapped in a gem.

Security alert through its dependencies:

Package Locked Requirement Latest Status Changelog
Gems sass-rails 3.2.5 >= 0 4.0.3

sass-rails version 3.2.5

Sass adapter for the Rails asset pipeline.

Gems simplecov 0.7.1 >= 0 0.8.2

simplecov version 0.7.1

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is not matching latest version. Please consider upgrading.

Gems sqlite3 1.3.6 >= 0 1.3.9

sqlite3 version 1.3.6

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is not matching latest version. Please consider upgrading.

Gems uglifier 1.3.0 >= 0 2.5.0

uglifier version 1.3.0

Uglifier minifies JavaScript files by wrapping UglifyJS to be accessible in Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems webmock 1.9.0 >= 0 1.17.4

webmock version 1.9.0

WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.

This dependency is not matching latest version. Please consider upgrading.