osbridge osbridge

openconferenceware

13 17 4

OpenConferenceWare is an open source web application for events and conferences. This customizable, general-purpose platform provides proposals, sessions, schedules, tracks and more.

You have 5 open security alerts

Reports Beta

Some reports are compatible with your project but none of them has been enabled.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems RedCloth ~> 4.2.0 4.3.2

RedCloth

Textile parser for Ruby.

Security alert:

Gems aasm ~> 3.1.0 4.12.2

aasm

AASM is a continuation of the acts-as-state-machine rails plugin, built for plain Ruby objects.

This dependency is not matching latest version. Please consider upgrading.

Gems acts-as-taggable-on ~> 3.0.0 5.0.0

acts-as-taggable-on

With ActsAsTaggableOn, you can tag a single model on several contexts, such as skills, interests, and awards. It also provides other advanced functionality.

This dependency is not matching latest version. Please consider upgrading.

Gems color ~> 1.5.1 1.8

color

Color is a Ruby library to provide basic RGB, CMYK, HSL, and other colourspace manipulation support to applications that require it. It also provides 152 named RGB colours (184 with spelling variations) that are commonly supported in HTML, SVG, and X11 applications. A technique for generating monochromatic contrasting palettes is also included. The Color library performs purely mathematical manipulation of the colours based on colour theory without reference to colour profiles (such as sRGB or Adobe RGB). For most purposes, when working with RGB and HSL colour spaces, this won't matter. Absolute colour spaces (like CIE L*a*b* and XYZ) and cannot be reliably converted to relative colour spaces (like RGB) without colour profiles. Color 1.8 adds an alpha parameter to all <tt>#css_rgba</tt> calls, fixes a bug exposed by new constant lookup semantics in Ruby 2, and ensures that <tt>Color.equivalent?</tt> can only be called on Color instances. Barring bugs introduced in this release, this (really) is the last version of color that supports Ruby 1.8, so make sure that your gem specification is set properly (to <tt>~> 1.8</tt>) if that matters for your application. This version will no longer be supported one year after the release of color 2.0.

This dependency is not matching latest version. Please consider upgrading.

Gems comma ~> 3.0 4.1.0

comma

Ruby Comma Seperated Values generation library

This dependency is not matching latest version. Please consider upgrading.

Gems dynamic_form ~> 1.1.4 1.1.4

dynamic_form

DynamicForm holds a few helper methods to help you deal with your Rails3 models. It includes the stripped out methods from Rails 2; error_message_on and error_messages_for. It also brings in the functionality of the custom-err-messages plugin, which provides more flexibility over your model error messages.

This dependency is up-to-date. Congrats and keep going!

Gems gchartrb ~> 0.8.0 0.8

gchartrb

Visit http://code.google.com/p/gchartrb to track development regarding gchartrb. == FEATURES: * Provides an object oriented interface in Ruby to create Google Chart URLs for charts. == INSTALL: === Ruby Gem:

This dependency is up-to-date. Congrats and keep going!

Gems hashery ~> 2.1.0 2.1.2

hashery

The Hashery is a tight collection of Hash-like classes. Included among its many offerings are the auto-sorting Dictionary class, the efficient LRUHash, the flexible OpenHash and the convenient KeyHash. Nearly every class is a subclass of the CRUDHash which defines a CRUD model on top of Ruby's standard Hash making it a snap to subclass and augment to fit any specific use case.

This dependency is up-to-date. Congrats and keep going!

Gems jquery-rails ~> 3.1.0 4.3.1

jquery-rails

This gem provides jQuery and the jQuery-ujs driver for your Rails 4+ application.

This dependency is not matching latest version. Please consider upgrading.

Gems nokogiri ~> 1.6.0 1.8.0

nokogiri

Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. Among Nokogiri's many features is the ability to search documents via XPath or CSS3 selectors.

Security alerts:

Gems omniauth ~> 1.2.0 1.6.1

omniauth

A generalized Rack framework for multiple-provider authentication.

This dependency is not matching latest version. Please consider upgrading.

Gems paperclip ~> 4.1.0 5.1.0

paperclip

Easy upload management for ActiveRecord

Security alert:

Gems prawn ~> 0.12.0 2.2.2

prawn

Prawn is a fast, tiny, and nimble PDF generator for Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems rails ~> 4.0.2 5.1.3

rails

Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.

This dependency is not matching latest version. Please consider upgrading.

Gems rails-observers ~> 0.1.2 0.1.5

rails-observers

Rails observer (removed from core in Rails 4.0)

This dependency is up-to-date. Congrats and keep going!

Gems randumb ~> 0.5.0 0.5.2

randumb

Adds the ability to pull random records from ActiveRecord

This dependency is up-to-date. Congrats and keep going!

Gems rinku ~> 1.7.3 2.0.2

rinku

A fast and very smart autolinking library that acts as a drop-in replacement for Rails `auto_link`

This dependency is not matching latest version. Please consider upgrading.

Gems sass-rails ~> 4.0.0 5.0.6

sass-rails

Sass adapter for the Rails asset pipeline.

This dependency is not matching latest version. Please consider upgrading.

Gems uglifier ~> 2.4.0 3.2.0

uglifier

Uglifier minifies JavaScript files by wrapping UglifyJS to be accessible in Ruby

Gems vpim ~> 13.11.11 13.11.11

vpim

This is a pure-ruby library for decoding and encoding vCard and iCalendar data ("personal information") called vPim.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems cadre >= 0 1.0.4

cadre

Three things: An rspec formatter that triggers libnotify on completion. An rspec formatter that outputs to vim quickfix A simplecov formatter that produces vim markers (+ a vim plugin to load them)

This dependency is up-to-date. Congrats and keep going!

Gems capybara ~> 2.2.0 2.15.1

capybara

Capybara is an integration testing tool for rack based web applications. It simulates how a user would interact with a website

This dependency is not matching latest version. Please consider upgrading.

Gems coveralls ~> 0.7.0 0.8.21

coveralls

A Ruby implementation of the Coveralls API.

This dependency is not matching latest version. Please consider upgrading.

Gems cucumber-rails ~> 1.4.0 1.5.0

cucumber-rails

Cucumber Generator and Runtime for Rails

This dependency is not matching latest version. Please consider upgrading.

Gems database_cleaner ~> 1.2.0 1.6.1

database_cleaner

Strategies for cleaning databases. Can be used to ensure a clean state for testing.

This dependency is not matching latest version. Please consider upgrading.

Gems debugger >= 0 1.6.8

debugger

debugger is a fast implementation of the standard Ruby debugger debug.rb. It is implemented by utilizing a new Ruby C API hook. The core component provides support that front-ends can build on. It provides breakpoint handling, bindings for stack frames among other things.

This dependency is up-to-date. Congrats and keep going!

Gems factory_girl_rails ~> 4.3.0 4.8.0

factory_girl_rails

factory_girl_rails provides integration between factory_girl and rails 3 or newer (currently just automatic factory definition loading)

This dependency is not matching latest version. Please consider upgrading.

Gems guard-rspec >= 0 4.7.3

guard-rspec

Guard::RSpec automatically run your specs (much like autotest).

This dependency is up-to-date. Congrats and keep going!

Gems launchy >= 0 2.4.3

launchy

Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.

This dependency is up-to-date. Congrats and keep going!

Gems omniauth-openid ~> 1.0.0 1.0.1

omniauth-openid

OpenID strategy for OmniAuth.

This dependency is up-to-date. Congrats and keep going!

Gems pry >= 0 0.10.4

pry

An IRB alternative and runtime developer console

This dependency is up-to-date. Congrats and keep going!

Gems rspec-rails ~> 2.14.0 3.6.1

rspec-rails

rspec-rails is a testing framework for Rails 3+.

This dependency is not matching latest version. Please consider upgrading.

Gems simplecov ~> 0.8.2 0.15.0

simplecov

Code coverage for Ruby 1.9+ with a powerful configuration library and automatic merging of coverage across test suites

This dependency is not matching latest version. Please consider upgrading.

Gems sqlite3 ~> 1.3.0 1.3.13

sqlite3

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is up-to-date. Congrats and keep going!