Packagist_big

composer/composer

1.5.2

Composer helps you declare, manage and install dependencies of PHP projects, ensuring you have the right stack everywhere.

(package, dependency, autoload)

Critical or Security advisories for 1.5.2

This version doesn't have any advisory. Want to report one?

Changelog for 1.5.2

  • Fixed GitLabDriver looping endlessly in some conditions
  • Fixed GitLabDriver support for unauthenticated requests
  • Fixed GitLab zip downloads not triggering credentials prompt if unauthenticated
  • Fixed path repository support of COMPOSER_ROOT_VERSION, it now applies to all path repos within the same git repository
  • Fixed path repository handling of copies to avoid copying VCS files and others
  • Fixed sub-directory call to ignore list and create-project commands as well as calls to Composer using --working-dir
  • Fixed invalid warning appearing when calling remove on an non-stable package

Dependencies for 1.5.2

Name Requirement Status
^1.0

^1.0

^1.0

^3.0 || ^4.0 || ^5.0

^4.5 || ^5.0.5

^2.3 || ^3.0

^1.0

^1.0

^1.4

^1.0

Display all

My projects using composer/composer

Name Locked version Requirement
You should be logged in to see which of your projects use composer/composer.