This version is outdated! Click here to see latest
Packagist_big

composer/composer

1.5.3

Composer helps you declare, manage and install dependencies of PHP projects, ensuring you have the right stack everywhere.

(package, dependency, autoload)

Critical or Security advisories for 1.5.3

This version doesn't have any advisory. Want to report one?

Changelog for 1.5.3

  • Fixed require/remove commands reverting the composer.json change when a non-solver-related error occurs
  • Fixed GitLabDriver to support installations of GitLab not at the root of the domain
  • Fixed create-project not following the optimize-autoloader flag of the root package
  • Fixed Authorization header being forwarded across domains after a redirect
  • Improved some error messages for clarity

Dependencies for 1.5.3

Name Requirement Status
^1.0

^1.0

^1.0

^3.0 || ^4.0 || ^5.0

^4.5 || ^5.0.5

^2.3 || ^3.0

^1.0

^1.0

^1.4

^1.0

Display all

My projects using composer/composer

Name Locked version Requirement
You should be logged in to see which of your projects use composer/composer.