phadej phadej

jsstana

4 14 0

s-expression match patterns for Mozilla Parser AST

Dependencies

Package Locked Requirement Latest Status Changelog
Npms chalk ~1.0.0 1.1.1

chalk

Terminal string styling done right. Much color.

This dependency is not matching latest version. Please consider upgrading.

Npms commander ~2.6.0 2.8.1

commander

the complete solution for node.js command-line programs

This dependency is not matching latest version. Please consider upgrading.

Npms esprima ~2.0.0 2.5.0

esprima

ECMAScript parsing infrastructure for multipurpose analysis

This dependency is not matching latest version. Please consider upgrading.

Npms estraverse ~1.9.1 4.1.0

estraverse

ECMAScript JS AST traversal functions

This dependency is not matching latest version. Please consider upgrading.

Npms levenshtein ~1.0.2 1.0.5

levenshtein

Javascript implementation of the L-diggity.

This dependency is not matching latest version. Please consider upgrading.

Npms packrattle ~3.0.1 4.1.0

packrattle

GLL parser-combinator library

This dependency is not matching latest version. Please consider upgrading.

Npms underscore ~1.8.2 1.8.3

underscore

JavaScript's functional programming helper library.

This dependency is not matching latest version. Please consider upgrading.

Npms walkdir 0.0.7 0.0.10

walkdir

Find files simply. Walks a directory tree emitting events based on what it finds. Presents a familliar callback/emitter/a+sync interface. Walk a tree of any depth.

This dependency is not matching latest version. Please consider upgrading.

Package Locked Requirement Latest Status Changelog
Npms chai ^2.1.0 3.2.0

chai

BDD/TDD assertion library for node.js and the browser. Test framework agnostic.

This dependency is not matching latest version. Please consider upgrading.

Npms david ^6.1.4 6.2.0

david

Node.js module that tells you when your project npm dependencies are out of date.

This dependency is up-to-date. Congrats and keep going!

Npms escodegen ~1.6.1 1.6.1

escodegen

ECMAScript code generator

This dependency is up-to-date. Congrats and keep going!

Npms eslint ^0.15.0 1.3.1

eslint

An AST-based pattern checker for JavaScript.

This dependency is not matching latest version. Please consider upgrading.

Npms istanbul ~0.3.0 0.3.19

istanbul

Yet another JS code coverage tool that computes statement, line, function and branch coverage with module loader hooks to transparently add coverage when running tests. Supports all JS coverage use cases including unit tests, server side functional tests

This dependency is up-to-date. Congrats and keep going!

Npms jscs ^1.7.3 2.1.1

jscs

JavaScript Code Style

This dependency is not matching latest version. Please consider upgrading.

Npms jshint ~2.6.0 2.8.0

jshint

Static analysis tool for JavaScript

This dependency is not matching latest version. Please consider upgrading.

Npms jsverify ^0.5.1 0.7.1

jsverify

Property-based testing for JavaScript.

This dependency is not matching latest version. Please consider upgrading.

Npms ljs ~0.3.0 0.3.2

ljs

Generate docs from your source

This dependency is up-to-date. Congrats and keep going!

Npms mocha ~2.1.0 2.2.5

mocha

simple, flexible, fun test framework

This dependency is not matching latest version. Please consider upgrading.