phiggins phiggins

webmock

2 8 0

Library for stubbing HTTP requests and setting expectations on HTTP requests in Ruby.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems addressable > 2.2.5, ~> 2.2 2.3.8

addressable

Addressable is a replacement for the URI implementation that is part of Ruby's standard library. It more closely conforms to the relevant RFCs and adds support for IRIs and URI templates.

This dependency is not matching latest version. Please consider upgrading.

Gems crack >= 0.1.7 0.4.2

crack

Really simple JSON and XML parsing, ripped from Merb and Rails.

This dependency is not matching latest version. Please consider upgrading.

Gems jruby-openssl ~> 0.7 0.9.8

jruby-openssl

JRuby-OpenSSL is an add-on gem for JRuby that emulates the Ruby OpenSSL native library.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems curb >= 0.7.8 0.8.8

curb

Curb (probably CUrl-RuBy or something) provides Ruby-language bindings for the libcurl(3), a fully-featured client-side URL transfer library. cURL and libcurl live at http://curl.haxx.se/

This dependency is not matching latest version. Please consider upgrading.

Gems em-http-request >= 0.2.14 1.1.2

em-http-request

EventMachine based, async HTTP Request client

This dependency is not matching latest version. Please consider upgrading.

Gems guard-rspec >= 0 4.6.3

guard-rspec

Guard::RSpec automatically run your specs (much like autotest).

This dependency is up-to-date. Congrats and keep going!

Gems httpclient >= 2.1.5.2 2.6.0.1

httpclient

gives something like the functionality of libwww-perl (LWP) in Ruby

This dependency is not matching latest version. Please consider upgrading.

Gems patron >= 0.4.9 0.4.20

patron

Ruby HTTP client library based on libcurl

This dependency is not matching latest version. Please consider upgrading.

Gems rb-fsevent >= 0 0.9.5

rb-fsevent

FSEvents API with Signals catching (without RubyCocoa)

This dependency is not matching latest version. Please consider upgrading.

Gems rspec >= 2.0.0 3.3.0

rspec

BDD for Ruby

This dependency is not matching latest version. Please consider upgrading.