B2fed76c7a4cf1778adb683b70281481?s=64 radiant

radiant

24 3 0

Radiant is a no-fluff, open source content management system designed for small teams.

Dependencies

Package Locked Requirement Latest Status Changelog
Gems RedCloth ~> 4.2 4.2.9

RedCloth

Textile parser for Ruby.

This dependency is up-to-date. Congrats and keep going!

Gems activeresource >= 3.2 4.0.0

activeresource

REST on Rails. Wrap your RESTful web app with Ruby classes and work with them like Active Record models.

This dependency is up-to-date. Congrats and keep going!

Gems acts_as_tree ~> 0.1 1.6.0

acts_as_tree

A gem that adds simple support for organizing ActiveRecord models into parent–children relationships.

This dependency is not matching latest version. Please consider upgrading.

Gems compass ~> 0.12 0.12.6

compass

Compass is a Sass-based Stylesheet Framework that streamlines the creation and maintenance of CSS.

This dependency is up-to-date. Congrats and keep going!

Gems compass-rails ~> 1.0 1.1.7

compass-rails

Integrate Compass into Rails 3.0 and up.

This dependency is up-to-date. Congrats and keep going!

Gems haml ~> 4.0 4.0.5

haml

Haml (HTML Abstraction Markup Language) is a layer on top of HTML or XML that's designed to express the structure of documents in a non-repetitive, elegant, and easy way by using indentation rather than closing tags and allowing Ruby to be embedded with ease. It was originally envisioned as a plugin for Ruby on Rails, but it can function as a stand-alone templating engine.

This dependency is up-to-date. Congrats and keep going!

Gems highline ~> 1.6 1.6.21

highline

A high-level IO library that provides validation, type conversion, and more for command-line interfaces. HighLine also includes a complete menu system that can crank out anything from simple list selection to complete shells with just minutes of work.

This dependency is up-to-date. Congrats and keep going!

Gems rack-cache ~> 1.2 1.2

rack-cache

Rack::Cache is suitable as a quick drop-in component to enable HTTP caching for Rack-based applications that produce freshness (Expires, Cache-Control) and/or validation (Last-Modified, ETag) information.

This dependency is up-to-date. Congrats and keep going!

Gems radius ~> 0.7 0.7.4

radius

Radius is a powerful tag-based template language for Ruby inspired by the template languages used in MovableType and TextPattern. It uses tags similar to XML, but can be used to generate any form of plain text (HTML, e-mail, etc...).

This dependency is up-to-date. Congrats and keep going!

Gems rails >= 3.2 4.1.0

rails

Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.

This dependency is up-to-date. Congrats and keep going!

Gems rake ~> 10.0 10.3.1

rake

Rake is a Make-like program implemented in Ruby. Tasks and dependencies are specified in standard Ruby syntax. Rake has the following features: * Rakefiles (rake's version of Makefiles) are completely defined in standard Ruby syntax. No XML files to edit. No quirky Makefile syntax to worry about (is that a tab or a space?) * Users can specify tasks with prerequisites. * Rake supports rule patterns to synthesize implicit tasks. * Flexible FileLists that act like arrays but know about manipulating file names and paths. * A library of prepackaged tasks to make building rakefiles easier. For example, tasks for building tarballs and publishing to FTP or SSH sites. (Formerly tasks for building RDoc and Gems were included in rake but they're now available in RDoc and RubyGems respectively.) * Supports parallel execution of tasks.

This dependency is up-to-date. Congrats and keep going!

Gems stringex ~> 1.3 2.5.2

stringex

Some [hopefully] useful extensions to Ruby's String class. Stringex is made up of three libraries: ActsAsUrl [permalink solution with better character translation], Unidecoder [Unicode to ASCII transliteration], and StringExtensions [miscellaneous helper methods for the String class].

This dependency is not matching latest version. Please consider upgrading.

Gems tzinfo ~> 0.3 1.1.0

tzinfo

TZInfo provides daylight savings aware transformations between times in different time zones.

This dependency is not matching latest version. Please consider upgrading.

Gems will_paginate ~> 3.0 3.0.5

will_paginate

will_paginate provides a simple API for performing paginated queries with Active Record, DataMapper and Sequel, and includes helpers for rendering pagination links in Rails, Sinatra and Merb web apps.

This dependency is up-to-date. Congrats and keep going!

Package Locked Requirement Latest Status Changelog
Gems autotest-rails >= 0 4.2.1

autotest-rails

This is an autotest plugin to provide rails support. It provides basic rails support and extra plugins for migrations and fixtures.

This dependency is up-to-date. Congrats and keep going!

Gems capybara ~> 2.1 2.2.1

capybara

Capybara is an integration testing tool for rack based web applications. It simulates how a user would interact with a website

This dependency is up-to-date. Congrats and keep going!

Gems cucumber-rails ~> 1.4 1.4.0

cucumber-rails

Cucumber Generator and Runtime for Rails

This dependency is up-to-date. Congrats and keep going!

Gems database_cleaner ~> 1.1 1.2.0

database_cleaner

Strategies for cleaning databases. Can be used to ensure a clean state for testing.

This dependency is up-to-date. Congrats and keep going!

Gems factory_girl ~> 4.2 4.4.0

factory_girl

factory_girl provides a framework and DSL for defining and using factories - less error-prone, more explicit, and all-around easier to work with than fixtures.

This dependency is up-to-date. Congrats and keep going!

Gems mysql >= 0 2.9.1

mysql

This is the MySQL API module for Ruby. It provides the same functions for Ruby programs that the MySQL C API provides for C programs. This package is offered as gem for easy installation using RubyGems. It wraps unmodified tmtm's mysql-ruby extension into a proper gem. Please note that tmtm (Tomita Mashahiro) has deprecated development of this extension and only update it for bug fixes.

This dependency is up-to-date. Congrats and keep going!

Gems pg >= 0 0.17.1

pg

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 8.4 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

This dependency is up-to-date. Congrats and keep going!

Gems protected_attributes >= 0 1.0.7

protected_attributes

Protect attributes from mass assignment

This dependency is up-to-date. Congrats and keep going!

Gems pry-debugger >= 0 0.2.2

pry-debugger

Combine 'pry' with 'debugger'. Adds 'step', 'next', and 'continue' commands to control execution.

This dependency is up-to-date. Congrats and keep going!

Gems rails-observers >= 0 0.1.2

rails-observers

Rails observer (removed from core in Rails 4.0)

This dependency is up-to-date. Congrats and keep going!

Gems rspec ~> 2.14 2.14.1

rspec

BDD for Ruby

This dependency is up-to-date. Congrats and keep going!

Gems rspec-rails ~> 2.14 2.14.2

rspec-rails

RSpec for Rails

This dependency is up-to-date. Congrats and keep going!

Gems sqlite3 ~> 1.3 1.3.9

sqlite3

This module allows Ruby programs to interface with the SQLite3 database engine (http://www.sqlite.org). You must have the SQLite engine installed in order to build this module. Note that this module is only compatible with SQLite 3.6.16 or newer.

This dependency is up-to-date. Congrats and keep going!